当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : help....update from 5.10 to 6.06...but erro occured
帖子发表于 : 2006-05-26 15:33 

注册: 2006-05-24 19:22
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
i am really sorry that i do not know why i couldn`t write in chinese....
only english works in the typing ....

anyway.....my problem is..

i try to update from 5.10 to 6.06

but two error occured just now...i don`t know how to handle it....

-------------

gstreamer0.8-misc libwavpack0
下列【新】软件包将被安装:
libwavpack0
下列的软件包将被升级:
gstreamer0.8-misc
共升级了 1 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 371 个软件未被升级。
有 587 个软件包没有被完全安装或卸载。
需要下载 0B/1323kB 的软件包。
解压缩后会消耗掉 348kB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 66933 个文件和目录。)
正预备替换 gstreamer0.8-misc 0.8.11-0unofficialubuntu3 (使用 .../gstreamer0.8-misc_0.8.12-1ubuntu2_i386.deb) ...
正在解压缩将用于更替的包文件 gstreamer0.8-misc ...
dpkg:处理 /var/cache/apt/archives/gstreamer0.8-misc_0.8.12-1ubuntu2_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/gstreamer-0.8/libgstgoom.so”,它属于软件包 gstreamer0.8-visuals
dpkg-deb: 子进程 paste 被信号(断开的管道)终止了
dpkg:关于含有 libwavpack0 的 .../libwavpack0_4.32-2ubuntu2_i386.deb:
libwavpack0 冲突于 gstreamer0.8-misc (<< 0.8.12-1ubuntu2)
gstreamer0.8-misc (版本为 0.8.11-0unofficialubuntu3)现在 已安装完毕。
dpkg:处理 /var/cache/apt/archives/libwavpack0_4.32-2ubuntu2_i386.deb (--unpack)时出错:
软件包相互冲突 - 将不安装 libwavpack0
在处理时有错误发生:
/var/cache/apt/archives/gstreamer0.8-misc_0.8.12-1ubuntu2_i386.deb
/var/cache/apt/archives/libwavpack0_4.32-2ubuntu2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@SHRIMPY:/home/shrimpy# apt-get --purge remove gstreamer
-----------------------------------------------------------------------

4. 如果出现某个软件包冲突的错误,可以尝试先删除原有的包,比如这个gstreamer0.8-misc,总是出错,就可以先删除之: $ sudo apt-get --purge remove gstreamer0.8-misc

5. 如果某个包还是装不上,可以来点暴力的,方法如下: $ sudo dpkg -i --force-all /var/cache/apt/archives/gstreamer0.8-misc_0.8.12-1ubuntu1_i386.deb


i have already tried to remove gstreamer.......but ...after i have done the above ..


i type apt-get dist-upgrade
errors still there.........


最后由 shrimpy 编辑于 2006-05-26 15:37,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-05-26 15:36 

注册: 2006-05-24 19:22
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
root@SHRIMPY:/home/shrimpy# apt-get --purge remove gstreamer0.8-misc
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
gstreamer0.8-plugins: 依赖: gstreamer0.8-misc (>= 0.8.12) 但是它将不会被安装
gstreamer0.8-vorbis: 依赖: gstreamer0.8-misc (>= 0.8.12) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
root@SHRIMPY:/home/shrimpy#




root@SHRIMPY:/home/shrimpy# dpkg -i --force-all /var/cache/apt/archives/gstreamer0.8-misc_0.8.12-1ubuntu1_i386.deb
dpkg:处理 /var/cache/apt/archives/gstreamer0.8-misc_0.8.12-1ubuntu1_i386.deb (--install) 时出错:
无法访问打包文件: 没有那个文件或目录
在处理时有错误发生:
/var/cache/apt/archives/gstreamer0.8-misc_0.8.12-1ubuntu1_i386.deb


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-05-26 15:53 

注册: 2006-05-25 12:00
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
wo de shi
正在解压缩 slocate (从 .../slocate_3.0.beta.r3-1_amd64.deb) ...
Removing `diversion of /etc/cron.daily/find to /etc/cron.daily/find.notslocate by slocate'
dpkg-divert: rename involves overwriting `/etc/cron.daily/find' with
different file `/etc/cron.daily/find.notslocate', not allowed
dpkg:处理 /var/cache/apt/archives/slocate_3.0.beta.r3-1_amd64.deb (--unpack)时 出错:
子进程·pre-installation script·返回了错误号·2
在处理时有错误发生:
/var/cache/apt/archives/slocate_3.0.beta.r3-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


why?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-05-26 16:09 

注册: 2006-05-24 19:22
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
i have already gone over the problem..


base on your error...i think u could handle it in this way


$ sudo dpkg -i --force-all /var/cache/apt/archives/slocate_3.0.beta.r3-1_amd64.deb


just have a try...

wish u good luck


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-05-26 16:12 

注册: 2006-05-25 12:00
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
hai shi bu xing


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-05-26 17:14 

注册: 2006-05-24 19:22
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
我也帮不了你了。。。。。我刚玩ubuntu


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译