[讨论]gnome & emacs

为当前最终发行版之前的所有版本提供支持
回复
hannibal
帖子: 30
注册时间: 2005-06-13 18:37
送出感谢: 0
接收感谢: 0

[讨论]gnome & emacs

#1

帖子 hannibal » 2006-06-02 0:54

gnome下面的emacs还是无法把输入法弄出来,以前的版本就有这个问题,6.06好像没有修正。是和gnome-settings-daemon这个东西的冲突。有谁有办法解决吗?因为这个问题,我在上个版本中已经放弃gnome了。
头像
Tenyears
帖子: 2245
注册时间: 2005-06-30 15:46
来自: 成都
送出感谢: 0
接收感谢: 0

#2

帖子 Tenyears » 2006-06-02 9:29

搜一下。本坛duoxing贴出了解决方法
Humanity to others // 己所不欲,勿施与人
Laptop: ThinkPad X220 --- Win7 Home / Ubuntu 12.04
Desktop: Win7/Ubuntu 12.04
Server: Ubuntu12.04
hannibal
帖子: 30
注册时间: 2005-06-13 18:37
送出感谢: 0
接收感谢: 0

#3

帖子 hannibal » 2006-06-04 19:23

gbk编码的是没有问题,关键就是utf8+gnome+emacs问题就来了,而且搜了很多,没有解决方案。
railwaycat
帖子: 29
注册时间: 2006-01-21 16:05
送出感谢: 0
接收感谢: 0

#4

帖子 railwaycat » 2006-06-04 20:53

等着吧,这个东西目前还没有有效且不ugly的解决方案
网上所谓“完美解决”无非就是用各种方法使用gbk的locale。
觉得问题应该是出在emacs身上,可能是某个旷日持久且藏得够深的bug。想想编译emacs22时check out出来的单文件上万行的K&R C代码就知道RMS们有多痛苦了。
等吧……
不回灌水贴
不回可以google到答案的贴
不回“圣战”贴
补充中……
头像
forrest
帖子: 36
注册时间: 2005-11-13 1:51
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 forrest » 2006-06-11 23:47

用 emacs 就不能用 utf8 ?? 不是吧!
.
.
.
Stupid is as stupid does.

AMD Sempron 2500+ 64-bits
Asrock K8NF4G-SATA2 (GeForce6100+nForce 410 chipsets)
railwaycat
帖子: 29
注册时间: 2006-01-21 16:05
送出感谢: 0
接收感谢: 0

#6

帖子 railwaycat » 2006-06-12 0:25

可以用eim嘛,正宗的emacs下的智能拼音:)
不回灌水贴
不回可以google到答案的贴
不回“圣战”贴
补充中……
回复

回到 “老旧版本支持”