如何在Ubuntu 6中安装stardict

为当前最终发行版之前的所有版本提供支持
回复
kuerbt
帖子: 305
注册时间: 2006-04-13 13:53
送出感谢: 0
接收感谢: 1 次

如何在Ubuntu 6中安装stardict

#1

帖子 kuerbt » 2006-06-02 16:11

第一时间内安装好了Ubuntu 6,但是却找不到stardict。
是因为没有设置cn99的源吗?

论坛中好像有xdjm说cn99的源支持ubuntu 6好像不行。
高手进来指点一下 :x
kuerbt
帖子: 305
注册时间: 2006-04-13 13:53
送出感谢: 0
接收感谢: 1 次

#2

帖子 kuerbt » 2006-06-02 16:54

自己动手,丰衣足食。

依照 http://wiki.ubuntu.org.cn/%E5%BF%AB%E9% ... 7%E5%8D%97
设置cn99的源
deb http://ubuntu.cn99.com/ubuntu/ dapper main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-backports main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ dapper main restricted universe multiverse

安装stardict的包:
sudo apt-get install stardict stardict-common stardict-cdict-gb stardict-cedict-gb stardict-hanzim stardict-langdao-ce-gb stardict-langdao-ec-gb stardict-oxford-gb stardict-xdict-ce-gb stardict-xdict-ec-gb

可惜,只有stardict, stardict-common两个包,其他的包都找不到。

高手指点一下。
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 karron » 2006-06-02 17:40

到http://ftp.ubuntu.org.cn下载字典.或者到stardict.sf.net下载字典,stardict.sf.net上有安装指南
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
kuerbt
帖子: 305
注册时间: 2006-04-13 13:53
送出感谢: 0
接收感谢: 1 次

#4

帖子 kuerbt » 2006-06-02 17:44

安装JDK的包倒是比较容易
apt-get install sun-java5-jdk

export JAVA_HOME=/usr/lib/jvm/java-1.5.0-sun-1.5.0.06
export PATH=${JAVA_HOME}/bin:${JAVA_HOME}/jre/bin:${PATH}
头像
Bailuhuaxiang
帖子: 96
注册时间: 2006-03-24 18:27
送出感谢: 0
接收感谢: 0

#5

帖子 Bailuhuaxiang » 2006-06-03 1:57

可以和breezy的源混用安装stardict,我都是这么装字典和w32codecs的
Ubuntu Dapper& Windows 2003 SP1
AMD Athlon XP 1800+
Asus A7V8X-X
Geforce2 mx400
Kingmax DDR400 256M+Adata DDR400 512
Seagate 80G+ 60G
LG T710S
shooter
帖子: 56
注册时间: 2005-04-13 21:04
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 shooter » 2006-06-03 2:01

Dapper的源可以安装~
Get busy living, or get busy dying.
lisir
帖子: 1187
注册时间: 2006-04-29 14:54
来自: 山东
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 lisir » 2006-06-03 8:03

我通过下载RPM包倒是装上了,但是无法使用,在终端执行,说是找不到GLIBC2.4, 我在新立得中找了一下,但没有,这怎么办呢?
kuerbt
帖子: 305
注册时间: 2006-04-13 13:53
送出感谢: 0
接收感谢: 1 次

#8

帖子 kuerbt » 2006-06-03 9:49

我投机取巧了一下。

同事的5.10上的stardict可以工作,我的6.06上的两个基本包安装好了,只是没有字典。于是,将同事的/usr/share/stardict/dic目录的内容拷贝到我的机器上,重新启动一下,就可以使用了。
kuerbt
帖子: 305
注册时间: 2006-04-13 13:53
送出感谢: 0
接收感谢: 1 次

#9

帖子 kuerbt » 2006-06-03 9:51

请问一下, 6.06上的w32codecs不是缺省安装好的吗?
如果需要手工安装,需要装哪些包?
Bailuhuaxiang 写了:可以和breezy的源混用安装stardict,我都是这么装字典和w32codecs的
synweb
帖子: 19
注册时间: 2006-06-04 1:04
来自: 江苏
送出感谢: 0
接收感谢: 0

#10

帖子 synweb » 2006-06-06 2:51

交大源里就有阿
kuerbt
帖子: 305
注册时间: 2006-04-13 13:53
送出感谢: 0
接收感谢: 1 次

#11

帖子 kuerbt » 2006-06-06 8:54

哦,
我没有设置交大的源
我在公司里,不知道连接到校园网会不会很慢?
回复

回到 “老旧版本支持”