ubuntu中如何编译c和c++?

为当前最终发行版之前的所有版本提供支持
回复
zhjyl
帖子: 7
注册时间: 2006-05-27 9:13
送出感谢: 0
接收感谢: 0
联系:

ubuntu中如何编译c和c++?

#1

帖子 zhjyl » 2006-06-02 16:44

如题。
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 karron » 2006-06-02 17:22

sudo apt-get install build-essential

安装编译环境
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
arrowapex
帖子: 4
注册时间: 2006-06-02 14:09
送出感谢: 0
接收感谢: 0

#3

帖子 arrowapex » 2006-06-03 16:09

先安装gcc和g++
然后用gcc [filename]就可以编译了
fucj
帖子: 78
注册时间: 2006-05-04 12:02
送出感谢: 0
接收感谢: 0

#4

帖子 fucj » 2006-06-03 16:38

我运行了sudo命令出现如下情况,如何解决?请高手帮忙!!


正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: gcc (>= 4:4.0) 但是它将不会被安装
依赖: g++ (>= 4:4.0) 但是它将不会被安装
依赖: make 但是它将不会被安装
依赖: dpkg-dev (>= 1.13.5) 但是它将不会被安装
gstreamer0.8-plugins: 依赖: gstreamer0.8-visuals (>= 0.8.11) 但是它将不会被安 装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 karron » 2006-06-03 16:40

sudo apt-get update
sudo apt-get dist-upgrade

先。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
jnwysh
帖子: 376
注册时间: 2006-04-25 17:07
送出感谢: 0
接收感谢: 0

#6

帖子 jnwysh » 2006-06-04 9:43

确实如此
回复

回到 “老旧版本支持”