不能用rpm命令???

为当前最终发行版之前的所有版本提供支持
回复
zhjyl
帖子: 7
注册时间: 2006-05-27 9:13
送出感谢: 0
接收感谢: 0
联系:

不能用rpm命令???

#1

帖子 zhjyl » 2006-06-02 16:59

我装的是ubuntu5.01版本,上网下载了一些软件,结果发现*.rpm格式的软件怎么安装?
我用rpm -ivh 软件名,提示说不存在rpm这个命令,是什么原因?
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 karron » 2006-06-02 17:25

在ubuntu中请忘掉rpm.ubuntu中有更好的包管理工具.你要安装什么软件,只需要打开新立得,在里面搜索并安装就好了.如果你知道确切的软件名,也可以执行命令 sudo apt-get install xxx 来安装.

不过要注意的是,请按照主页wiki中第一次设置指南里面设置好source.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
tcs
帖子: 141
注册时间: 2006-04-06 13:51
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 tcs » 2006-06-02 21:03

ubuntu是基于debian的系统,
支持deb包。
mimihu88
帖子: 551
注册时间: 2006-04-03 11:26
送出感谢: 0
接收感谢: 1 次

#4

帖子 mimihu88 » 2006-06-02 23:41

用这个命令安装rpm格式的包

sudo alien -i xxx(软件名).rpm

如果没有安装alien,先sudo apt-get install alien

有些rpm包即使安装了也不一定能用
g2.0
帖子: 110
注册时间: 2005-06-09 21:30
来自: 河南
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 g2.0 » 2006-06-03 11:20

rpm的依赖性我想短期内是不能解决的
所以喜欢deb
jnwysh
帖子: 376
注册时间: 2006-04-25 17:07
送出感谢: 0
接收感谢: 0

#6

帖子 jnwysh » 2006-06-04 20:36

karron 写了:在ubuntu中请忘掉rpm.ubuntu中有更好的包管理工具.你要安装什么软件,只需要打开新立得,在里面搜索并安装就好了.如果你知道确切的软件名,也可以执行命令 sudo apt-get install xxx 来安装.

不过要注意的是,请按照主页wiki中第一次设置指南里面设置好source.
如何设置source?
aieiui
帖子: 43
注册时间: 2006-06-01 9:42
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 aieiui » 2006-06-04 21:07

jnwysh 写了:
karron 写了:在ubuntu中请忘掉rpm.ubuntu中有更好的包管理工具.你要安装什么软件,只需要打开新立得,在里面搜索并安装就好了.如果你知道确切的软件名,也可以执行命令 sudo apt-get install xxx 来安装.

不过要注意的是,请按照主页wiki中第一次设置指南里面设置好source.
如何设置source?
http://wiki.ubuntu.org.cn/%E5%BF%AB%E9% ... 7%E5%8D%97
回复

回到 “老旧版本支持”