6.06安装好后进不了图形界面

为当前最终发行版之前的所有版本提供支持
回复
weigangme
帖子: 34
注册时间: 2006-05-22 23:16
来自: 湖北武汉
送出感谢: 0
接收感谢: 0
联系:

6.06安装好后进不了图形界面

#1

帖子 weigangme » 2006-06-02 19:35

ubuntu-6.06-alternate-i386.iso装好后进不了图形界面
运行 startx 说 : no screens print

我的xorg.conf

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "ATI Technologies, Inc. Radeon X700 SE (RV410)"
Driver "ati"
BusID "PCI:5:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. Radeon X700 SE (RV410)"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection



我的配置如下;
昂达 NF4S (NF4X芯片)
WD 80G SATA
七彩虹 X550XT
闪龙 2800+(64)
AOC 786P[/code]
windforest
帖子: 53
注册时间: 2005-12-13 20:56
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 windforest » 2006-06-02 19:50

装了ati驱动没?
weigangme
帖子: 34
注册时间: 2006-05-22 23:16
来自: 湖北武汉
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 weigangme » 2006-06-02 21:42

没有 , 刚装的系统,还没进去过

会不会是显示器的问题啊?

在文本模式下输入:
sudo gedit /etc/X11/xorg.conf
输出的是:
no dispaly found :(NULL)
weigangme
帖子: 34
注册时间: 2006-05-22 23:16
来自: 湖北武汉
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 weigangme » 2006-06-03 16:37

问题解决了一半,把
Section "Device"
Identifier "ATI Technologies, Inc. Radeon X700 SE (RV410)"
Driver "ati"
BusID "PCI:5:0:0"
EndSection

该成

Section "Device"
Identifier "ATI Technologies, Inc. Radeon X700 SE (RV410)"
Driver "vesa"
BusID "PCI:5:0:0"
EndSection

可以进X,但还是有个问题,就是分辨率老是为1600*1200,不能改。
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 karron » 2006-06-03 16:51

把xorg.conf中高的分辨率删掉。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
回复

回到 “老旧版本支持”