正式版ATI驱动问题!

为当前最终发行版之前的所有版本提供支持
shuaiant
帖子: 33
注册时间: 2005-05-04 19:51
送出感谢: 0
接收感谢: 0

正式版ATI驱动问题!

#1

帖子 shuaiant » 2006-06-03 0:55

今天重新安装了正式版.按照下面步骤安装ati驱动.
sudo apt-get update
sudo apt-get install linux-restricted-modules-$(uname -r)
sudo apt-get install xorg-driver-fglrx
sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

$ fglrxinfo
竟然也出现了下面这种错误.
[fglrx] API ERROR: could not register entrypoint for SelectTextureSGIS
[fglrx] API ERROR: could not register entrypoint for SelectTextureTransformSGIS
[fglrx] API ERROR: could not register entrypoint for ClientActiveVertexStreamATI[fglrx] API ERROR: could not register entrypoint for VertexBlendEnviATI
[fglrx] API ERROR: could not register entrypoint for VertexBlendEnvfATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2sATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2svATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2iATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2ivATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2fATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2fvATI

这是怎么回事啊?原来手动安装那个8.25.18 会出现上面那种错误,用源里的还能用,现在用源里的也不行了?
ati的驱动啊.怎么就这么费劲啊.
头像
ellickif
帖子: 58
注册时间: 2006-05-02 2:11
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 ellickif » 2006-06-03 1:24

我装新版的驱动也出了这样的问题,不过你只要把8.25.18完全卸载后再装源里的驱动就可以了。
shuaiant
帖子: 33
注册时间: 2005-05-04 19:51
送出感谢: 0
接收感谢: 0

#3

帖子 shuaiant » 2006-06-03 11:43

我这次没有装8.25.18的啊.用源里的也出这样的错误了啊.
macaco
帖子: 36
注册时间: 2006-04-13 11:22
送出感谢: 0
接收感谢: 0

#4

帖子 macaco » 2006-06-03 20:27

我也遇到了,也是全新安装后直接装驱动失败
头像
ellickif
帖子: 58
注册时间: 2006-05-02 2:11
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 ellickif » 2006-06-03 20:47

我是安装官方驱动的时候出现了这样的问题,正等待高手解决
顶一下吧:D
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#6

帖子 catinsnow » 2006-06-04 3:01

新版的驱动的r200系列显卡比如ATI9100支持有问题.在ATI网站上下载上一版本驱动,解压出libGL.so.1.2,替换掉/usr/lib/libGL.so.1.2既可.
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
头像
ellickif
帖子: 58
注册时间: 2006-05-02 2:11
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 ellickif » 2006-06-04 14:38

catinsnow 写了:新版的驱动的r200系列显卡比如ATI9100支持有问题.在ATI网站上下载上一版本驱动,解压出libGL.so.1.2,替换掉/usr/lib/libGL.so.1.2既可.
原来是这样啊,我的M9+好像就是RV200系列的
gtx
帖子: 172
注册时间: 2005-10-28 17:40
送出感谢: 0
接收感谢: 0

#8

帖子 gtx » 2006-06-04 15:39

http://www.ground-impact.com/libGL.so.1.2
在ubuntu官方论坛上找到的,可能要用代理
shuaiant
帖子: 33
注册时间: 2005-05-04 19:51
送出感谢: 0
接收感谢: 0

#9

帖子 shuaiant » 2006-06-04 16:08

gtx 写了:http://www.ground-impact.com/libGL.so.1.2
在ubuntu官方论坛上找到的,可能要用代理
下不下来啊,用哪个国家的代理?
gtx
帖子: 172
注册时间: 2005-10-28 17:40
送出感谢: 0
接收感谢: 0

#10

帖子 gtx » 2006-06-04 16:30

我把它上传了,见附件 :D
附件
libGL.so.1.2.tar.gz
(144.05 KiB) 下载 1213 次
macaco
帖子: 36
注册时间: 2006-04-13 11:22
送出感谢: 0
接收感谢: 0

#11

帖子 macaco » 2006-06-04 16:49

gtx 写了:我把它上传了,见附件 :D
十分感谢,用了它,我的9200卡成功安装了fglrx驱动,xgl也成功了
shuaiant
帖子: 33
注册时间: 2005-05-04 19:51
送出感谢: 0
接收感谢: 0

#12

帖子 shuaiant » 2006-06-04 16:59

万分感谢.m9000也成功了..
newbird
帖子: 30
注册时间: 2006-02-24 21:32
送出感谢: 0
接收感谢: 0

#13

帖子 newbird » 2006-06-23 13:33

好的,谢谢,解决了。
血色眼泪
帖子: 335
注册时间: 2005-12-27 21:15
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 血色眼泪 » 2006-06-24 22:49

Nvidia能用吗

大不了换显卡咯
tester
帖子: 25
注册时间: 2006-05-22 17:25
送出感谢: 0
接收感谢: 0

#15

帖子 tester » 2006-07-20 21:32

ellickif 写了:
catinsnow 写了:新版的驱动的r200系列显卡比如ATI9100支持有问题.在ATI网站上下载上一版本驱动,解压出libGL.so.1.2,替换掉/usr/lib/libGL.so.1.2既可.
原来是这样啊,我的M9+好像就是RV200系列的
这位大俠呀,俺和你的卡一样的,俺的是NX7000笔记本,卡是Mobility Radeon 9200,你成功驱动起3D了吗?

俺折腾N久,还是没装上~
回复

回到 “老旧版本支持”