当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 谁解决了gftp远程中文显示问题的把你的~/gftp/gftprc贴上来
帖子发表于 : 2005-07-31 13:52 

注册: 2005-07-28 15:08
帖子: 265
送出感谢: 0 次
接收感谢: 0 次
用设置远程字符集的方法实在是不能解决问题


所以我想看看是不是其他问题


(我怀疑和装的编码有关系)


_________________
无声胜有声


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-07-31 16:46 

注册: 2005-07-28 15:08
帖子: 265
送出感谢: 0 次
接收感谢: 0 次
还有,你们是不是装的由ajing99修改过的2。0。17版 的gftp

(用apt-get获取的都是2。0。18版 的)


_________________
无声胜有声


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-07-31 16:58 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
引用:
gftp不能进入中文目录和下载中文文件
是gtk2的问题,下载源码自己修改一下去掉gtk2的支持就行了。
我自己编译(rh7.2+gcc-3.2)的文件传到ftp.lib.pku.edu.cn了,包括修改好的src.rpm。
补充一下,gftp可以基于gtk2或者gtk1.2,用gtk1.2的话中文就没什么问题。
要使用gtk1.2,configure时加选项--disable-gtk20


是的。用apt-get获取的都是2。0。18版 的。我也没解决中文问题,不过我很少机会上带中文目录的FTP。


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-07-31 17:48 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
也可以试试
env LANG=zh_CN gftp
别人用kubuntu可以的,我也用,但还是不行。 :oops:


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-07-31 19:29 

注册: 2005-07-28 15:08
帖子: 265
送出感谢: 0 次
接收感谢: 0 次
没用

\u5728\u5c06\u5b57\u7b26\u4e32\u201cFashionWalker0604\u04fe\u05f0\uffff\uffff.rm\u201d\u4ece\u5b57\u7b26\u96c6 <\u672a\u77e5> \u8f6c\u6362\u6210\u5b57\u7b26\u96c6 UTF-8 \u65f6\u51fa\u9519\uff1a\u8f6c\u6362\u8f93\u5165\u4e2d\u51fa\u73b0\u65e0\u6548\u5b57\u7b26\u5e8f\u5217
\u5728\u5c06\u5b57\u7b26\u4e32\u201crav2005\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffffID.txt\u201d\u4ece\u5b57\u7b26\u96c6 <\u672a\u77e5> \u8f6c\u6362\u6210\u5b57\u7b26\u96c6 UTF-8 \u65f6\u51fa\u9519\uff1a\u8f6c\u6362\u8f93\u5165\u4e2d\u51fa\u73b0\u65e0\u6548\u5b57\u7b26\u5e8f\u5217
\u5728\u5c06\u5b57\u7b26\u4e32\u201c\uffff\uffff\uffff\uffff\u05f7\uffff\uffff12.06.rm\u201d\u4ece\u5b57\u7b26\u96c6 <\u672a\u77e5> \u8f6c\u6362\u6210\u5b57\u7b26\u96c6 UTF-8 \u65f6\u51fa\u9519\uff1a\u8f6c\u6362\u8f93\u5165\u4e2d\u51fa\u73b0\u65e0\u6548\u5b57\u7b26\u5e8f\u5217
\u5728\u5c06\u5b57\u7b26\u4e32\u201c\u02b5\uffff\uffff\uffff\uffff\u201d\u4ece\u5b57\u7b26\u96c6 <\u672a\u77e5> \u8f6c\u6362\u6210\u5b57\u7b26\u96c6 UTF-8 \u65f6\u51fa\u9519\uff1a\u8f6c\u6362\u8f93\u5165\u4e2d\u51fa\u73b0\u65e0\u6548\u5b57\u7b26\u5e8f\u5217

(gftp-gtk:14891): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(gftp-gtk:14891): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(gftp-gtk:14891): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(gftp-gtk:14891): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()


_________________
无声胜有声


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-08-01 15:32 

注册: 2005-07-28 12:27
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
要是想解决这个问题, 你得打完补丁之后自已编译一下!!!

sudo apt-get build-dep gftp
sudo apt-get source gftp
patch -Np1 < ../gftp_remote_charsets.patch
sudo debian/rules binary

cd ..
dpkg -i gftp* 用刚才编译的deb覆盖掉原来的就ok啦^^

然后你还得把这些gftp package锁定,不然的话sudo apt-get upgrade之后
又会变成打补丁前的version!!

ps : 按下图设置gftp


附件:
文件注释: option
gftp.png
gftp.png [ 46.1 KiB | 被浏览 1683 次 ]
文件注释: patch file
gftp_remote_charsets.patch.gz [8.15 KiB]
被下载 63 次
页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-08-01 19:43 

注册: 2005-07-28 15:08
帖子: 265
送出感谢: 0 次
接收感谢: 0 次
好麻烦。

这样,每次有新版本的时候,都要重新下载源码,重新编译


_________________
无声胜有声


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-08-02 10:45 

注册: 2005-07-28 12:27
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
zhuzhzh 写道:
好麻烦。

这样,每次有新版本的时候,都要重新下载源码,重新编译



也不算太复杂呀^^

这个补丁好像已经题交给gftp的维护者了, 希望在下个版本中修复这个bug~~


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-08-02 11:20 

注册: 2005-07-28 15:08
帖子: 265
送出感谢: 0 次
接收感谢: 0 次
kimsuelim 写道:
zhuzhzh 写道:
好麻烦。

这样,每次有新版本的时候,都要重新下载源码,重新编译



也不算太复杂呀^^

这个补丁好像已经题交给gftp的维护者了, 希望在下个版本中修复这个bug~~



那就好啊,我本来上那个官方开发网站想给他们提建议的,结果没找到发言的地方,HEHE


_________________
无声胜有声


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2005-08-06 14:16 
头像

注册: 2005-04-08 14:54
帖子: 310
送出感谢: 0 次
接收感谢: 0 次
我用2.0.18版,设为GBK就可以用了。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2005-08-06 14:23 

注册: 2005-03-28 0:48
帖子: 156
地址: 辽宁抚顺
送出感谢: 0 次
接收感谢: 0 次
用lftp多爽多方便啊,用这个gftp超级不稳定。 :(


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2005-08-06 14:36 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
不稳定倒不觉得。用过了好几个图形界面的FTP,最稳定算GFTP了。


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2005-08-06 14:46 

注册: 2005-03-28 0:48
帖子: 156
地址: 辽宁抚顺
送出感谢: 0 次
接收感谢: 0 次
yongyi 写道:
不稳定倒不觉得。用过了好几个图形界面的FTP,最稳定算GFTP了。

至今为止我未发现一个GNOME上比较好的图形界面的FTP软件,好的图形界面FTP软件都跑到KDE上去了。所以我才一直用lftp。

再说lftp挺好用的,虽然不是图形界面。但是文本不好用么?

一般就这几个命令就够用了

lftp 用户名:密码@地址

下载目录:mirror -c
下载文件:get或者pget(这个是多线程)


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2005-08-06 15:01 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
kde下的更不稳定啊,至少在我的kubuntu5.04 是这样,自己编译了一个KFTPGrabber 倒解决了什么乱码的问题了,但操作起来还是得小心翼翼的,操作快了点,又不见了 :P
我也喜欢lftp,但每次也要输入一长串的,有时也烦呀。
不过,这些也没什么好说的了,看个人喜好了。


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2005-08-06 18:01 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
我这边ftp中文不多,所以都是使用gnome的文件浏览器,加入bookmark。呵呵方便。密码直接存储在密钥环,呵呵都不用管了。


_________________
当净其意如虚空,远离妄想及诸取,令心所向皆无碍


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译