[问题]LumaQQ启动出错·[已解决]

为当前最终发行版之前的所有版本提供支持
回复
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

[问题]LumaQQ启动出错·[已解决]

#1

帖子 dbzhang800 » 2006-06-03 14:03

怎么办呢?请高手指点

dbzhang@xjtu-dbzhang:/usr/local/LumaQQ$ ./lumaqq
dbzhang@xjtu-dbzhang:/usr/local/LumaQQ$ Exception in thread "main" java.lang.NoClassDefFoundError: edu.tsinghua.lumaqq.qq.QQClient
at java.lang.Class.initializeClass(libgcj.so.7)
at edu.tsinghua.lumaqq.LumaQQ.main(LumaQQ.java:137)
Caused by: java.lang.ClassNotFoundException: java.util.Queue not found in gnu.gcj.runtime.SystemClassLoader{urls=[file:/usr/local/LumaQQ/lib/xerces.jar,file:/usr/local/LumaQQ/lib/swt.jar,file:/usr/local/LumaQQ/lib/poifs.jar,file:/usr/local/LumaQQ/lib/org.eclipse.ui.workbench_3.1.0.jar,file:/usr/local/LumaQQ/lib/org.eclipse.osgi_3.1.0.jar,file:/usr/local/LumaQQ/lib/org.eclipse.jface_3.1.0.jar,file:/usr/local/LumaQQ/lib/org.eclipse.emf.ecore.xmi_2.1.0.jar,file:/usr/local/LumaQQ/lib/org.eclipse.emf.ecore_2.1.0.jar,file:/usr/local/LumaQQ/lib/org.eclipse.emf.common_2.1.0.jar,file:/usr/local/LumaQQ/lib/org.eclipse.core.runtime_3.1.0.jar,file:/usr/local/LumaQQ/lib/org.eclipse.core.resources_3.1.0.jar,file:/usr/local/LumaQQ/lib/lumaqq_xsd.jar,file:/usr/local/LumaQQ/lib/lumaqq_template.jar,file:/usr/local/LumaQQ/lib/lumaqq.jar,file:/usr/local/LumaQQ/lib/log4j-1.2.8.jar,file:/usr/local/LumaQQ/lib/jql_protocol.jar,file:/usr/local/LumaQQ/lib/jql_net.jar,file:/usr/local/LumaQQ/lib/je.jar,file:/usr/local/LumaQQ/lib/jdom.jar,file:/usr/local/LumaQQ/lib/commons-logging.jar,file:/usr/local/LumaQQ/lib/commons-codec.jar,file:./], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
at java.net.URLClassLoader.findClass(libgcj.so.7)
at java.lang.ClassLoader.loadClass(libgcj.so.7)
at java.lang.ClassLoader.loadClass(libgcj.so.7)
at java.lang.Class.initializeClass(libgcj.so.7)
...1 more
上次由 dbzhang800 在 2006-06-03 16:55,总共编辑 1 次。
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 karron » 2006-06-03 14:05

安装java1.5
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#3

帖子 dbzhang800 » 2006-06-03 14:58

装了,不管用

我是昨天从5.10升级到6.06的,然后lumaqq就不能能用了
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 karron » 2006-06-03 15:12

java -version
看看你的版本。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#5

帖子 dbzhang800 » 2006-06-03 15:24

dbzhang@xjtu-dbzhang:~$ java -version
java version "1.4.2"
gij (GNU libgcj) version 4.1.0 (Ubuntu 4.1.0-1ubuntu8)

Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 karron » 2006-06-03 15:50

sudo update-alternatives --config java

在显示的屏幕上出现
1 /usr/bin/gij-wrapper-4.0
*+ 2 /usr/lib/jvm/java-gcj/bin/java
3 /usr/lib/j2sdk1.5-sun/bin/java

选择 3 java1.5的版本。

就可以了。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
Vstar
帖子: 273
注册时间: 2005-10-03 14:13
来自: Tokushima, Japan
送出感谢: 0
接收感谢: 1 次
联系:

#7

帖子 Vstar » 2006-06-03 16:26

sudo apt-get install sun-java5-jre
sudo ln -sf /usr/lib/jvm/java-1.5.0-sun-1.5.0.06/jre/bin/java /usr/bin/java
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#8

帖子 dbzhang800 » 2006-06-03 16:54

karron 写了:sudo update-alternatives --config java

在显示的屏幕上出现
1 /usr/bin/gij-wrapper-4.0
*+ 2 /usr/lib/jvm/java-gcj/bin/java
3 /usr/lib/j2sdk1.5-sun/bin/java

选择 3 java1.5的版本。

就可以了。

谢谢,搞定了

我的选择5然后就好了
dbzhang@xjtu-dbzhang:~/work/Powell$ sudo update-alternatives --config java
Password:

There are 5 alternatives which provide `java'.

Selection Alternative
-----------------------------------------------
1 /usr/lib/j2re1.5-sun/bin/java
2 /usr/bin/gij-wrapper-4.0
3 /usr/bin/gij-wrapper-4.1
*+ 4 /usr/lib/jvm/java-gcj/jre/bin/java
5 /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
回复

回到 “老旧版本支持”