紧急问题,waiting for root system files

为当前最终发行版之前的所有版本提供支持
回复
LostWater
帖子: 33
注册时间: 2006-05-26 18:50
送出感谢: 0
接收感谢: 0

紧急问题,waiting for root system files

#1

帖子 LostWater » 2006-06-03 14:28

64位安装版,硬盘安装结束后,重启出现以下提示
waiting for root system files
卡在这儿,无法进入系统


尝试虚拟机安装后,重启虚拟机正常,但重启主机依然以上问题
xinye0123
帖子: 61
注册时间: 2006-01-10 13:36
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 xinye0123 » 2006-06-03 14:46

he wo yi yang ,ni de ying pan shi SATA de ba? yao geng gai /boot/grub/menu.lst he /etc/fstab,ba hdX gai cheng sdX, OK
LostWater
帖子: 33
注册时间: 2006-05-26 18:50
送出感谢: 0
接收感谢: 0

#3

帖子 LostWater » 2006-06-03 15:03

不是挺明白你的意思
我是双硬盘,一个sata,一个pata,ubuntu我是装在pata下的
然后用原有的grub手动添加引导的

fstab下hdx,sdx信息都有,我自己看也没错

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1
/dev/hda10 /media/hda10 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/hda5 /media/hda5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/hda7 /media/hda7 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/hda8 /media/hda8 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/hda9 /media/hda9 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sda1 /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sda10 /media/sda10 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sda5 /media/sda5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sda6 /media/sda6 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sda7 /media/sda7 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sda8 /media/sda8 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sda9 /media/sda9 vfat defaults,utf8,umask=007,gid=46 0 1
/dev/hda6 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
LostWater
帖子: 33
注册时间: 2006-05-26 18:50
送出感谢: 0
接收感谢: 0

#4

帖子 LostWater » 2006-06-03 15:05

root (hd1,0)
kernel /vmlinuz
initrd /initrd.img

这是我的grub命令
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2006-06-03 15:23

你把sata的卸掉试试。
● 鸣学
LostWater
帖子: 33
注册时间: 2006-05-26 18:50
送出感谢: 0
接收感谢: 0

#6

帖子 LostWater » 2006-06-03 15:30

eexpress 写了:你把sata的卸掉试试。
grub从sata引导的
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#7

帖子 eexpress » 2006-06-03 16:11

啊。重安装grub罗。
● 鸣学
LostWater
帖子: 33
注册时间: 2006-05-26 18:50
送出感谢: 0
接收感谢: 0

#8

帖子 LostWater » 2006-06-03 18:18

没有其他办法吗,sata我想保留
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#9

帖子 eexpress » 2006-06-03 19:34

按照道理。grub的menu.list很容易设置的。
你对一下里面的设置就是了。前面我是假定你核对无错误的。
或者是64位的问题?这个不确定,因为没用64位的。
● 鸣学
LostWater
帖子: 33
注册时间: 2006-05-26 18:50
送出感谢: 0
接收感谢: 0

#10

帖子 LostWater » 2006-06-03 20:39

root (hd1,0)
kernel /vmlinuz
initrd /initrd.img

第二硬盘,第一主分区,没错啊,也能进ubuntu引导
只是卡住了
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#11

帖子 eexpress » 2006-06-03 20:45

你的menu.list这么简单的?自己写的?

title Ubuntu, kernel 2.6.15-21-686
root (hd0,2)
kernel /boot/vmlinuz-2.6.15-21-686 root=/dev/hda3 ro quiet splash
initrd /boot/initrd.img-2.6.15-21-686
savedefault
boot
● 鸣学
LostWater
帖子: 33
注册时间: 2006-05-26 18:50
送出感谢: 0
接收感谢: 0

#12

帖子 LostWater » 2006-06-03 21:28

谢谢,加上了句
root=/dev/hda1 ro quiet splash
可以启动了

可是一进去就是花屏
是不是分辨率太高了1280*1024


有办法启动前改吗
xinye0123
帖子: 61
注册时间: 2006-01-10 13:36
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 xinye0123 » 2006-06-07 11:48

进安全模式改xorg.conf
回复

回到 “老旧版本支持”