当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 紧急问题,waiting for root system files
帖子发表于 : 2006-06-03 14:28 

注册: 2006-05-26 18:50
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
64位安装版,硬盘安装结束后,重启出现以下提示
waiting for root system files
卡在这儿,无法进入系统


尝试虚拟机安装后,重启虚拟机正常,但重启主机依然以上问题


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-06-03 14:46 

注册: 2006-01-10 13:36
帖子: 61
送出感谢: 0 次
接收感谢: 0 次
he wo yi yang ,ni de ying pan shi SATA de ba? yao geng gai /boot/grub/menu.lst he /etc/fstab,ba hdX gai cheng sdX, OK


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-06-03 15:03 

注册: 2006-05-26 18:50
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
不是挺明白你的意思
我是双硬盘,一个sata,一个pata,ubuntu我是装在pata下的
然后用原有的grub手动添加引导的

fstab下hdx,sdx信息都有,我自己看也没错

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1
/dev/hda10 /media/hda10 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/hda5 /media/hda5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/hda7 /media/hda7 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/hda8 /media/hda8 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/hda9 /media/hda9 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sda1 /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sda10 /media/sda10 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sda5 /media/sda5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sda6 /media/sda6 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sda7 /media/sda7 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sda8 /media/sda8 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sda9 /media/sda9 vfat defaults,utf8,umask=007,gid=46 0 1
/dev/hda6 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-06-03 15:05 

注册: 2006-05-26 18:50
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
root (hd1,0)
kernel /vmlinuz
initrd /initrd.img

这是我的grub命令


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-06-03 15:23 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
你把sata的卸掉试试。


_________________
● 鸣学


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-06-03 15:30 

注册: 2006-05-26 18:50
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
你把sata的卸掉试试。
grub从sata引导的


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-06-03 16:11 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
啊。重安装grub罗。


_________________
● 鸣学


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-06-03 18:18 

注册: 2006-05-26 18:50
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
没有其他办法吗,sata我想保留


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-06-03 19:34 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
按照道理。grub的menu.list很容易设置的。
你对一下里面的设置就是了。前面我是假定你核对无错误的。
或者是64位的问题?这个不确定,因为没用64位的。


_________________
● 鸣学


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-06-03 20:39 

注册: 2006-05-26 18:50
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
root (hd1,0)
kernel /vmlinuz
initrd /initrd.img

第二硬盘,第一主分区,没错啊,也能进ubuntu引导
只是卡住了


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-06-03 20:45 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
你的menu.list这么简单的?自己写的?

title Ubuntu, kernel 2.6.15-21-686
root (hd0,2)
kernel /boot/vmlinuz-2.6.15-21-686 root=/dev/hda3 ro quiet splash
initrd /boot/initrd.img-2.6.15-21-686
savedefault
boot


_________________
● 鸣学


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-06-03 21:28 

注册: 2006-05-26 18:50
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
谢谢,加上了句
root=/dev/hda1 ro quiet splash
可以启动了

可是一进去就是花屏
是不是分辨率太高了1280*1024


有办法启动前改吗


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2006-06-07 11:48 

注册: 2006-01-10 13:36
帖子: 61
送出感谢: 0 次
接收感谢: 0 次
进安全模式改xorg.conf


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译