something wrong about my scim

为当前最终发行版之前的所有版本提供支持
回复
bdahz
帖子: 8
注册时间: 2006-02-03 20:03
送出感谢: 0
接收感谢: 0

something wrong about my scim

#1

帖子 bdahz » 2006-06-03 20:34

i hate scim,so i remove scim by "sudo apt-get remove scim"
and install fcitx by"sudo apt-get install fcitx"
but now fcitx doesn't work, what is worse, when i click on anthing in "Select Input Method" in the pop-menu of a text editor or terminal, it will exit.

what can i do now ?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-06-03 20:41

$ l /etc/X11/xinit/xinput.d/
ja_JP@ none@ scim-anthy@ scim.dpkg-dist@ scim-pinyin@ zh_CN@ zh_SG@
ko_KR@ scim scim-chewing@ scim-hangul@ scim_xim zh_HK@ zh_TW@

看里面的scim还是fcitx
● 鸣学
bdahz
帖子: 8
注册时间: 2006-02-03 20:03
送出感谢: 0
接收感谢: 0

#3

帖子 bdahz » 2006-06-03 20:45

$ cd /etc/X11/xinit/xinput.d/
$ ls
fcitx none scim-chewing scim-pinyin~ zh_CN
ja_JP scim scim-pinyin scim_xim
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2006-06-03 20:46

文件里面的设置。比如zh_CN。里面的项目
● 鸣学
bdahz
帖子: 8
注册时间: 2006-02-03 20:03
送出感谢: 0
接收感谢: 0

#5

帖子 bdahz » 2006-06-03 20:48

$ cat zh_CN
XIM=fcitx
XIM_PROGRAM=/usr/bin/fcitx
XIM_ARGS=""
GTK_IM_MODULE=XIM
QT_IM_MODULE=XIM
DEPENDS="fcitx"
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2006-06-03 20:57

是这样的。
那只能终端运行gedit xxx看提示了。
● 鸣学
bdahz
帖子: 8
注册时间: 2006-02-03 20:03
送出感谢: 0
接收感谢: 0

#7

帖子 bdahz » 2006-06-03 21:05

$ gedit xxx

(gedit:7276): Gdk-WARNING **: locale not supported by Xlib

(gedit:7276): Gdk-WARNING **: cannot set locale modifiers



wei shenme yao qu kan gedit de tishi?
you shenme yong ma?

haiyou, zaixie scim shi bu shi only"sudo apt-get remove scim", qita de yaobuyao zaixie?
xiang "im-switch"de yao bu yao zaixie? ruguo yao zaixie, hai yin gai zaixie shenme ?
回复

回到 “老旧版本支持”