[问题]有人在6.06下成功装上ATI的驱动吗?

为当前最终发行版之前的所有版本提供支持
回复
weigangme
帖子: 34
注册时间: 2006-05-22 23:16
来自: 湖北武汉
送出感谢: 0
接收感谢: 0
联系:

[问题]有人在6.06下成功装上ATI的驱动吗?

#1

帖子 weigangme » 2006-06-04 19:45

有谁成功装上了ATI驱动的能出来分享一 下吗?
我看了下。好多人都碰到问题了,我是新手所以不敢乱来
请高手指条明路。
macaco
帖子: 36
注册时间: 2006-04-13 11:22
送出感谢: 0
接收感谢: 0

#2

帖子 macaco » 2006-06-04 20:18

按照这个wiki的文章来装吧
https://wiki.ubuntu.com/BinaryDriverHow ... C%28ati%29

代码: 全选

sudo apt-get update 
sudo apt-get install linux-restricted-modules-$(uname -r) 
sudo apt-get install xorg-driver-fglrx 
sudo aticonfig --initial 
sudo aticonfig --overlay-type=Xv 
在终端输入fglrxinfo查看驱动信息。正常的话你会看到类似下面的信息:

代码: 全选

$ fglrxinfo 
display: :0.0  screen: 0 
OpenGL vendor string: ATI Technologies Inc. 
OpenGL renderer string: RADEON 9200 Generic 
OpenGL version string: 2.0.5755 (8.24.8) 
若出现以下错误提示信息:

代码: 全选

$ fglrxinfo 
[fglrx] API ERROR: could not register entrypoint for SelectTextureSGIS 
[fglrx] API ERROR: could not register entrypoint for SelectTextureTransformSGIS 
[fglrx] API ERROR: could not register entrypoint for ClientActiveVertexStreamATI[fglrx] API ERROR: could not register entrypoint for VertexBlendEnviATI 
[fglrx] API ERROR: could not register entrypoint for VertexBlendEnvfATI 
[fglrx] API ERROR: could not register entrypoint for VertexStream2sATI 
[fglrx] API ERROR: could not register entrypoint for VertexStream2svATI 
[fglrx] API ERROR: could not register entrypoint for VertexStream2iATI 
[fglrx] API ERROR: could not register entrypoint for VertexStream2ivATI 
[fglrx] API ERROR: could not register entrypoint for VertexStream2fATI 
[fglrx] API ERROR: could not register entrypoint for VertexStream2fvATI
......
则可能你用的是r200系列显卡,比如我的ATI9200就遇到这个问题了。
此时到viewtopic.php?t=16555的10楼下载libGL.so.1.2文件download.php?id=3933,覆盖掉/usr/lib/libGL.so.1.2既可。
头像
interskh
帖子: 203
注册时间: 2005-11-16 10:42
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 interskh » 2006-06-04 21:01

我装的时候碰到了一些问题,现在好了
进不了X就dpkg-reconfigure xorg-server一下
基本上不会有什么危险的
redhairboy
帖子: 38
注册时间: 2006-03-07 0:37
送出感谢: 0
接收感谢: 0

#4

帖子 redhairboy » 2006-06-05 16:50

我的9550安装很顺利
weigangme
帖子: 34
注册时间: 2006-05-22 23:16
来自: 湖北武汉
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 weigangme » 2006-06-05 19:35

谢谢各位
去试一下。
试了一下
输出如下:
weigang@ubuntu:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)

清问这是不是正常的阿
我的显卡是X550XT的
头像
interskh
帖子: 203
注册时间: 2005-11-16 10:42
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 interskh » 2006-06-05 22:08

恩,应该是没有装上
jerome
帖子: 1
注册时间: 2006-06-03 19:44
送出感谢: 0
接收感谢: 0

#7

帖子 jerome » 2006-06-06 21:24

安装对应两个包,apt源上都有,前面的朋友也讲得很详细了。
运行命令:sudo dpkg-reconfigure xorg-server
设置界面中驱动选择fglrx(关键),重启系统(印象中光重启X是没有效果的);
如果是宽屏或高分辨率的话,分辨率如果变回800x600,重新运行上述命令改一下分辨率就行了。
PS:我选用fglrx重启之后,运行上述命令配置分辨率的时候,发现会在设置界面的自动探测显示器类型时死机,如果你也碰到类似情况,就不要自动探测了。
tony21921
帖子: 25
注册时间: 2006-06-05 10:27
送出感谢: 0
接收感谢: 0

#8

帖子 tony21921 » 2006-06-08 23:05

我的9550,装了驱动之后
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)

重启也没有用,重装也没有用。有没有人遇到过啊?怎么处理呢?
Jeremy
帖子: 224
注册时间: 2005-11-08 10:12
送出感谢: 0
接收感谢: 0

#9

帖子 Jeremy » 2006-06-09 13:22

我和你一样的显卡.
我前面已经写过了相关的安装问题了。
你还要安装fglrx-kernel-source,以及核心对应的模块包。
回复

回到 “老旧版本支持”