一個前freebsd使用者問關於apt-get的問題

为当前最终发行版之前的所有版本提供支持
回复
ED209
帖子: 10
注册时间: 2006-06-01 17:13
送出感谢: 0
接收感谢: 0

一個前freebsd使用者問關於apt-get的問題

#1

帖子 ED209 » 2006-06-05 10:37

我以前是用freebsd的,但ubuntu6.06的確很好用,所以做了叛徒 :D
在freebsd上的套件源"ports"每天也有更新,不知道ubuntu上那個套件源的更新會否比較慢?
我應該如何查看系統內安裝了甚麼套件和源裡有甚麼選擇呢? 最好看到是甚麼版本吧。
來自不同地區的源有沒有分別? 會否有不一致的情況發生?
freebsd有一個很好的工具,可以彩排安裝和卸載套件,免除很多麻煩,不知道ubuntu可以嗎?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-06-05 10:41

apt的很好哦。安装卸载很方便。图像界面用新立得包管理。和升级管理器。
apt-get install
apt-get remove --purge
apt-cache search 查软件,用perlreg的,或者reg表达式。

我用的多的就这几个。
alias ag='sudo apt-get upgrade'
alias ai='sudo apt-get install'
alias ar='sudo apt-get remove'
alias as='apt-cache search'
alias au='sudo apt-get update'

更新也多,我都烦了。1,2天就更新。
:lol:
● 鸣学
ED209
帖子: 10
注册时间: 2006-06-01 17:13
送出感谢: 0
接收感谢: 0

#3

帖子 ED209 » 2006-06-05 11:31

eexpress 写了:apt的很好哦。安装卸载很方便。图像界面用新立得包管理。和升级管理器。
apt-get install
apt-get remove --purge
apt-cache search 查软件,用perlreg的,或者reg表达式。

我用的多的就这几个。
alias ag='sudo apt-get upgrade'
alias ai='sudo apt-get install'
alias ar='sudo apt-get remove'
alias as='apt-cache search'
alias au='sudo apt-get update'

更新也多,我都烦了。1,2天就更新。
:lol:
請問那裡的源會比較多比較新?還是通通一樣?
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

#4

帖子 Element » 2006-06-05 12:15

每个源里的东西都是一样的,不过有的同步会慢一点,2,3的差别吧。
只要你找到你最快的源就可以咯。
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
kisswen
帖子: 62
注册时间: 2006-03-22 17:52
送出感谢: 0
接收感谢: 0

#5

帖子 kisswen » 2006-06-05 12:51

源其实就是一个提供ubuntu软件下载的服务器吧?
呵呵
我这样理解的
刚开始用的唆
请大家多指教
ED209
帖子: 10
注册时间: 2006-06-01 17:13
送出感谢: 0
接收感谢: 0

#6

帖子 ED209 » 2006-06-05 13:12

多問一個問題
如果用sudo apt-get upgrade去升級大型套件,例如firefox和gnome等,會有系統不穩要重灌的可能嗎?
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 karron » 2006-06-05 15:02

一般官方源里的东西都是比较稳定的. 如果出现bug一般过不了多久就会升级修补好的.

另外,ubuntu的发布一般是随着gnome的稳定版发布一起发布的.比如5.10是2.10,现在的6.06是2.12,可能6.10就是2.14的gnome了.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
回复

回到 “老旧版本支持”