当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 网卡可以正常工作但无法通过路由器上网?[OK!]
帖子发表于 : 2006-06-05 16:38 
头像

注册: 2005-05-11 17:36
帖子: 92
地址: 四川南充
送出感谢: 0 次
接收感谢: 0 次
问题:无法通过路由器上网?

路由器设置为自动分配IP地址,联了两台机器(acer 5022 和 P4 NorthWood)都是xp和i386-ubuntu 6.06双启动

在ubuntu系统中acer无法上网但那台P4上网正常

我以为是硬件支持的问题于是把acer直接联在ADSL上结果上网正常,可见网卡可以正常工作

还有一个现象虽然acer无法通过路由器上网但是可以通过路由器使用P4 NorthWood上的共享文件夹且传输速度正常。

请问这是怎么回事应该怎样解决?


_________________
我和他人紧紧相连, 密不可分, 我们都在同一种生活之中.

[]Laptop: acer 5022 /AMD64/ati X600/1G/100G
OS: acer WinXp / Gentoo 2006.0 AMD64
[]Desktop:P4 2.4 NorthWood/SiS 651/521M/80G
OS: Xp.Pro.en / Ubuntu 6.06


最后由 杨珂 编辑于 2006-06-05 22:23,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-06-05 20:30 

注册: 2006-05-13 18:08
帖子: 75
送出感谢: 1
接收感谢: 0 次
我也碰到过这个问题,主要是DNS的问题,网址对应的IP地址找不到,后来从 "系统"-->"系统管理"-->"联网"看到 DNS 服务器中路由器的地址在最后一个, 就将地址改为手动分配(即不使用DHCP, 但掩码,网关什么的和原来一样,可以通过 ifconfig 看看现在的设置, 记下来手动填到对应的字段里面), 然后在 DNS 里面把路由器地址放在第一个, 就没有问题了.

BTW, 我用ADSL上网, 这个问题好象是某一天突然发生的, 所以我怀疑和电信做过什么调整有关.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-06-05 22:22 
头像

注册: 2005-05-11 17:36
帖子: 92
地址: 四川南充
送出感谢: 0 次
接收感谢: 0 次
glassprogrammer 写道:
主要是DNS的问题


谢谢提示,已经解决了。
问题就出在DNS上,我把192.168.1.1加到DNS Servers里面就可以了。

奇怪的是在使用同样系统的P4 NorthWood上DNS Servers是系统自动添加的。


_________________
我和他人紧紧相连, 密不可分, 我们都在同一种生活之中.

[]Laptop: acer 5022 /AMD64/ati X600/1G/100G
OS: acer WinXp / Gentoo 2006.0 AMD64
[]Desktop:P4 2.4 NorthWood/SiS 651/521M/80G
OS: Xp.Pro.en / Ubuntu 6.06


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译