我升级到dapper后也不能进入X

为当前最终发行版之前的所有版本提供支持
回复
angelo
帖子: 46
注册时间: 2005-10-10 18:43
送出感谢: 0
接收感谢: 0

我升级到dapper后也不能进入X

#1

帖子 angelo » 2006-06-05 23:22

检查了日志文件Xorg.0.log里的错误,如下:
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.(II) Loading extension MIT-SCREEN-SAVER

(EE) Failed to load module "kbd" (module does not exist, 0)

(EE) Failed to load module "mouse" (module does not exist, 0)

(EE) Failed to load module "synaptics" (module does not exist, 0)

(EE) No Input driver matching `kbd'

(EE) No Input driver matching `mouse'

(EE) No Input driver matching `synaptics'
不知道是不是这几个模块没有安装??
我自己查了一下,这正好是键盘、鼠标和触摸板的驱动,
我对照了一下升级前后的xorg.conf文件,发现升级并没有改动该文件
是不是升级的时候将这几个输入设备的驱动给删掉了或者挪到了别的位置?
现在,暂时不知道该怎么办了。。。
头像
fortruth
帖子: 1795
注册时间: 2005-11-06 1:51
来自: 七彩云世界
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 fortruth » 2006-06-06 1:31

我也出现同样的问题...求解...
angelo
帖子: 46
注册时间: 2005-10-10 18:43
送出感谢: 0
接收感谢: 0

#3

帖子 angelo » 2006-06-06 10:29

我的xorg.conf文件中输入设备部分如下:
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 zhan » 2006-06-06 10:52

sudo dpkg-reconfigure xserver-xorg重新配置一下看看。

http://wiki.ubuntu.org.cn/DapperUpgrades
按照官方文档来做一般不容易出问题.
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
angelo
帖子: 46
注册时间: 2005-10-10 18:43
送出感谢: 0
接收感谢: 0

#5

帖子 angelo » 2006-06-06 11:06

zhan 写了:sudo dpkg-reconfigure xserver-xorg重新配置一下看看。

http://wiki.ubuntu.org.cn/DapperUpgrades
按照官方文档来做一般不容易出问题.
重新配置怎么配?那些选项不是都一路确定下来的吗?
angelo
帖子: 46
注册时间: 2005-10-10 18:43
送出感谢: 0
接收感谢: 0

#6

帖子 angelo » 2006-06-06 11:12

自己捣鼓了一下,发现在urs/lib/xorg/modules/input中有所需要的kbd和mouse驱动
但是为什么系统不认呢?
试着把这两个.so文件拷贝到usr/X11R6/lib/modules/input中,重启出现了新的错误,提示什么东西mismatching.

哪位大虾能解释一下啊?
回复

回到 “老旧版本支持”