坏包装不上缷不了,还不能修复

为当前最终发行版之前的所有版本提供支持
回复
jacksun1105
帖子: 5
注册时间: 2005-07-21 2:56
送出感谢: 0
接收感谢: 0

坏包装不上缷不了,还不能修复

#1

帖子 jacksun1105 » 2006-06-07 13:39

我装的那个, 其实也不是我自己想装的gforge-db-postgresql, 装到一半好像说跟什么有冲突,最后新立得说:

gforge-db-postgresql: subprocess post-installation script returned error exit status 1

现在我每次用新立得,最后都会出现这个错误。。。我应该怎么处理啊?谢谢
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-06-07 13:47

dpkg -l gfxxxxx看状态是什么,头2个字母。
sudo apt-get remover --purge gfxxxx也试试。
● 鸣学
jacksun1105
帖子: 5
注册时间: 2005-07-21 2:56
送出感谢: 0
接收感谢: 0

#3

帖子 jacksun1105 » 2006-06-07 14:05

sunq@ugman:~$ dpkg -l gforge-db-postgresql
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-========================-========================-================================================================
iF gforge-db-postgresql 3.1-31 Collaborative development tool - database (using PostgreSQL)


root@ugman:/home/sunq# apt-get remover --purge gforge-db-postgresql
E: Invalid operation remover

下边呢?唉,我实在搞不定了
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 zhan » 2006-06-07 18:40

用 sudo dpkg --purge ***试试看能不能卸载掉
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2006-06-07 19:09

:em06 到。打错了字。是remove
● 鸣学
回复

回到 “老旧版本支持”