2个问题,error: 依赖性检测失败 /bin/sh

为当前最终发行版之前的所有版本提供支持
回复
lemon
帖子: 3
注册时间: 2006-06-09 16:49
送出感谢: 0
接收感谢: 0

2个问题,error: 依赖性检测失败 /bin/sh

#1

帖子 lemon » 2006-06-12 17:52

在ubuntu 6.06 安装多个rpm都提示找不到 /bin/sh, 如下安装MQ v5.3 for linux 的时候。

ccs@ccs-laptop:/opt/WebSphereMQ$ rpm -i MQSeriesRuntime-5.3.0-1.i386.rpm
error: 依赖性检测失败:
/bin/sh 被 MQSeriesRuntime-5.3.0-1.i386 所需要

请大家指点一下我如何安装这个/bin/sh 咚咚呢? 还有一个问题是,我看到一些帖子比如安装JDK 环境
sudo apt-get install ****, 我如何去知道****的正确名称呢? 是可以在那里查找吗?

我确信我看过《ubuntu 设置起步》《提问的智慧》,谢谢大家!
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#2

帖子 firehare » 2006-06-12 18:16

首先,我要提醒楼主的是 Ubuntu 不是 RedHat,它所使用的软件包并非 rpm 而是 deb
其次,鉴于楼主对 Ubuntu 还不是很了解,建议使用新立得软件包管理器来进行查找、安装软件包,图形界面也方便,相信楼主会很快搞清它的用法的
最后,如果楼主有空的话,建议看一下 Ubuntu 自带的帮助,相信能很快帮助楼主理清思路的!
我心无畏,源自于我心无知。
图片
lemon
帖子: 3
注册时间: 2006-06-09 16:49
送出感谢: 0
接收感谢: 0

#3

帖子 lemon » 2006-06-14 10:49

非常感谢 firehare, 但是但是、、、我的问题依然没有进展呀
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 zhan » 2006-06-14 12:50

其实应该告诉你的是,不要安装rpm包的东西,而要安装deb包。否则出了问题的话可能很麻烦。^_^
关于这个名字的问题,是可以查询的,ubuntu自带了“新利得”软件管理器,是一个有图形界面的软件包管理器,可以直接搜索,安装软件,很方便。如果找不到这个程序的话,就直接在终端中 sudo synaptic 启动。另外关于安装jdk的问题,这个包什么的在wiki中有提到,而且其中也提到了绝大多数需要的包的安装。
另外关于/bin/sh的问题,这个在ubuntu中是缺省安装的,你的问题就在于用了 rpm来安装包,这个是不被允许的,因此出现了问题。
再啰嗦一遍 wiki中设置的地址 http://wiki.ubuntu.org.cn/快速设置指南/DapperDrake
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
回复

回到 “老旧版本支持”