wrong:(gedit:5030) Why?(已解决)

为当前最终发行版之前的所有版本提供支持
回复
489319
帖子: 72
注册时间: 2006-01-11 16:27
送出感谢: 0
接收感谢: 0
联系:

wrong:(gedit:5030) Why?(已解决)

#1

帖子 489319 » 2006-06-12 23:51

jun@jun:~$ sudo gedit /etc/apt/sources.list
(gedit:5030): Gdk-WARNING **: locale not supported by Xlib
(gedit:5030): Gdk-WARNING **: cannot set locale modifiers
---------------------------------------------------------------------------------------------
Unable to lock the administration directory
---------------------------------------------------------------------------------------------
Why? thx!
上次由 489319 在 2006-06-14 20:46,总共编辑 1 次。
489319
帖子: 72
注册时间: 2006-01-11 16:27
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 489319 » 2006-06-13 0:24

  加了sudo,难道权限还不够吗,请问?要怎样解决?现在是,似乎只要是gpedit命令运行,都有以上提示。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2006-06-13 0:59

可能组权限出问题了。
试试用sudo vi。看什么现象。
● 鸣学
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 yongyi » 2006-06-13 12:24

locale是什么?GB18030吗?
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
489319
帖子: 72
注册时间: 2006-01-11 16:27
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 489319 » 2006-06-13 23:10

eexpress 写了:可能组权限出问题了。
试试用sudo vi。看什么现象。



~
~ VIM - Vi IMproved
~
~ version 7.0.10
~ by Bram Moolenaar et al.
~ Vim is open source and freely distributable
~
~ Help poor children in Uganda!
~ type :help iccf<Enter> for information
~
~ type :q<Enter> to exit
~ type :help<Enter> or <F1> for on-line help
~ type :help version7<Enter> for version info
~
~
~
~
~
Type :quit<Enter> to exit Vim 0,0-1 All
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2006-06-13 23:38

sudo vi /etc/apt/sources.list
这样。
● 鸣学
489319
帖子: 72
注册时间: 2006-01-11 16:27
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 489319 » 2006-06-13 23:44

eexpress 写了:sudo vi /etc/apt/sources.list
这样。

:lol: :lol: :lol: :lol: :lol:

  谢谢,终于弄成中文了,虽然在安装中文包的过程中有些问题。真的感谢你,eexpress。
  可我还是想用原来的gedit命令,因为我在安装一些软件包时,它默认的还是用gedit命令的。在我刚才安装中文包时,就有体现,内容提示和我一楼的内容一样。
  请问,怎样回到从前??
489319
帖子: 72
注册时间: 2006-01-11 16:27
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 489319 » 2006-06-14 0:48

eexpress 写了:sudo vi /etc/apt/sources.list
这样。

  现在又是这样的提示信息:

  ** (gedit:6391): CRITICAL **: gedit_plugins_engine_shutdown: assertion `gedit_plugins_engine_gconf_client != NULL' failed
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#9

帖子 eexpress » 2006-06-14 15:51

dpkg -l python-gnome2-desktop看看是不是安装。 就是输出行的前面有 ii 的提示

代码: 全选

$ dpkg -l python-gnome2-desktop
期望状态=未知(u)/安装(i)/删除(r)/清除(p)/保持(h)
| 当前状态=未(n)/已安装(i)/仅存配置(c)/仅解压缩(U)/配置失败(F)/不完全安装(H)
|/ 错误?=(无)/保持(?)/须重装(R)/两者兼有(#) (状态,错误:大写=故障)
||/ 名称         版本         简介
+++-==============-==============-============================================
ii  python-gnome2- 2.14.0-0ubuntu Python bindings for the GNOME desktop enviro


这样的情况不好判断。可能是少安装了什么。你update和upgrade升级过了吗。如果升级过,没错误提示。就应该正常。否则贴出错误提示。

还有,可以安装vim-gtk,代替gedit。有个图形界面的gvim,比gedit好。文件浏览器那里可以右键设置每种文件的打开方式为gvim就是了。vi这套软件是麻烦些,但是用熟悉了,就可以当作最终软件用了。gedit都可以删除了。

简单的编辑器还有nano和mousepad。很简单的类型。
● 鸣学
489319
帖子: 72
注册时间: 2006-01-11 16:27
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 489319 » 2006-06-14 20:43

  谢谢,按你说的,update和upgrade升级后就正常了。
回复

回到 “老旧版本支持”