出现依赖关系损坏的包,如何处理?

为当前最终发行版之前的所有版本提供支持
回复
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

出现依赖关系损坏的包,如何处理?

#1

帖子 lyreopera » 2005-08-03 18:35

无apt,

下载了stardic,configure时提示libc6版本过低,
在http://www.debian.org/distrib/packages下载新的libc6,
安装后进新立得,提示有依赖关系损坏的包,正是这个libc6,
无视之……

后来想卸掉cedega,
标记删除,结果同时出现一大堆要卸掉的包……
犹豫了一下,还是卸掉……

现在在新立得里标记安装一个软件,就会提示说XXXX还没配置,
正常情况下应该是把这些包也一柄标记并安装的……


我这种情况,是要常常下载安装源以外的软件包的,
依赖关系损坏,是难以避免的……
上次就是因为这个连x都卸了……

没apt的情况下如何处理?
……
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#2

帖子 oneleaf » 2005-08-03 18:39

那就使用 sudo dpkg-reconfigure *** 配置一下罗。
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 yongyi » 2005-08-03 18:43

不清楚你哪个东东没配置,也可以试试

代码: 全选

sudo apt-get -f install

解决依赖问题。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#4

帖子 lyreopera » 2005-08-03 18:54

好吧,试试看……



我大概连中文语言包都删掉了,
现在gnome里面基本上英文,
只有菜单还是中文……

其实英文也没多大关系,
不过今天在翻译bmp(已经变成英文了)的时候,
有些正式的翻译实在不知道是什么……


是不是这几个包?
language-pack-zh language-pack-zh-base language-support-zh


不敢乱下了,谁能发给我?
谢谢了!
……
头像
millenniumdark
论坛版主
帖子: 4160
注册时间: 2005-07-02 14:41
系统: Ubuntu 14.04 (Kylin)
送出感谢: 43 次
接收感谢: 9 次
联系:

libc6的問題

#5

帖子 millenniumdark » 2005-08-04 10:06

我上次裝了新的libc6也出現這一問題,連locale也刪掉了

如果你當初不是completely remove的話,到新立得里看看。
在not installed(residual config)里有這些軟件,重新安裝一下就行了。
回复

回到 “老旧版本支持”