升级后firefox无法启动(彻底解决)

为当前最终发行版之前的所有版本提供支持
回复
头像
bricksun
帖子: 85
注册时间: 2006-05-13 8:17
来自: 比京
送出感谢: 0
接收感谢: 0

升级后firefox无法启动(彻底解决)

#1

帖子 bricksun » 2006-06-17 19:01

从5。10升级到6。06花了我一晚上时间,没想到会花这么长时间。
现在问题出现了,firefox无法启动了,报错如下:
/opt/firefox/run-mozilla.sh: line 131: 5341 Segmentation fault "$prog" ${1+"$@"}
不知道如何解决,请大伙参谋参谋

解决方法:
按快速设置指南的方法,安装scim-bridge,以下引用:
"#安装scim-bridge;请确保已正确设置中文环境

sudo apt-get install scim-bridge

#编辑im-switch生成的scim配置文件

sudo gedit /etc/X11/xinit/xinput.d/zh_CN

#将默认的 GTK_IM_MODULE=scim 修改为 GTK_IM_MODULE="scim-bridge"
#将默认的 QT_IM_MODULE=scim 修改为 QT_IM_MODULE="xim" (不然可能无法在qt程序中输入中文)"
这么设置以后,firefox依然无法启动,搜索论坛发现aubrey提供一个方法,引用:
“编辑/etc/gtk-2.0/gtk.immodules文件,注释掉如下两行:
"/usr/lib/gtk-2.0/2.4.0/immodules/im-scim.so"
"scim" "SCIM Input Method" "scim" "/usr/share/locale" ""

结合以上两个方法,既可以用firefox,又可以用scim了(因为不会用fcitx)。

谢谢论坛的各位坛友,Ubuntu因你而精彩!
上次由 bricksun 在 2006-06-19 22:09,总共编辑 1 次。
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 karron » 2006-06-17 19:52

scim和这些程序冲突,解决方法请搜索一下论坛,很多的
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
klz1007
帖子: 125
注册时间: 2006-03-11 3:35
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 klz1007 » 2006-06-18 3:00

你可以试一下用SCIM-bridge或其它的来解决,具体方法你可以搜一下,我试过opera.openoffice.firefox是没问题的。
头像
bricksun
帖子: 85
注册时间: 2006-05-13 8:17
来自: 比京
送出感谢: 0
接收感谢: 0

#4

帖子 bricksun » 2006-06-19 8:03

果然如此,scim的冲突这么大呀
我就是按照快速指南更改的设置,而且安装了scim-bridge,没想到还是发生冲突
现在把scim卸载了,漂亮的火狐又出现在我的面前
kuposky
帖子: 52
注册时间: 2006-03-02 18:17
送出感谢: 0
接收感谢: 0

#5

帖子 kuposky » 2006-06-19 19:17

仅安装还不够
还要改配置让GTK程序使用SCIM-bridge
头像
bricksun
帖子: 85
注册时间: 2006-05-13 8:17
来自: 比京
送出感谢: 0
接收感谢: 0

#6

帖子 bricksun » 2006-06-22 0:29

解决方法(已贴在主贴):
按快速设置指南的方法,安装scim-bridge,以下引用:
"#安装scim-bridge;请确保已正确设置中文环境

sudo apt-get install scim-bridge

#编辑im-switch生成的scim配置文件

sudo gedit /etc/X11/xinit/xinput.d/zh_CN

#将默认的 GTK_IM_MODULE=scim 修改为 GTK_IM_MODULE="scim-bridge"
#将默认的 QT_IM_MODULE=scim 修改为 QT_IM_MODULE="xim" (不然可能无法在qt程序中输入中文)"
这么设置以后,firefox依然无法启动,搜索论坛发现aubrey提供一个方法,引用:
“编辑/etc/gtk-2.0/gtk.immodules文件,注释掉如下两行:
"/usr/lib/gtk-2.0/2.4.0/immodules/im-scim.so"
"scim" "SCIM Input Method" "scim" "/usr/share/locale" ""
回复

回到 “老旧版本支持”