安装LumaQQ的问题

为当前最终发行版之前的所有版本提供支持
回复
头像
ibmwebzh
帖子: 84
注册时间: 2006-03-13 19:20
送出感谢: 0
接收感谢: 0

安装LumaQQ的问题

#1

帖子 ibmwebzh » 2006-06-20 12:56

装上jre之后,下载了LumaQQ 2006 m2版。结果启动之后终端出现下列信息:
Exception in thread "main" java.lang.NoClassDefFoundError: org.eclipse.emf.ecore.plugin.EcorePlugin
at java.lang.Class.initializeClass(libgcj.so.7)
at org.eclipse.emf.ecore.resource.impl.URIConverterImpl.<clinit>(URIConverterImpl.java:207)
at java.lang.Class.initializeClass(libgcj.so.7)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.getURIConverter(ResourceSetImpl.java:411)
at org.eclipse.emf.ecore.resource.impl.ResourceImpl.getURIConverter(ResourceImpl.java:835)
at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:865)
at edu.tsinghua.lumaqq.eutil.GlobalUtil.load(GlobalUtil.java:106)
at edu.tsinghua.lumaqq.LumaQQ.readGlobalSettingFile(LumaQQ.java:226)
at edu.tsinghua.lumaqq.LumaQQ.main(LumaQQ.java:119)
Caused by: java.lang.ClassNotFoundException: org.eclipse.core.runtime.jobs.ISchedulingRule not found in gnu.gcj.runtime.SystemClassLoader{urls=[file:./lib/xerces.jar,file:./lib/swt.jar,file:./lib/poifs.jar,file:./lib/org.eclipse.ui.workbench_3.2.0.I20051214-1200.jar,file:./lib/org.eclipse.osgi_3.2.0.v20051212a.jar,file:./lib/org.eclipse.jface_3.2.0.I20051214-0010.jar,file:./lib/org.eclipse.equinox.common_1.0.0.v20051205.jar,file:./lib/org.eclipse.emf.ecore.xmi_2.2.0.jar,file:./lib/org.eclipse.emf.ecore_2.2.0.jar,file:./lib/org.eclipse.emf.common_2.2.0.jar,file:./lib/org.eclipse.core.runtime_3.2.0.v20051208.jar,file:./lib/org.eclipse.core.resources_3.2.0.v20051208.jar,file:./lib/org.eclipse.core.commands_3.2.0.I20051212-2000.jar,file:./lib/lumaqq_xsd.jar,file:./lib/lumaqq_template.jar,file:./lib/lumaqq.jar,file:./lib/log4j-1.2.8.jar,file:./lib/jql_protocol.jar,file:./lib/jql_net.jar,file:./lib/je.jar,file:./lib/jdom.jar,file:./lib/commons-logging.jar,file:./lib/commons-codec.jar,file:./], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
at java.net.URLClassLoader.findClass(libgcj.so.7)
at java.lang.ClassLoader.loadClass(libgcj.so.7)
at java.lang.ClassLoader.loadClass(libgcj.so.7)
at java.lang.VMClassLoader.defineClass(libgcj.so.7)
at java.lang.ClassLoader.defineClass(libgcj.so.7)
at java.security.SecureClassLoader.defineClass(libgcj.so.7)
at java.net.URLClassLoader.findClass(libgcj.so.7)
at java.lang.ClassLoader.loadClass(libgcj.so.7)
at java.lang.ClassLoader.loadClass(libgcj.so.7)
at java.lang.VMClassLoader.defineClass(libgcj.so.7)
at java.lang.ClassLoader.defineClass(libgcj.so.7)
at java.security.SecureClassLoader.defineClass(libgcj.so.7)
at java.net.URLClassLoader.findClass(libgcj.so.7)
at java.lang.ClassLoader.loadClass(libgcj.so.7)
at java.lang.ClassLoader.loadClass(libgcj.so.7)
at java.lang.VMClassLoader.defineClass(libgcj.so.7)
at java.lang.ClassLoader.defineClass(libgcj.so.7)
at java.security.SecureClassLoader.defineClass(libgcj.so.7)
at java.net.URLClassLoader.findClass(libgcj.so.7)
at java.lang.ClassLoader.loadClass(libgcj.so.7)
at java.lang.ClassLoader.loadClass(libgcj.so.7)
at java.lang.Class.forName(libgcj.so.7)
at java.lang.Class.initializeClass(libgcj.so.7)
...8 more
我又重新安装了一遍jre,结果还是如此。
这个问题该如何解决?请大家帮助。
zxx007
帖子: 217
注册时间: 2006-04-29 15:43
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 zxx007 » 2006-06-20 13:13

安装后,用
sudo update-alternatives --config java

选择jr2re5了吗
头像
ibmwebzh
帖子: 84
注册时间: 2006-03-13 19:20
送出感谢: 0
接收感谢: 0

#3

帖子 ibmwebzh » 2006-06-20 13:32

谢谢,可以了。
netbaby
帖子: 16
注册时间: 2006-06-16 12:12
送出感谢: 0
接收感谢: 0

#4

帖子 netbaby » 2006-06-20 17:01

原来是要这样的啊,谢谢楼上的
回复

回到 “老旧版本支持”