[问题]新手请教一个系统安装问题

为当前最终发行版之前的所有版本提供支持
回复
bcnfish
帖子: 10
注册时间: 2006-05-18 15:02
送出感谢: 0
接收感谢: 0

[问题]新手请教一个系统安装问题

#1

帖子 bcnfish » 2006-06-21 11:15

我编译内核 是从2.6.12->2.6.17 vmlinuz-2.6.17生成了  initrd.img-2.6.17也生成了  修改完grub 之后,启动出现下面的错误  不知道怎么半了 再一点 ,initrd.img-2.6.17文件是内核编译完手工生成的.
启动错误画面我截图了,哪位高手指点下,谢谢,急...
附件
error.JPG
Dreamer
帖子: 22
注册时间: 2005-10-14 22:46
送出感谢: 0
接收感谢: 0

Re: [问题]新手请教一个系统安装问题

#2

帖子 Dreamer » 2006-06-21 13:02

1 如果你的Grub启动选项还有2.6.12,就用它启动你的机器。然后重新编译。再试。
2 如果把老的启动选项删除了,那恭喜你了。你可以:
a 下载一个DOS下使用的Grub尝试恢复你的系统。怎么用到论坛搜索一下就明白了
b 用LiveCD 启动系统,修改你的menu.lst.
c 万般无奈,只有重新安装了
bcnfish
帖子: 10
注册时间: 2006-05-18 15:02
送出感谢: 0
接收感谢: 0

#3

帖子 bcnfish » 2006-06-21 13:24

grub 中还有2.6.12的启动项,可以正常进去

如果不重新编译,就用这次编译的 让系统正常启动,还有解决办法吗?
bcnfish
帖子: 10
注册时间: 2006-05-18 15:02
送出感谢: 0
接收感谢: 0

#4

帖子 bcnfish » 2006-06-22 17:28

请问上面截图中的 "mptscsih" 是什么意思?



系统启动失败是不是与这个有关     ?
bcnfish
帖子: 10
注册时间: 2006-05-18 15:02
送出感谢: 0
接收感谢: 0

#5

帖子 bcnfish » 2006-06-23 11:19

问题解决了   我换了个IDE硬盘  另装系统  重新编译  一切就OK了  

就是不明白  SCSI硬盘在编译时 还应注意什么  ,肯定是这点导致我第一次编译失败

请各位大侠指点   一直在线...
回复

回到 “老旧版本支持”