configure 出错!!

为当前最终发行版之前的所有版本提供支持
回复
头像
wenhacxx
帖子: 171
注册时间: 2006-05-13 14:38
送出感谢: 0
接收感谢: 0
联系:

configure 出错!!

#1

帖子 wenhacxx » 2006-06-25 0:31

错误如下:checking for GTK... configure: error: Package requirements (gtk+-2.0 >= 2.8.0) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the GTK_CFLAGS and GTK_LIBS environment variables
to avoid the need to call pkg-config. See the pkg-config man page for
more details.


我已经装了gtk了,但就是configure不了,不知道怎么回事。我也看了很多论坛上有关的贴,但没有一个见效的,平时很多要编译的软件要configure的时候就这样出错,真苦恼!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-06-25 3:22

版本不对吧。编译时,很多软件指定版本的。
源里面那么多软件。编译作什么。多半是你不知道软件名。我用了很长时间,发现只要是不使用测试版本,源的都有。
● 鸣学
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 karron » 2006-06-25 9:19

编译软件可以用 sudo apt-get build-dep XXX 来安装一些依赖库。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
wenhacxx
帖子: 171
注册时间: 2006-05-13 14:38
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 wenhacxx » 2006-07-13 9:48

已经解决,安装了libgtk2.0-dev就行了
回复

回到 “老旧版本支持”