[问题] 安装Java时出错 本人新人 求高人帮忙 谢谢

为当前最终发行版之前的所有版本提供支持
回复
Daves
帖子: 2
注册时间: 2006-06-26 13:05
送出感谢: 0
接收感谢: 0

[问题] 安装Java时出错 本人新人 求高人帮忙 谢谢

#1

帖子 Daves » 2006-06-26 13:20

刚装好ubuntu,也更新了。在按照wiki里面安装设置里面的步骤装java时出错 求达人帮忙 谢谢

安装信息:
$ sudo apt-get install sun-java5-jre
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
将会安装下列额外的软件包:
sun-java5-bin
建议安装的软件包:
sun-java5-plugin ia32-sun-java5-plugin sun-java5-fonts
推荐安装的软件包:
gsfonts-x11
下列【新】软件包将被安装:
sun-java5-bin sun-java5-jre
共升级了 0 个软件包,新安装了 2 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 0B/29.5MB 的软件包。
解压缩后会消耗掉 83.3MB 的额外空间。
您希望继续执行吗?[Y/n]y
正在预设定软件包 ...
(正在读取数据库 ... 系统当前总共安装有 75143 个文件和目录。)
正在解压缩 sun-java5-bin (从 .../sun-java5-bin_1.5.0-06-1_i386.deb) ...
sun-dlj-v1-1 license could not be presented
dpkg:处理 /var/cache/apt/archives/sun-java5-bin_1.5.0-06-1_i386.deb (--unpack) 时出错:
子进程·pre-installation script·返回了错误号·2
正在解压缩 sun-java5-jre (从 .../sun-java5-jre_1.5.0-06-1_all.deb) ...
sun-dlj-v1-1 license could not be presented
dpkg:处理 /var/cache/apt/archives/sun-java5-jre_1.5.0-06-1_all.deb (--unpack)时出错:
子进程·pre-installation script·返回了错误号·2
在处理时有错误发生:
/var/cache/apt/archives/sun-java5-bin_1.5.0-06-1_i386.deb
/var/cache/apt/archives/sun-java5-jre_1.5.0-06-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 zhan » 2006-06-26 13:35

恩,为什么会有依赖关系的错误?
试试 sudo apt-get -f install 看看是什么提示。
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
Daves
帖子: 2
注册时间: 2006-06-26 13:05
送出感谢: 0
接收感谢: 0

#3

帖子 Daves » 2006-06-26 13:43

试了

提示下

正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
turbohead
帖子: 58
注册时间: 2006-07-07 19:12
送出感谢: 0
接收感谢: 0

#4

帖子 turbohead » 2006-07-23 23:51

同样的问题,大家一起汇到这个帖子吧,看看有人能解决不
http://forum.ubuntu.org.cn/viewtopic.ph ... B%E7%A8%8B
回复

回到 “老旧版本支持”