问启动问题。LILO /GRUB!

为当前最终发行版之前的所有版本提供支持
回复
kpa
帖子: 84
注册时间: 2005-07-26 22:54
送出感谢: 0
接收感谢: 0
联系:

问启动问题。LILO /GRUB!

#1

帖子 kpa » 2005-08-07 20:17

我在安装系统时,因本不熟GRUB。且。又阴差阳错,装了LILO。具体安装过程略了。但能顺利启动。。。

我有多个硬盘,UBUNTU是安装在HDC1.HDC5是SWAP。HDA1是03OS。

在BIOS设HDA/HDC硬盘分别可以正常启动两个OS。

现问。UBUNTU。

查过/BOOT/GRUB。。GRUB是无安装的。
LILO。CONF是无内容的。
启动是出现LILO。。。。

那么讲。我机器安装的是LILO。但具体配置在那里?当前LILO安装是在HDC/MBR还是眅HDC1?
另外,我想重新安装GRUB。需要如何操作?

谢谢
头像
oneleaf
论坛管理员
帖子: 10213
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 101 次

#2

帖子 oneleaf » 2005-08-07 20:42

sudo apt-get remove lilo
sudo apt-get install grub
sudo grub-install /dev/hdc
sudo update-grub
sudo gedit /etc/kernel-img.conf

代码: 全选

# Do not create symbolic links in /
do_symlinks = yes
relative_links = yes
do_bootloader = no
do_bootfloppy = no
do_initrd = yes
link_in_boot = no
postinst_hook = /sbin/update-grub
postrm_hook   = /sbin/update-grub


搞定!
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
kpa
帖子: 84
注册时间: 2005-07-26 22:54
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 kpa » 2005-08-08 21:26

as this do
it isn't can

os can't boot (hd2,0)
but change (hd2,0) --->(hd0,0).the os can boot.


why???
头像
oneleaf
论坛管理员
帖子: 10213
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 101 次

#4

帖子 oneleaf » 2005-08-08 21:39

如果从第二个硬盘启动时,第二个硬盘在grub中就是hd0。当然启动完毕后会更正过来。
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
kpa
帖子: 84
注册时间: 2005-07-26 22:54
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 kpa » 2005-08-09 20:59

oneleaf 写了:如果从第二个硬盘启动时,第二个硬盘在grub中就是hd0。当然启动完毕后会更正过来。


是否。在GRUB加载时,无论盘是第几个。当前GRUB所在。就定义为HD0?

之后才按正常顺序运行?
头像
oneleaf
论坛管理员
帖子: 10213
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 101 次

#6

帖子 oneleaf » 2005-08-09 21:25

呵呵,你试试就知。我也不太确定。
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
klux
帖子: 22
注册时间: 2005-08-07 16:38
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 klux » 2005-08-11 0:07

不是吧,后面的hdXX是指你要引导的系统内核所在.
而对于Grub来说是安装在512b的MBR上的.他的配置文件则是安装在你想安装的系统的/boot/grub/下的grub.conf(你安装grub时,安装环境的系统)
好好学习,天天向上。——毛主席

OS : ubuntu 5.04
klux
帖子: 22
注册时间: 2005-08-07 16:38
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 klux » 2005-08-11 0:13

而对于定义是HD0,还是别的要看你的硬盘是主是从,是辅助主,从.依次是:hd0,hd1,hd2,hd3etc.
好好学习,天天向上。——毛主席

OS : ubuntu 5.04
回复

回到 “老旧版本支持”