用新立得软件包管理器出现问题。求兄弟指导

为当前最终发行版之前的所有版本提供支持
回复
adof
帖子: 10
注册时间: 2006-06-29 4:49
送出感谢: 0
接收感谢: 0

用新立得软件包管理器出现问题。求兄弟指导

#1

帖子 adof » 2006-06-29 17:10

E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。
E: Unable to correct dependencies

这是再用edit里面fix broken packages时出现的错误。 我目前就是 因为 有broken packages不能安装 删除任何软件。大家 帮忙了 。
adof
帖子: 10
注册时间: 2006-06-29 4:49
送出感谢: 0
接收感谢: 0

#2

帖子 adof » 2006-06-29 17:14

root@ubuntu:/home/adof# apt-get install kmplayer
E: 无法获得锁 /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

就是这个问题。不知道 怎么办 ???
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#3

帖子 zhuqin_83 » 2006-06-30 5:06

你开了synaptic然后又用apt-get当然不行。
把synaptic关了,在用终端,或者只用synaptic.
adof
帖子: 10
注册时间: 2006-06-29 4:49
送出感谢: 0
接收感谢: 0

#4

帖子 adof » 2006-06-30 12:23

root@ubuntu:/home/adof# apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 失败。
下列的软件包有不能满足的依赖关系:
libc6: 依赖: tzdata 但却无法安装它
libc6-i686: 预依赖: libc6 (= 2.3.6-0ubuntu20) 但是 2.3.6-13 已经安装了
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的 缘故。
E: 无法更正依赖关系

只用 终端,还是有这个 问题。
头像
websnail
帖子: 270
注册时间: 2006-06-01 12:42
送出感谢: 0
接收感谢: 0

#5

帖子 websnail » 2006-07-01 23:34

还是去新立得里面,找到这个软件包,在“软件包”这个菜单里面,把“锁定版本”或者“强制版本”取消掉。另外新立得还有修复损坏的软件包的功能啊。多试试好了,反正学linux就得折腾!:D
irc
帖子: 19
注册时间: 2005-12-20 10:46
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 irc » 2006-07-03 10:03

不行阿,新立德关了也不行。
单独用新立德也报错。呵呵。麻烦大了
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 karron » 2006-07-03 10:07

不知道你是安装什么软件导致的这个错误.

建议只安装源里面的软件,就使用新立得来安装,这样出问题的可能性就很小了.只要设置好正确的源,比如新手指南里面的哪些,一般软件都有了.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
回复

回到 “老旧版本支持”