当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Nvidia 6100, 3D加速没有,请问如何解决?
帖子发表于 : 2006-06-29 19:22 

注册: 2006-06-26 12:13
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
通过nvidia-glx安装的驱动。用glx没有问题,不过感觉CPU占用比较高,glxgears -info信息如下:

:~$ glxgears -info
GL_RENDERER = GeForce 6100/PCI/SSE2/3DNOW!
GL_VERSION = 1.2 (2.0.2 NVIDIA 87.62)
GL_VENDOR = NVIDIA Corporation
......

9210 frames in 5.0 seconds = 1841.999 FPS
11634 frames in 5.0 seconds = 2325.850 FPS
11815 frames in 5.0 seconds = 2352.424 FPS
11058 frames in 5.0 seconds = 2194.029 FPS

然后:
~$ glxinfo | grep rendering
direct rendering: No

请问应该如何解决呢?
我的xorg.conf如下:
代码:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Mon May 15 13:23:42 PDT 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

   # path to defoma fonts
    FontPath        "/usr/share/X11/fonts/misc"
    FontPath        "/usr/share/X11/fonts/cyrillic"
    FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/Type1"
    FontPath        "/usr/share/X11/fonts/100dpi"
    FontPath        "/usr/share/X11/fonts/75dpi"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load           "i2c"
    Load           "bitmap"
    Load           "ddc"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
    Load           "int10"
    Load           "type1"
    Load           "vbe"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc104"
    Option         "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ExplorerPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "stylus"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to
    Option         "Type" "stylus"
    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "eraser"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to
    Option         "Type" "eraser"
    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "cursor"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to
    Option         "Type" "cursor"
    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier     "VA902-3Serie"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Generic Video Card"
    Driver         "nvidia"
    Option          "RenderAccel"   "true"
    Option          "AllowGLXWithComposite" "true"
    Option          "CursorShadow"  "1"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Generic Video Card"
    Monitor        "VA902-3Serie"
    DefaultDepth    24
    SubSection     "Display"
        Depth       1
        Modes      "1280x1024@60"
    EndSubSection
    SubSection     "Display"
        Depth       4
        Modes      "1280x1024@60"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1280x1024@60"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "1280x1024@60"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1280x1024@60"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024@60"
    EndSubSection
EndSection


机器配置:Sephrom 2500+, Nvidia C51G, 1.5GB DDR 400[/code]


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-06-30 7:18 

注册: 2006-06-26 12:13
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
顶~~~


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-06-30 20:26 

注册: 2006-06-26 12:13
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
没人知道吗?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-07-01 4:37 

注册: 2006-06-08 23:09
帖子: 41
送出感谢: 0 次
接收感谢: 0 次
nvidia-glx-dev这个包没装?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-07-01 10:00 

注册: 2006-06-26 12:13
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
没有,这个看起来是开发包,有必要装?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-07-01 17:40 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

怎么没有dri。驱动不对哦。


_________________
● 鸣学


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-07-01 22:58 

注册: 2006-06-26 12:13
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
If you have a working X config file for a different driver (such as the "nv"
or "vesa" driver), then simply edit the file as follows.

Remove the line:

Driver "nv"
(or Driver "vesa")
(or Driver "fbdev")

and replace it with the line:

Driver "nvidia"

Remove the following lines:

Load "dri"
Load "GLCore"

In the "Module" section of the file, add the line (if it does not already
exist):

Load "glx"

nvidia的驱动说明文件里面明确说明不要dri的呀


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-07-03 0:58 

注册: 2006-06-08 23:09
帖子: 41
送出感谢: 0 次
接收感谢: 0 次
magnusrex 写道:
没有,这个看起来是开发包,有必要装?

我不装这个包的话,mplayer就放不了任何视频
画面是幻灯片,影音超级不同步
装了这个包,就很流畅了
你试看看吧,无效再删除就可以了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译