Nvidia 6100, 3D加速没有,请问如何解决?

为当前最终发行版之前的所有版本提供支持
回复
magnusrex
帖子: 9
注册时间: 2006-06-26 12:13
送出感谢: 0
接收感谢: 0

Nvidia 6100, 3D加速没有,请问如何解决?

#1

帖子 magnusrex » 2006-06-29 19:22

通过nvidia-glx安装的驱动。用glx没有问题,不过感觉CPU占用比较高,glxgears -info信息如下:

:~$ glxgears -info
GL_RENDERER = GeForce 6100/PCI/SSE2/3DNOW!
GL_VERSION = 1.2 (2.0.2 NVIDIA 87.62)
GL_VENDOR = NVIDIA Corporation
......

9210 frames in 5.0 seconds = 1841.999 FPS
11634 frames in 5.0 seconds = 2325.850 FPS
11815 frames in 5.0 seconds = 2352.424 FPS
11058 frames in 5.0 seconds = 2194.029 FPS

然后:
~$ glxinfo | grep rendering
direct rendering: No

请问应该如何解决呢?
我的xorg.conf如下:

代码: 全选

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Mon May 15 13:23:42 PDT 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

	# path to defoma fonts
    FontPath        "/usr/share/X11/fonts/misc"
    FontPath        "/usr/share/X11/fonts/cyrillic"
    FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/Type1"
    FontPath        "/usr/share/X11/fonts/100dpi"
    FontPath        "/usr/share/X11/fonts/75dpi"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load           "i2c"
    Load           "bitmap"
    Load           "ddc"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
    Load           "int10"
    Load           "type1"
    Load           "vbe"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc104"
    Option         "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ExplorerPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "stylus"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to 
    Option         "Type" "stylus"
    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "eraser"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to 
    Option         "Type" "eraser"
    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "cursor"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to 
    Option         "Type" "cursor"
    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier     "VA902-3Serie"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Generic Video Card"
    Driver         "nvidia"
    Option          "RenderAccel"   "true"
    Option          "AllowGLXWithComposite" "true"
    Option          "CursorShadow"  "1"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Generic Video Card"
    Monitor        "VA902-3Serie"
    DefaultDepth    24
    SubSection     "Display"
        Depth       1
        Modes      "1280x1024@60"
    EndSubSection
    SubSection     "Display"
        Depth       4
        Modes      "1280x1024@60"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1280x1024@60"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "1280x1024@60"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1280x1024@60"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024@60"
    EndSubSection
EndSection
机器配置:Sephrom 2500+, Nvidia C51G, 1.5GB DDR 400[/code]
magnusrex
帖子: 9
注册时间: 2006-06-26 12:13
送出感谢: 0
接收感谢: 0

#2

帖子 magnusrex » 2006-06-30 7:18

顶~~~
magnusrex
帖子: 9
注册时间: 2006-06-26 12:13
送出感谢: 0
接收感谢: 0

#3

帖子 magnusrex » 2006-06-30 20:26

没人知道吗?
ougi
帖子: 41
注册时间: 2006-06-08 23:09
送出感谢: 0
接收感谢: 0

#4

帖子 ougi » 2006-07-01 4:37

nvidia-glx-dev这个包没装?
magnusrex
帖子: 9
注册时间: 2006-06-26 12:13
送出感谢: 0
接收感谢: 0

#5

帖子 magnusrex » 2006-07-01 10:00

没有,这个看起来是开发包,有必要装?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2006-07-01 17:40

Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

怎么没有dri。驱动不对哦。
● 鸣学
magnusrex
帖子: 9
注册时间: 2006-06-26 12:13
送出感谢: 0
接收感谢: 0

#7

帖子 magnusrex » 2006-07-01 22:58

If you have a working X config file for a different driver (such as the "nv"
or "vesa" driver), then simply edit the file as follows.

Remove the line:

Driver "nv"
(or Driver "vesa")
(or Driver "fbdev")

and replace it with the line:

Driver "nvidia"

Remove the following lines:

Load "dri"
Load "GLCore"

In the "Module" section of the file, add the line (if it does not already
exist):

Load "glx"

nvidia的驱动说明文件里面明确说明不要dri的呀
ougi
帖子: 41
注册时间: 2006-06-08 23:09
送出感谢: 0
接收感谢: 0

#8

帖子 ougi » 2006-07-03 0:58

magnusrex 写了:没有,这个看起来是开发包,有必要装?
我不装这个包的话,mplayer就放不了任何视频
画面是幻灯片,影音超级不同步
装了这个包,就很流畅了
你试看看吧,无效再删除就可以了
回复

回到 “老旧版本支持”