安装beep media player及wma、ape插件

为当前最终发行版之前的所有版本提供支持
614a
帖子: 42
注册时间: 2006-06-16 2:39
送出感谢: 0
接收感谢: 0

安装beep media player及wma、ape插件

#1

帖子 614a » 2006-06-30 15:52

安装beep media player(也可以直接在 菜单-添加/删除 里安装)

代码: 全选

sudo apt-get install beep-media-player
安装后改变mp3标签设置以显示中文:右击播放器界面-首选项-插件-媒体-MPEG音频插件-标签-转换非UTF-8标签为UTF-8标签, 填GBK

下面安装ape、wma插件,采用编译源代码方式。

先安装编译环境

代码: 全选

sudo apt-get install build-essential
我记不请是否会自动安装gcc、make了,如果没有装就再装吧。

代码: 全选

sudo apt-get install gcc make
如果编译gtk+相关程序,可能需要安装libgtk2.0-dev包,这里就需要

代码: 全选

sudo apt-get install libgtk2.0-dev
安装beep media player开发包,用于编译插件

代码: 全选

sudo apt-get install beep-media-player-dev
安装编译汇编代码的包,编译ape插件需要

代码: 全选

sudo apt-get install yasm
安装ape插件,下载地址(国内)http://supermmx.org/linux/mac/

下载ape解码包(源码)MAC non-win32 port,文件名mac-3.99-u4-b5.tar.gz,解压,到解压后目录配置、编译、安装

代码: 全选

./configure --enable-assembly
make
sudo make install
下载ape插件(源码)MAC plugin for Beep Media Player,文件名bmp-mac-0.1.1.tar.gz,解压,到解压后目录配置、编译、安装

代码: 全选

./configure --enable-local=yes
make
sudo make install
编译的参数是根据包里INSTALL文件说明加上的(我没加时安装后无法加载ape插件)

安装wma插件(源码),下载地址(国外)http://download.berlios.de/bmp-plugins/ ... 1.1.tar.gz
先安装gcc-3.4(用gcc-4.0以上版本无法正常编译)

代码: 全选

sudo apt-get install gcc-3.4
设置编译器版本

代码: 全选

export CC=gcc-3.4
将wma插件包解压,到解压后目录,配置、编译、安装

代码: 全选

./configure 
make
sudo make install
如果编译文件时出错,且屏幕不能完全显示,则在运行编译命令前,输入

代码: 全选

scripts filename
filename不写则文件名默认为typescript。接着运行编译命令,这样会在目录下生成名为filename的文件,里面记录着编译时候在命令行的输出。这些信息可以帮助你分析出错原因。
vituly
帖子: 32
注册时间: 2006-05-13 19:01
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 vituly » 2006-06-30 22:01

支持!!!

:lol: :lol:
:lol:
头像
Polya
帖子: 58
注册时间: 2006-06-06 17:13
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 Polya » 2006-07-02 19:09

按楼主所述,成功,十分感谢!
emohuang
帖子: 33
注册时间: 2006-06-25 14:50
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 emohuang » 2006-07-03 23:24

xiaochuan@ubuntu:~$ sudo apt-get install libgtk2.0-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
将会安装下列额外的软件包:
libatk1.0-dev libcairo2-dev libexpat1-dev libfontconfig1-dev
libfreetype6-dev libglib2.0-dev libgtk2.0-0 libgtk2.0-bin libgtk2.0-common
libpango1.0-dev libpng12-dev libx11-dev libxau-dev libxcursor-dev
libxdmcp-dev libxext-dev libxfixes-dev libxft-dev libxi-dev libxinerama-dev
libxrandr-dev libxrender-dev x-dev x11proto-core-dev x11proto-fixes-dev
x11proto-input-dev x11proto-kb-dev x11proto-randr-dev x11proto-render-dev
x11proto-xext-dev x11proto-xinerama-dev zlib1g-dev
建议安装的软件包:
libcairo2-doc libglib2.0-doc libgtk2.0-doc libpango1.0-doc
下列【新】软件包将被安装:
libatk1.0-dev libcairo2-dev libexpat1-dev libfontconfig1-dev
libfreetype6-dev libglib2.0-dev libgtk2.0-dev libpango1.0-dev libpng12-dev
libx11-dev libxau-dev libxcursor-dev libxdmcp-dev libxext-dev libxfixes-dev
libxft-dev libxi-dev libxinerama-dev libxrandr-dev libxrender-dev x-dev
x11proto-core-dev x11proto-fixes-dev x11proto-input-dev x11proto-kb-dev
x11proto-randr-dev x11proto-render-dev x11proto-xext-dev
x11proto-xinerama-dev zlib1g-dev
下列的软件包将被升级:
libgtk2.0-0 libgtk2.0-bin libgtk2.0-common
共升级了 3 个软件包,新安装了 30 个软件包,要卸载 0 个软件包,有 1 个软件未被升 级。
需要下载 4329kB/9174kB 的软件包。
解压缩后会消耗掉 26.8MB 的额外空间。
您希望继续执行吗?[Y/n]y
【警告】:下列的软件包不能通过验证!
x11proto-core-dev x11proto-kb-dev x11proto-input-dev libxau-dev libxdmcp-dev
libx11-dev x11proto-render-dev libxrender-dev libxext-dev libxi-dev
x11proto-xext-dev x11proto-fixes-dev libxfixes-dev libxcursor-dev
libexpat1-dev zlib1g-dev libfreetype6-dev libfontconfig1-dev x-dev
libxft-dev x11proto-xinerama-dev libxinerama-dev x11proto-randr-dev
libxrandr-dev libglib2.0-dev libatk1.0-dev libpng12-dev libcairo2-dev
libgtk2.0-common libgtk2.0-bin libgtk2.0-0 libpango1.0-dev libgtk2.0-dev
不经验证就安装这些软件包么?[y/N] y
错误 http://archive.ubuntu.com dapper-updates/main libgtk2.0-common 2.8.18-0ubuntu1
404 Not Found [IP: 85.133.25.8 80]
错误 http://archive.ubuntu.com dapper-updates/main libgtk2.0-bin 2.8.18-0ubuntu1 404 Not Found [IP: 85.133.25.8 80]
错误 http://archive.ubuntu.com dapper-updates/main libgtk2.0-0 2.8.18-0ubuntu1
404 Not Found [IP: 85.133.25.8 80]
错误 http://archive.ubuntu.com dapper-updates/main libgtk2.0-dev 2.8.18-0ubuntu1 404 Not Found [IP: 85.133.25.8 80]
无法下载 http://archive.ubuntu.com/ubuntu/pool/m ... u1_all.deb 404 Not Found [IP: 85.133.25.8 80]
无法下载 http://archive.ubuntu.com/ubuntu/pool/m ... 1_i386.deb 404 Not Found [IP: 85.133.25.8 80]
无法下载 http://archive.ubuntu.com/ubuntu/pool/m ... 1_i386.deb 404 Not Found [IP: 85.133.25.8 80]
无法下载 http://archive.ubuntu.com/ubuntu/pool/m ... 1_i386.deb 404 Not Found [IP: 85.133.25.8 80]
E: 有几个软件包无法下载,您可以运行 apt-get update 或者加上 --fix-missing 的选项再试试?
xiaochuan@ubuntu:~$
不要对技术失去激情
xiechy
帖子: 1074
注册时间: 2006-01-18 15:01
送出感谢: 0
接收感谢: 1 次

#5

帖子 xiechy » 2006-07-06 22:08

我做好了包。
viewtopic.php?t=19211
feixu911
帖子: 53
注册时间: 2006-04-21 18:31
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 feixu911 » 2006-08-07 21:14

谢谢楼主的贡献呀!!一直编译不过去,看了你的贴才知道是gcc版本问题。哎!!
头像
oliver
帖子: 775
注册时间: 2005-10-05 11:31
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 oliver » 2006-08-16 20:35

安装libgtk2.0-dev包的时候无法处理依赖关系。

代码: 全选

oliver@ubuntu:~$ sudo apt-get install libgtk2.0-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  libgtk2.0-dev: 依赖: libpango1.0-dev (>= 1.10.0-2) 但是它将不会被安装
                 依赖: libcairo2-dev 但是它将不会被安装
E: 无法安装的软件包
oliver@ubuntu:~$


代码: 全选

oliver@ubuntu:~$ sudo apt-get install libpango1.0-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  libpango1.0-dev: 依赖: libcairo2-dev (>= 1.0.0) 但是它将不会被安装
E: 无法安装的软件包
oliver@ubuntu:~$

等等...我尝试将提示需要的包一一安装,但是下面还是无法继续下去。


:(
kejinlu
帖子: 9
注册时间: 2006-08-23 20:02
送出感谢: 0
接收感谢: 0

#8

帖子 kejinlu » 2006-08-28 23:50

很好
头像
haige
帖子: 315
注册时间: 2006-03-16 16:29
送出感谢: 0
接收感谢: 0

支持,顶顶

#9

帖子 haige » 2006-08-30 20:14

谢谢,继续努力
LittleLing
帖子: 20
注册时间: 2006-08-24 14:53
送出感谢: 0
接收感谢: 0

#10

帖子 LittleLing » 2006-09-07 12:12

sudo apt-get install beep-media-player

這句不能用,我的版本是6.061,是否要安裝其他的package?

我已經安裝了debian 的安裝package
boxuan1128
帖子: 11
注册时间: 2006-09-21 12:38
来自: 天津市
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 boxuan1128 » 2006-09-21 15:15

无法找到 beep-media-player?
gren
帖子: 132
注册时间: 2006-12-01 16:42
来自: 金城
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 gren » 2006-12-09 17:25

我刚刚接触ubuntu还不知道怎么去编译,按照楼主的办法竟然成功了,大大增强了,我学习linux的信心,楼主真是好人阿!!!谢谢了阿!!!缘分阿!!!
Rbocid
帖子: 12
注册时间: 2006-12-17 19:38
送出感谢: 0
接收感谢: 0

#13

帖子 Rbocid » 2006-12-20 13:54

oliver 写了:安装libgtk2.0-dev包的时候无法处理依赖关系。

代码: 全选

oliver@ubuntu:~$ sudo apt-get install libgtk2.0-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  libgtk2.0-dev: 依赖: libpango1.0-dev (>= 1.10.0-2) 但是它将不会被安装
                 依赖: libcairo2-dev 但是它将不会被安装
E: 无法安装的软件包
oliver@ubuntu:~$


代码: 全选

oliver@ubuntu:~$ sudo apt-get install libpango1.0-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  libpango1.0-dev: 依赖: libcairo2-dev (>= 1.0.0) 但是它将不会被安装
E: 无法安装的软件包
oliver@ubuntu:~$

等等...我尝试将提示需要的包一一安装,但是下面还是无法继续下去。


:(

我跟你一样无法依赖阿
ghostpainter
帖子: 1
注册时间: 2006-12-26 11:48
送出感谢: 0
接收感谢: 0

#14

帖子 ghostpainter » 2006-12-26 19:01

非常感谢!帮了我大忙!!
boywhy
帖子: 19
注册时间: 2008-03-05 11:59
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 boywhy » 2008-03-05 15:24

这个是因为 ???

代码: 全选

make  all-recursive
make[1]: Entering directory `/home/dengos/bmp-wma-0.1.1'
Making all in src
make[2]: Entering directory `/home/dengos/bmp-wma-0.1.1/src'
Making all in libffwma
make[3]: Entering directory `/home/dengos/bmp-wma-0.1.1/src/libffwma'
make[3]: 没有什么可以做的为 `all'。
make[3]: Leaving directory `/home/dengos/bmp-wma-0.1.1/src/libffwma'
Making all in wma123
make[3]: Entering directory `/home/dengos/bmp-wma-0.1.1/src/wma123'
make[3]: 没有什么可以做的为 `all'。
make[3]: Leaving directory `/home/dengos/bmp-wma-0.1.1/src/wma123'
make[3]: Entering directory `/home/dengos/bmp-wma-0.1.1/src'
/bin/bash ../libtool --mode=link gcc-3.4 -DPNG_NO_MMX_CODE -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/libpng12   -I./libffwma -L./libffwma -g -O2    -o libwma.la -rpath /usr/lib/bmp/Input -module -avoid-version bmp-wma.lo iir.lo  -lbeep -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lfontconfig -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage -lpango-1.0 -lcairo -lX11 -lXfixes -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0   -lffwma
gcc-3.4 -shared  .libs/bmp-wma.o .libs/iir.o  -L/usr/lib -L/home/dengos/bmp-wma-0.1.1/src/libffwma /usr/lib/libbeep.so /usr/lib/libgtk-x11-2.0.so /usr/lib/libgdk-x11-2.0.so /usr/lib/libatk-1.0.so /usr/lib/libgdk_pixbuf-2.0.so -lm /usr/lib/libpangocairo-1.0.so -lfontconfig -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage /usr/lib/libpango-1.0.so /usr/lib/libcairo.so -lX11 -lXfixes /usr/lib/libgobject-2.0.so /usr/lib/libgmodule-2.0.so -ldl /usr/lib/libglib-2.0.so -lffwma  -Wl,-soname -Wl,libwma.so -o .libs/libwma.so
/usr/bin/ld: /home/dengos/bmp-wma-0.1.1/src/libffwma/libffwma.a(libffwma_a-allcodecs.o): relocation R_X86_64_32 against `wmav1_decoder' can not be used when making a shared object; recompile with -fPIC
/home/dengos/bmp-wma-0.1.1/src/libffwma/libffwma.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[3]: *** [libwma.la] 错误 1
make[3]: Leaving directory `/home/dengos/bmp-wma-0.1.1/src'
make[2]: *** [all-recursive] 错误 1
make[2]: Leaving directory `/home/dengos/bmp-wma-0.1.1/src'
make[1]: *** [all-recursive] 错误 1
make[1]: Leaving directory `/home/dengos/bmp-wma-0.1.1'
make: *** [all] 错误 2
回复

回到 “老旧版本支持”