ubuntu里没有make命令吗?

为当前最终发行版之前的所有版本提供支持
回复
头像
yjcong
帖子: 2470
注册时间: 2006-02-28 3:11
送出感谢: 0
接收感谢: 0

ubuntu里没有make命令吗?

#1

帖子 yjcong » 2006-06-30 21:39

连vpn网, 需要下一些ubuntu源里没有的东西, 其中一个是tar.gz, tar后,需要用make装, 但终端显示无此命令. man也没有反应. 难道在ubuntu里就不能装ubuntu源里没有,且必须用make装的软件吗?

还有一个是.rpm的, dpkg -b 后,显示没有deb用的文件, 转换不了, 我该怎么办?
cutefox.png
cutefox.png (164.22 KiB) 查看 5071 次
上次由 yjcong 在 2009-06-18 19:21,总共编辑 1 次。
头像
bricksun
帖子: 85
注册时间: 2006-05-13 8:17
来自: 比京
送出感谢: 0
接收感谢: 0

#2

帖子 bricksun » 2006-06-30 21:42

应该安装 build-essential开发工具包
第二个问题就不知道了
Vstar
帖子: 273
注册时间: 2005-10-03 14:13
来自: Tokushima, Japan
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 Vstar » 2006-06-30 21:46

sudo apt-get install make
sudo apt-get install alien
可以用alien将rpm文件转为deb文件
致虚极,守静笃
头像
yjcong
帖子: 2470
注册时间: 2006-02-28 3:11
送出感谢: 0
接收感谢: 0

#4

帖子 yjcong » 2006-06-30 23:19

谢谢2楼, 但我现在连不了网, build-ess 需要很多的东西, 所以现在还是用不了.

谢谢3楼, 因为上不了网, apt-get的命令不起作用;在5-10里是有alien命令的, 而且我用过,但在6-04里,没有反应, man也一样.
头像
yjcong
帖子: 2470
注册时间: 2006-02-28 3:11
送出感谢: 0
接收感谢: 0

#5

帖子 yjcong » 2006-06-30 23:23

谢谢2楼, 但我现在连不了网, build-ess 需要很多的东西, 所以现在还是用不了.

谢谢3楼, 因为上不了网, apt-get的命令不起作用;在5-10里是有alien命令的, 而且我用过,但在6-04里,没有反应, man也一样.

下了个make的文件, 装了, 但运行的时候显示下面的东西, 又是什么原因呢?

root@yc002:/home/oem/programme/1/pptp-1.7.1# make
gcc -Wall -O0 -g -c -o pptp.o pptp.c
make: gcc:命令未找到
make: *** [pptp.o] 错误 127
root@yc002:/home/oem/programme/1/pptp-1.7.1#
614a
帖子: 42
注册时间: 2006-06-16 2:39
送出感谢: 0
接收感谢: 0

#6

帖子 614a » 2006-06-30 23:48

make只是用来帮助配置编译参数、调用编译命令的,需要安装gcc编译器才能编译。
网络不好的话还是安装dvd版本,不用通过网络下东西。
头像
yjcong
帖子: 2470
注册时间: 2006-02-28 3:11
送出感谢: 0
接收感谢: 0

#7

帖子 yjcong » 2006-07-01 15:45

我是装得dvd版本呀, 难道我可以从dvd里copy这些东西吗?
回复

回到 “老旧版本支持”