[问题]请教一下ubuntu下安装QQ的问题

为当前最终发行版之前的所有版本提供支持
xzymail
帖子: 513
注册时间: 2006-06-29 11:36
送出感谢: 0
接收感谢: 0

[问题]请教一下ubuntu下安装QQ的问题

#1

帖子 xzymail » 2006-07-02 10:33

我刚装了个QQ,可是一点登录就老登录不了,是不是还没有装java的关系,可是我的装了很多遍java了,到那个www.sun.com.cn找安装过程的,可是老装不下呀,用sudo update-alternatives --config java还只是显示
There are 2 alternatives which provide `java'.

Selection Alternative
-----------------------------------------------
1 /usr/bin/gij-wrapper-4.1
*+ 2 /usr/lib/jvm/java-gcj/jre/bin/java
偶现在是在www.sun.com.cnh上下载的jre-1_5_0_07-linux-i586-rpm.bin,我是该下前面带“jre"的还是“jdk"的?请教各位大虾一下,我应该怎么做?
www0320
帖子: 4
注册时间: 2006-07-01 10:18
送出感谢: 0
接收感谢: 0

#2

帖子 www0320 » 2006-07-02 10:37

安装JAVA环境

*

sudo apt-get install sun-java5-jre
# 如果空间富裕,建议安装一个JDK。呵呵
sudo apt-get install sun-java5-jdk

设置当前默认的java解释器

*

sudo update-alternatives --config java

会出现可能如下的画面:

There are 4 alternatives which provide `java'.

Selection Alternative
-----------------------------------------------
*+ 1 /usr/lib/jvm/java-gcj/jre/bin/java
2 /usr/bin/gij-wrapper-4.1
3 /usr/bin/gij-wrapper-4.0
4 /usr/lib/jvm/java-1.5.0-sun/jre/bin/java

Press enter to keep the default[*], or type selection number:

输入 有包含 "sun" 的行的前面的数字。如上面显示,则输入 4,然后回车确定。
www0320
帖子: 4
注册时间: 2006-07-01 10:18
送出感谢: 0
接收感谢: 0

#3

帖子 www0320 » 2006-07-02 10:38

安装QQ

*

1.下载并安装
*

安装QQ需要先安装上一步的JAVA环境

wget -c http://download.ubuntu.org.cn/software/ ... jre.tar.gz
sudo tar zxvf lumaqq_2005-linux_gtk2_x86_no_jre.tar.gz -C /opt/
wget -c http://download.ubuntu.org.cn/software/ ... .15.00.zip
sudo unzip -o lumaqq_2005_patch_2006.02.02.15.00.zip -d /opt/LumaQQ/lib
sudo chown -R root:root /opt/LumaQQ/
sudo chmod -R 755 /opt/LumaQQ/
sudo gedit /usr/share/applications/LumaQQ.desktop

2.在新增的文件内加入下面这几行

[Desktop Entry]
Name=LumaQQ
Comment=QQ Client
Exec=/opt/LumaQQ/lumaqq
Icon=/opt/LumaQQ/QQ.png
Terminal=false
Type=Application
Categories=Application;Network;

3.保存编辑过的文件 安装完成后的快捷方式在(应用程序 -> internat -> LumaQQ)。
xzymail
帖子: 513
注册时间: 2006-06-29 11:36
送出感谢: 0
接收感谢: 0

#4

帖子 xzymail » 2006-07-02 22:17

请问一下,我真的是弄了超久了咯,我是在那个www.sun.com找方法的咯,可是老是弄不好啊,我是按它里边提到的命令装的,可还是不行呀,怎么办啊??
还有,再请教一下,“JDK”和“JRE”有什么分别呀,不是都是java吗?装个“JKD”要多大的空间,意思是不是说根目录要分大点啊??
我装这个的时候,我是按照下载下来的安装盘装的,还有,装“JKD”的“/”根目录是不是要大一点的,我是按他里边的默认自动分区分的,不会有问题吧?

这两天很喜欢linux的,可是老弄不好,哎~~~~~~~~
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 karron » 2006-07-03 10:00

你按照楼上得方法安装吧.扩展名为rpm得包是给redhat系列得linux用得.ubuntu不能直接使用.

建议你到 wiki.ubuntu.org.cn上面把快速设置指南好好看看,按照上面一步步做下去.就不会浪费这么多时间了.

另外jdk是给需要开发java得人使用的,jre只是一个运行环境.jdk应该占用空间要比jre大.建议你的linux分区在5G以上,免得出现空间不足的情况.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
Rainkero
帖子: 72
注册时间: 2006-06-23 0:50
来自: 重庆
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 Rainkero » 2006-07-03 14:29

用新立得查找安装JAVA 很简单那
xzymail
帖子: 513
注册时间: 2006-06-29 11:36
送出感谢: 0
接收感谢: 0

#7

帖子 xzymail » 2006-07-04 10:05

我是按照楼上的命令的啊,在终端里打进“sudo apt-get install sun-j2sdk1.5”,
可是接着说找不到“sun-j2sdk1.5”这是怎么了呀,是不是说要自己手动到www.sun.com.cn上下载jre啊??
楼上的说在新立得里面可以安装,那是怎么样个安装法,谢谢!
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 karron » 2006-07-04 10:16

在你的系统菜单里面找到新立得软件包管理器,然后点击搜索,输入java5,然后把带有jdk字样的那行前面的框打个勾,然后再点击右下角的应用或者apply的按钮,就会自动安装了.

另外,我没有看到楼上说过包名是 sun-j2sdk1.5,你好好看看前面的,人家是sun-java5-jdk .


这些问题在wiki.ubuntu.org.cn都有解决方法,我再次建议你把那篇文章好好看看,你前后已经过去2天多了,就为这个问题.难道都没有时间去看一下文档吗?

我怕你时间紧,一时半会儿找不到,把连接放在下面,抽空看看吧.

http://wiki.ubuntu.org.cn/%E5%BF%AB%E9% ... apperDrake
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
xzymail
帖子: 513
注册时间: 2006-06-29 11:36
送出感谢: 0
接收感谢: 0

#9

帖子 xzymail » 2006-07-05 15:30

很谢谢你们!
一定抽时间去看你给的文档,谢谢你咯`!!!!
ovo60
帖子: 29
注册时间: 2006-02-04 16:17
来自: 深圳
送出感谢: 0
接收感谢: 0

#10

帖子 ovo60 » 2006-07-05 16:07

装EVA吧
个人觉得比Luma QQ好用。
Luma启动慢,占资源。
Athlon64 3000+
ubuntu 6.06 AMD 64bit
xzymail
帖子: 513
注册时间: 2006-06-29 11:36
送出感谢: 0
接收感谢: 0

#11

帖子 xzymail » 2006-07-06 21:20

天啊,说真的,我真的是按你们的命令打进去了,sudo apt-get install sun-java5-jre
可是就是说找不到“sun-java5-jre"啊,真的,我晕了,
哎呀 ,怎么办啊??
xzymail
帖子: 513
注册时间: 2006-06-29 11:36
送出感谢: 0
接收感谢: 0

#12

帖子 xzymail » 2006-07-06 21:22

晕,还有啊,我在新立得里打上“java5"然后一个也找不到啊
我要怎么样才能装上呢???

再次请教,谢谢!!!
头像
betsyalan
帖子: 3
注册时间: 2006-07-05 14:49
送出感谢: 0
接收感谢: 0

#13

帖子 betsyalan » 2006-07-07 10:15

sudo apt-get install sun-java5-jre
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 无法找到软件包 sun-java5-jre

我也出现同样的问题,在新立得里查找JAVA5没东西。
头像
Bailuhuaxiang
帖子: 96
注册时间: 2006-03-24 18:27
送出感谢: 0
接收感谢: 0

#14

帖子 Bailuhuaxiang » 2006-07-07 10:17

用的是什么源?
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 karron » 2006-07-07 10:30

请修改源.......

拜托各位,抽点时间,找点空闲,看看上面,我给的连接,从头到尾,做一遍.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
回复

回到 “老旧版本支持”