UBunu与Debian共存问题,ubuntu无法安装!在线急等啊!问题未解决。yongyi请进,oneleaf看一下吧

为当前最终发行版之前的所有版本提供支持
回复
头像
antiok
帖子: 67
注册时间: 2005-07-31 11:37
送出感谢: 0
接收感谢: 0

UBunu与Debian共存问题,ubuntu无法安装!在线急等啊!问题未解决。yongyi请进,oneleaf看一下吧

#1

帖子 antiok » 2005-08-09 13:15

再次向各位大大求助,我的Ubuntu5.04无法安装了!
具体情况是,我下载了Debian 3.1 roa i386的第一张iso,安装顺序是这样的,先安装Debian到sda9,安装时选择2.6的内核,将Debian的Grub做到了软盘上,安装好后可从软盘启动到Debian的Grub。
然后开始安装Ubunu 5.04,刚开始都好好的,在磁盘分区时选择安装到sda10,同时将/分区挂载到sda10,格式化为Ext3,启动标志为关,然后还都没问题,可是到在安装Grub的时候就出了问题,安装程序显示找到了以下系统Debian、Fedora Core 和Windows XP,我选择不将Grub安装到Mbr,然后选择将其安装到/dev/sda10,然后系统就出现红色屏幕及字幕,说安装程序出现错误,无法将Grub安装到硬盘上!安装就无法进行了!后来我再次重新用光盘启动安装,这次选择将Grub安装到软盘/dev/fd0上,出现上次一样的提示,安装还是无法继续!

后来我又用安装光盘启动,将安装Ubunu所在的分区的启动标志打开也不行,就是卡在安装Grub那里了,老是出现红屏说install安装程序出现错误,无法安装Grub!
呜。。。到底怎么回事啊!我上个星期装的时候就没有这样的问题,上次一路回车Ubunu就装上了,那时候我的机器上还没有安装Debian,但是已经有Fedora Core和Windows,安装程序在安装Grub的时候就可以安装到Ubunu所在的分区的!
这次装好Debian后再装Ubunu到安装Grub的时候就不行了,百思不得其解,我就联想到是不是这两个系统不能共存?应该不会这样吧,也没有道理啊。
盼望大家给我指点一下!!!

附上我的磁盘分区:
/dev/sda1 Winxp 活动 NTFS
/dev/sda2 Win2003 NTFS
/dev/sda8 Fedora Core 4 Ext3
/dev/sda9 Debian 3.1 ro Ext3
/dev/sda10 分给ubunu的,装不上 :cry:

在线急等大家帮助!!!
上次由 antiok 在 2005-08-09 21:29,总共编辑 4 次。
头像
oneleaf
论坛管理员
帖子: 10213
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 101 次

#2

帖子 oneleaf » 2005-08-09 13:40

grub-install 有时会出安装不上去的问题,可以忽略,在后面手工安装grub。具体搜索 grub
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
头像
antiok
帖子: 67
注册时间: 2005-07-31 11:37
送出感谢: 0
接收感谢: 0

#3

帖子 antiok » 2005-08-09 18:14

能说的详细点吗?怎么手工弄啊?上次没这种问题的,是不和Debian冲突啊
头像
oneleaf
论坛管理员
帖子: 10213
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 101 次

#4

帖子 oneleaf » 2005-08-09 18:45

因为你在debian中已经安装了GRUB,所以会失败。

不过你既然已经有了grub,直接使用debian的grub就好了,加入ubuntu的启动项。
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
头像
antiok
帖子: 67
注册时间: 2005-07-31 11:37
送出感谢: 0
接收感谢: 0

#5

帖子 antiok » 2005-08-09 20:27

谢谢大大,有个疑问我还是不清楚,你说的冲突,为什么会出现?我装Debian的时候Debian的Grub是安装在Debian所在的分区sda9上的,为什么ubuntu的Grub就不能安装在它所在的分区sda10上呢?

顺便再问一下,怎样在Debian的Grub中加上Ubunu的启动项呢?
头像
yonsan
帖子: 887
注册时间: 2005-07-01 18:56
来自: 广州市
送出感谢: 0
接收感谢: 3 次

#6

帖子 yonsan » 2005-08-09 20:31

看来grub问题要整理成专贴才行了!其实在论坛或主页上搜索一下也应该可以解决这个问题!
I will be back!
头像
antiok
帖子: 67
注册时间: 2005-07-31 11:37
送出感谢: 0
接收感谢: 0

#7

帖子 antiok » 2005-08-09 20:43

大大具体解释一下好吗,我都搜索了3页也没找到啊!!!
有个疑问我还是不清楚,你说的冲突,为什么会出现?我装Debian的时候Debian的Grub是安装在Debian所在的分区sda9上的,为什么ubuntu的Grub就不能安装在它所在的分区sda10上呢?
请解释一下这个疑问好吗?

还有怎样在Debian的Grub中加上Ubunu的启动项呢?具体怎么做能写出步骤吗?谢谢!!!
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 yongyi » 2005-08-09 20:56

http://forum.ubuntu.org.cn/viewtopic.ph ... light=grub

参考下oneleaf的帖子。
因为你现在有debian的GRUB了,可以直接:
手工输入启动命令
例如:

代码: 全选

root (hd0,0) 
kernel /vmlinuz-2.6.10-5-686 root=/dev/hdb5 ro quiet splash
initrd /initrd.img-2.6.10-5-686
savedefault
boot

然后进入后就修改menu.lst


或者。。。。哦!
你可以进入debian,修改menu.lst ,相应地加入ubuntu的就行了吧?
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
antiok
帖子: 67
注册时间: 2005-07-31 11:37
送出感谢: 0
接收感谢: 0

#9

帖子 antiok » 2005-08-09 21:03

谢谢大大,那这个问题是什么原因呢?
我装Debian的时候Debian的Grub是安装在Debian所在的分区sda9上的,为什么ubuntu的Grub就不能安装在它所在的分区sda10上呢?
请解释一下这个疑问好吗?
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 yongyi » 2005-08-09 21:19

我装Debian的时候Debian的Grub是安装在Debian所在的分区sda9上的,为什么ubuntu的Grub就不能安装在它所在的分区sda10上呢?
请解释一下这个疑问好吗?

这不清楚呀。
我还没在一硬盘上安装这么多的grub(并且是同一种的grub)。或者像你说的,冲突。因为ubuntu安装程序也是用debian installer 的。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
antiok
帖子: 67
注册时间: 2005-07-31 11:37
送出感谢: 0
接收感谢: 0

#11

帖子 antiok » 2005-08-09 21:25

我考虑只可能是和Debian的冲突,上个星期我先装好了Fedora Core 4,然后再装Ubunu就没问题的!Grub可以安装到Ubunu的分区上。

大大看一下我的这个分析:
就是同一个硬盘上同一个Grub只能装一种啊?Ubunu的安装程序检测出我的硬盘上已经有了Debian的Grub,所以安装程序无法进行下去。
如果是2块硬盘就应该可以了吧。

希望oneleaf大大也来看一下。
头像
oneleaf
论坛管理员
帖子: 10213
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 101 次

#12

帖子 oneleaf » 2005-08-09 21:36

也许吧,我不敢确定。
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 yongyi » 2005-08-09 21:40

可以使用grub for dos + ubuntu 自带的grub。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
回复

回到 “老旧版本支持”