[问题]请教,为什么ubuntu安装启动后一直显示Buffer I/O error这样的文字?

为当前最终发行版之前的所有版本提供支持
回复
violayoung
帖子: 3
注册时间: 2006-06-30 11:22
送出感谢: 0
接收感谢: 0

[问题]请教,为什么ubuntu安装启动后一直显示Buffer I/O error这样的文字?

#1

帖子 violayoung » 2006-07-04 10:46

我的机器安装前有windows xp和red hat9两个系统,两个系统进入都没有问题。我用下载的ubuntu-6.06-desktop-i386.iso文件刻盘进行安装,可以进入图形安装界面,选择第一项“启动”后它显示加载内核,然后loading essential drivers显示ok,再往下从mounting root file system就开始有问题,不停的从屏幕上显示
[4294798.876000] Buffer I/O error on device hdb,logical block1
...
这样的信息,不知道是怎么回事,还请高手指点!
不知道是不是跟以前的系统有关系,我的硬盘一共30g,一共分了三个盘,前两个盘用于winxp,最后一块划给了linux
另外后来我又尝试用pqmagic把linux 的分区重新变为fat32分区,又重装了一遍winxp,用ubuntu光盘安装还是出现如上的问题。
我对linux的知识实在实在有限,希望大家帮我看看问题在哪里,多谢了!
yanxizhen
帖子: 28
注册时间: 2005-06-23 20:25
送出感谢: 0
接收感谢: 0

#2

帖子 yanxizhen » 2006-07-05 15:36

你硬盘是sata的么
614a
帖子: 42
注册时间: 2006-06-16 2:39
送出感谢: 0
接收感谢: 0

#3

帖子 614a » 2006-07-05 15:47

哪里有30G的sata,我估计楼主的hda是硬盘,hdb是光驱。如果hdb出现I/O错误,是不是光盘刻录的问题?用刻录软件检查一下光盘,或启动linux时check CD。
violayoung
帖子: 3
注册时间: 2006-06-30 11:22
送出感谢: 0
接收感谢: 0

#4

帖子 violayoung » 2006-07-05 16:36

查了一下,硬盘型号是IBM-DTLA-307030,我也不清楚是不是sata的,不太懂,不过我自己觉得hdb是windows的第二个分区

另外三楼说光盘的问题,是不是指iso文件的md5码的验证?如果是这个,这个我验证过了,若不是,怎么检查光盘?
614a
帖子: 42
注册时间: 2006-06-16 2:39
送出感谢: 0
接收感谢: 0

#5

帖子 614a » 2006-07-05 17:20

Usage: fdisk [-l] [-b SSZ] [-u] device
E.g.: fdisk /dev/hda (for the first IDE disk)
or: fdisk /dev/sdc (for the third SCSI disk)
or: fdisk /dev/eda (for the first PS/2 ESDI drive)
or: fdisk /dev/rd/c0d0 or: fdisk /dev/ida/c0d0 (for RAID devices)
现在市场上普通硬盘有两种,一种是并口的PATA硬盘,用的是IDE接口,另一种是串口的SATA硬盘,用的是SATA接口。IDE接口的设备(并口硬盘及非usb光驱)在linux里设备号是hd开头,SATA接口的设备(还包括服务器硬盘的SCSI接口)是sd开头。串口硬盘(非服务器硬盘)容量一般至少80G,你的硬盘容量只有30G,所以我说是普通的并口硬盘。

hda里的a指第一个IDE设备,hdb里的b指第二个IDE设备。你的硬盘是hda,那么光驱就应该是hdb了。现在hdb读取错误,可能就是光盘刻录出错。用ubuntu光盘启动后,菜单里有个check cd选项,可以检查光盘是否有问题。如果你有nero刻录软件,也可以用nero带的工具nero CD-DVD speed里的Scandisk来检查光盘是否有刻录问题。若刻录有问题则重新刻录。

linux下分区叫hda1、hda2等,从1开始。一般c盘为hda1,d盘为hda5,e盘为hda6,依此类推。

另外,我的nec 3540A DVD刻录机读取刻录的ubuntu的盘不行,先锋121DVD光驱读nec刻的盘没问题。我用的是可擦写的cd,不知道是盘的问题,iso镜像的问题,还是刻录机读盘能力的问题,毕竟只有刻ubuntu的镜像才出问题,刻window多个版本镜像都没问题。
violayoung
帖子: 3
注册时间: 2006-06-30 11:22
送出感谢: 0
接收感谢: 0

#6

帖子 violayoung » 2006-07-06 10:11

恩,多谢楼上的了,我回去再检查一下光盘,知道不是硬盘的问题我就放心拉,呵呵
btw,我用的是nero的刻录机,以前刻的镜像盘都没有问题的
回复

回到 “老旧版本支持”