关于libc的问题

为当前最终发行版之前的所有版本提供支持
回复
cnhzcy14
帖子: 30
注册时间: 2006-04-06 16:40
送出感谢: 0
接收感谢: 0

关于libc的问题

#1

帖子 cnhzcy14 » 2006-07-16 11:39

如果一个软件需要低版本的libc,除了降级外,还有其他办法吗?为什么低版本的和高版本的不兼容,或者说程序能在低版本的libc环境下运行,为什么就不能在高版本的libc运行呢?
头像
oneleaf
论坛管理员
帖子: 10226
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 103 次

#2

帖子 oneleaf » 2006-07-16 14:05

因为linux下的函数考虑向前兼容的比较差. 可以找找补丁,然后自己重新编译.
头像
madoldman
帖子: 599
注册时间: 2006-02-27 20:19
来自: works system
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 madoldman » 2006-07-16 14:59

不一定要降级阿,有时,把高版本做一个链接就可以,如果不行,可以从别人机器上复制一个低版本的so文件过来就可以了,不过在Ubuntu下一般都是用apt-get装东西,很少这样了,记得以前用FC4的时候,经常出现这样的问题,那时就在虚拟机里装了一个rh9,需要低版本的库时就从rh9里面复制,呵呵
东西路,南北走
十字路口人咬狗
拿起狗来打砖头
砖头咬了狗一口
图片
cnhzcy14
帖子: 30
注册时间: 2006-04-06 16:40
送出感谢: 0
接收感谢: 0

#4

帖子 cnhzcy14 » 2006-07-16 19:15

具体应该如何加链接?我的软件需要2.3.2<=libc<=2.3.4,需要copy哪几个so文件?可以copy到这些需要老版libc软件自己的安装目录下吗?
头像
madoldman
帖子: 599
注册时间: 2006-02-27 20:19
来自: works system
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 madoldman » 2006-07-18 0:06

copy到/usr/lib下就可以了
东西路,南北走
十字路口人咬狗
拿起狗来打砖头
砖头咬了狗一口
图片
回复

回到 “老旧版本支持”