安装 xfonts-wqy 失败,之后每次运行sudo apt-get install 都会重新配置 xfonts-wq

为当前最终发行版之前的所有版本提供支持
回复
lgc653
帖子: 5
注册时间: 2006-07-17 12:00
送出感谢: 0
接收感谢: 0

安装 xfonts-wqy 失败,之后每次运行sudo apt-get install 都会重新配置 xfonts-wq

#1

帖子 lgc653 » 2006-07-17 12:08

安装xfonts-wqy失败(实际上已经成功,但是在运行配置时失败,用的xfonts-wqy_0.7.0-6-1_all.deb,文件都安装成功了,但是提示处理 xfonts-wqy (--configure)时出错: 子进程 post-installation script 被信号(中断)终止了)

系统字体这时候已经可以正常使用了。新立得软件管理器里面也显示安装成功了。
但是每次运行sudo apt-get install 命令时,总是提示“有 1 个软件包没有被完全安装或卸载。”,然后系统又开始重新配置xfonts-wqy,然后再次配置失败。

请问是否有办法
1、将xfonts-wqy完整的安装成功。
2、每次运行sudo apt-get install 时不再运行xfontswqy未完成的安装。
头像
drivel
帖子: 1917
注册时间: 2006-07-08 9:21
来自: University of Science and Technology Beijing
送出感谢: 1 次
接收感谢: 0
联系:

#2

帖子 drivel » 2006-07-17 12:24

lgc653
帖子: 5
注册时间: 2006-07-17 12:00
送出感谢: 0
接收感谢: 0

#3

帖子 lgc653 » 2006-07-17 12:49

谢谢这位兄弟,我主要目的是想知道通过sudo apt-get install 命令安装软件的一些细节。
gmlbh
帖子: 406
注册时间: 2006-03-21 10:47
送出感谢: 0
接收感谢: 0

#4

帖子 gmlbh » 2006-07-17 13:06

我也有这种情况,想把它卸了可是卸不了,不知道为什么?
lgc653
帖子: 5
注册时间: 2006-07-17 12:00
送出感谢: 0
接收感谢: 0

#5

帖子 lgc653 » 2006-07-17 14:52

是啊,以后每次安装,卸载软件,他都要执行一遍,相当讨厌。不知如何处理。
头像
oneleaf
论坛管理员
帖子: 10207
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#6

帖子 oneleaf » 2006-07-17 16:53

在新立得找到损坏的包,删除。
lgc653
帖子: 5
注册时间: 2006-07-17 12:00
送出感谢: 0
接收感谢: 0

#7

帖子 lgc653 » 2006-07-17 17:05

新立得里面显示的是安装成功了。
头像
oneleaf
论坛管理员
帖子: 10207
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#8

帖子 oneleaf » 2006-07-17 17:46

点彻底删除后,再手工使用 dpkg -i 安装一次试试,我这边测试没有问题。
lgc653
帖子: 5
注册时间: 2006-07-17 12:00
送出感谢: 0
接收感谢: 0

#9

帖子 lgc653 » 2006-07-17 18:03

现在删除都无法删除,每次删除到最后都报安装时一样的错误。
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 zhan » 2006-07-18 18:20

先 apt-get -f install 试试
如果不行
dpkg --purge xfonts-wqy 应该可以删除的。
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
turbohead
帖子: 58
注册时间: 2006-07-07 19:12
送出感谢: 0
接收感谢: 0

#11

帖子 turbohead » 2006-07-23 22:48

我也很遇到了类似问题,但是我是安装mldonkey-server的时候发生的
sudo apt-get remove/install 任何软件的时候都会出现下面的错误

代码: 全选

Install
正在设置 mldonkey-server (2.7.1-2ubuntu2) ...
Starting MLDonkey: mlnetinstall: invalid option -- f
请尝试执行“install --help”来获取更多信息。
invoke-rc.d: initscript mldonkey-server, action "start" failed.
dpkg:处理 mldonkey-server (--configure)时出错:
 子进程·post-installation script·返回了错误号·1
在处理时有错误发生:
 mldonkey-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Remove
正在删除 mldonkey-server ...
Stopping MLDonkey: mlnetNo process in pidfile `/var/run/mlnet.pid' found running; none killed.
invoke-rc.d: initscript mldonkey-server, action "stop" failed.
dpkg:处理 mldonkey-server (--remove)时出错:
 子进程·pre-removal script·返回了错误号·1
Starting MLDonkey: mlnetinstall: invalid option -- f
请尝试执行“install --help”来获取更多信息。
invoke-rc.d: initscript mldonkey-server, action "start" failed.
dpkg: 作下列清理工作时发生错误:
 子进程·post-installation script·返回了错误号·1
在处理时有错误发生:
 mldonkey-server

现在不论用什么方法都删不掉,不知道为什么,有人知道该怎么办吗??
turbohead
帖子: 58
注册时间: 2006-07-07 19:12
送出感谢: 0
接收感谢: 0

#12

帖子 turbohead » 2006-07-23 23:40

同样的问题,大家一起汇到这个帖子吧,看看有人能解决不
http://forum.ubuntu.org.cn/viewtopic.ph ... B%E7%A8%8B
FangQ
帖子: 240
注册时间: 2006-03-05 13:50
送出感谢: 0
接收感谢: 0

#13

帖子 FangQ » 2006-07-24 0:09

事实上,最有效的方法是直接写信给这个包的维护者,carlos和caiqian,或者在package的bug-report页面报告这个bug。

http://packages.ubuntulinux.org/dapper/x11/xfonts-wqy
https://launchpad.net/distros/ubuntu/+s ... -wqy/+bugs

http://packages.debian.org/testing/x11/xfonts-wqy
http://bugs.debian.org/cgi-bin/pkgrepor ... xfonts-wqy
turbohead
帖子: 58
注册时间: 2006-07-07 19:12
送出感谢: 0
接收感谢: 0

#14

帖子 turbohead » 2006-07-24 17:35

恩,我也是在bug tracker上面找到了解决的办法,写在12楼我发布的那个帖子里了,不知道有用没有
rhhsun
帖子: 63
注册时间: 2006-09-18 23:14
送出感谢: 0
接收感谢: 0

楼主,你的问题解决了吗?

#15

帖子 rhhsun » 2006-09-18 23:24

我现在也有同样的问题,xfonts-wqy 装不完,删也删不掉,
更重要的是现在不能再安装和删除任何软件了!

sudo dpkg -i xfonts-wqy_0.7.0-6-1_all.deb

(正在读取数据库 ... 系统当前总共安装有 168746 个文件和目录。)
正预备替换 xfonts-wqy 0.7.0-6-1 (使用 xfonts-wqy_0.7.0-6-1_all.deb) ...
正在解压缩将用于更替的包文件 xfonts-wqy ...
usage error: unrecognized option
Usage: update-fonts-dir DIRECTORY ...
update-fonts-dir { -h | --help }
This program is a wrapper for mkfontdir(1x) that is primarily useful to Debian
package maintainer scripts. See update-fonts-dir(8) for more information.
Options:
-h, --help display this usage message and exitdpkg:警告 - 原先的 post-removal 脚本 退出时返回了错误号 2
dpkg - 现转而试用新软件包所带的脚本...
usage error: unrecognized option
Usage: update-fonts-dir DIRECTORY ...
update-fonts-dir { -h | --help }
This program is a wrapper for mkfontdir(1x) that is primarily useful to Debian
package maintainer scripts. See update-fonts-dir(8) for more information.
Options:
-h, --help display this usage message and exitdpkg:处理 xfonts-wqy_0.7.0-6-1_all.deb (--install)时出错:
子进程·新的 post-removal 脚本·返回了错误号·2
usage error: unrecognized option
Usage: update-fonts-dir DIRECTORY ...
update-fonts-dir { -h | --help }
This program is a wrapper for mkfontdir(1x) that is primarily useful to Debian
package maintainer scripts. See update-fonts-dir(8) for more information.
Options:
-h, --help display this usage message and exitdpkg: 作下列清理工作时发生错误:
子进程·post-removal script·返回了错误号·2
在处理时有错误发生:
xfonts-wqy_0.7.0-6-1_all.deb

sudo apt-get remove xfonts-wqy

正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 软件包 xfonts-wqy 需要重新安装,但是我无法找到相应的安装文件。

sudo apt-get install xfonts-wqy

正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 软件包 xfonts-wqy 需要重新安装,但是我无法找到相应的安装文件。

sudo apt-get install update
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 软件包 xfonts-wqy 需要重新安装,但是我无法找到相应的安装文件。

难道只能重装系统吗?
回复

回到 “老旧版本支持”