apt-get upgrade有问题

为当前最终发行版之前的所有版本提供支持
回复
头像
ibmwebzh
帖子: 84
注册时间: 2006-03-13 19:20
送出感谢: 0
接收感谢: 0

apt-get upgrade有问题

#1

帖子 ibmwebzh » 2006-07-18 13:00

这几天每次用apt-get update然后用apt-get upgrade,就会
下列的软件包的版本将保持不变:
linux-image-686 linux-restricted-modules-686
下列的软件包将被升级:
libsmbclient libxine-main1 linux-686 linux-restricted-modules-common login
nvidia-glx-legacy passwd ttf-opensymbol xserver-xorg-core
共升级了 9 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 2 个软件未被升级。
需要下载 11.3MB 的软件包。
解压缩后会消耗掉 0B 的额外空间。
您希望继续执行吗?[Y/n]y
错误 http://ubuntu.cn99.com dapper-security/main login 1:4.0.13-7ubuntu3.2
404 Not Found
错误 http://ubuntu.cn99.com dapper-security/main passwd 1:4.0.13-7ubuntu3.2
404 Not Found
错误 http://ubuntu.cn99.com dapper-security/main libxine-main1 1.1.1+ubuntu2-7.2 404 Not Found
错误 http://ubuntu.cn99.com dapper-security/restricted linux-686 2.6.15.24
404 Not Found
错误 http://ubuntu.cn99.com dapper-security/restricted linux-restricted-modules-common 2.6.15.11-3
404 Not Found
错误 http://ubuntu.cn99.com dapper-updates/main xserver-xorg-core 1:1.0.2-0ubuntu10.1
404 Not Found
错误 http://ubuntu.cn99.com dapper-security/restricted nvidia-glx-legacy 1.0.7174+2.6.15.11-3
404 Not Found
错误 http://ubuntu.cn99.com dapper-security/main ttf-opensymbol 2.0.2-2ubuntu12.1
404 Not Found
错误 http://ubuntu.cn99.com dapper-security/main libsmbclient 3.0.22-1ubuntu3.1
404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main ... 2_i386.deb 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main ... 2_i386.deb 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main ... 2_i386.deb 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/rest ... 4_i386.deb 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/rest ... -3_all.deb 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/rest ... 3_i386.deb 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main ... .1_all.deb 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb 404 Not Found
E: 有几个软件包无法下载,您可以运行 apt-get update 或者加上 --fix-missing 的选项再试试?
我用的是cn99的源,这几天除了我已外好象没有人说cn99有问题,而我的网络也没问题。是不是我的配置那里出了问题?该怎么办呢。

代码: 全选

deb http://ubuntu.cn99.com/ubuntu/ dapper main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-backports main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ dapper main restricted universe multiverse
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 zhuqin_83 » 2006-07-18 14:11

换个源试试。我从来都是用官方的源。
头像
ibmwebzh
帖子: 84
注册时间: 2006-03-13 19:20
送出感谢: 0
接收感谢: 0

#3

帖子 ibmwebzh » 2006-07-18 17:31

我换过vmmatrix.net和lupaworld.com的源,都不行,而且是一样的问题。
我以前用过其它源,但速度太慢,官方的源在我这儿也很慢。国外的源就更不用说了。
头像
haige
帖子: 315
注册时间: 2006-03-16 16:29
送出感谢: 0
接收感谢: 0

我不知道哪个是官方的源

#4

帖子 haige » 2006-07-28 19:27

是不是暴慢啊
头像
haige
帖子: 315
注册时间: 2006-03-16 16:29
送出感谢: 0
接收感谢: 0

我不知道哪个是官方的源

#5

帖子 haige » 2006-07-28 19:27

是不是暴慢啊
头像
haige
帖子: 315
注册时间: 2006-03-16 16:29
送出感谢: 0
接收感谢: 0

我不知道哪个是官方的源

#6

帖子 haige » 2006-07-28 19:27

是不是暴慢啊
acestrong
帖子: 4
注册时间: 2006-07-28 17:26
送出感谢: 0
接收感谢: 0

#7

帖子 acestrong » 2006-07-29 13:53

我用的上海交大的源,更新后说是出现依赖错误,看了一下是关于OpenOffice的,然后就不能用OpenOffice了。
想要更新其它的软件也不行了!
不知道是源的问题还是其它什么的。
我是新手,不知道怎么办,只有重装了:(
zouzhile
帖子: 36
注册时间: 2005-11-16 9:40
送出感谢: 0
接收感谢: 0

#8

帖子 zouzhile » 2006-07-30 10:22

我也发现了这样的问题!!顶一下,版主说说怎么回事啊?怎么解决呢?
头像
oneleaf
论坛管理员
帖子: 10226
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 103 次

#9

帖子 oneleaf » 2006-07-30 10:36

多加几个源.
zouzhile
帖子: 36
注册时间: 2005-11-16 9:40
送出感谢: 0
接收感谢: 0

#10

帖子 zouzhile » 2006-07-31 14:15

问题已经解决,参考了ubuntu手册,使用一个简单的命令就能帮你搞定升级错误!
aptitude install
我的机子上原来这个升级的问题已经解决了,这个命令是帮你把升级的软件恢复到原来的版本。
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 zhan » 2006-07-31 14:30

aptitude 比 apt-get 好用阿~~
难怪我没有OOo的问题,我一直用 aptitude 的..
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
回复

回到 “老旧版本支持”