apt-get upgrade error!!!!!! how to?

为当前最终发行版之前的所有版本提供支持
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

apt-get upgrade error!!!!!! how to?

#1

帖子 eexpress » 2005-08-15 13:31

root@eexpress-ubuntu-office:/home/exp # apt-get dist-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
mozilla-firefox-gnome-support: 依赖: firefox-gnome-support 但是它还没有被安装
E: 不能满足依赖关系。不妨试一下 -f 选项。
root@eexpress-ubuntu-office:/home/exp # sudo dpkg-reconfigure locales
/usr/sbin/dpkg-reconfigure: locales 已被损坏或未完成安装
root@eexpress-ubuntu-office:/home/exp # sudo apt-get install scim scim-gtk2-immodule scim-modules-socket scim-modules-table scim-pinyin scim-tables-zh scim-input-pad
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
mozilla-firefox-gnome-support: 依赖: firefox-gnome-support 但是它将不会被安装
scim: 依赖: libscim6 但是它将不会被安装
scim-gtk2-immodule: 依赖: libscim6 但是它将不会被安装
scim-input-pad: 依赖: libscim6 但是它将不会被安装
scim-modules-socket: 依赖: libscim6 但是它将不会被安装
scim-modules-table: 依赖: libscim6 但是它将不会被安装
scim-pinyin: 依赖: libscim6 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#2

帖子 firehare » 2005-08-15 13:34

从上面的问题来看,好象是你上次没有安装完程序,导致这次升级失败!
我心无畏,源自于我心无知。
图片
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2005-08-15 13:37

all is accroding to first_install.html at ubuntu.org.cn web page.
first time occour 3 error and some warnning during install.
so do "sudo apt-get update \ sudo apt-get dist-upgrade" again. then get those message above.
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#4

帖子 firehare » 2005-08-15 13:44

是不是由于在你apt-get update时,服务器正在同步呀?
这样的话是会出现你上面所提到的问题的
我心无畏,源自于我心无知。
图片
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2005-08-15 13:48

so, how can i do.
re-download using "sudo apt-get update"?
but when i do so, it did not download any, it seems just verify those download package. and stopped.
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#6

帖子 firehare » 2005-08-15 13:49

这个时候建议你用sudo apt-get -f install 试试

然后再
sudo apt-get update
sudo apt-get dist-upgrade
我心无畏,源自于我心无知。
图片
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#7

帖子 eexpress » 2005-08-15 13:51

i had done this before. now i do again.

root@eexpress-ubuntu-office:/home/exp # apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#8

帖子 oneleaf » 2005-08-15 13:53

当净其意如虚空,远离妄想及诸取,令心所向皆无碍
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#9

帖子 firehare » 2005-08-15 13:54

eexpress 写了:so, how can i do.
re-download using "sudo apt-get update"?
but when i do so, it did not download any, it seems just verify those download package. and stopped.


apt-get update 只是看看源中是否有新的软件而已,它不会下载任何软件的,只是下载一些软件信息和版本信息而已
我心无畏,源自于我心无知。
图片
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#10

帖子 eexpress » 2005-08-15 13:57

取消11:00和17:00的同步?
ok. but using "apt-get -f install " or "apt-get update"?
if the system can re-download those updated package?

can i get a stabled scim.deb first.
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#11

帖子 firehare » 2005-08-15 13:58

eexpress 写了:i had done this before. now i do again.

root@eexpress-ubuntu-office:/home/exp # apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。


如它所言,这样就不会有什么问题了!
我心无畏,源自于我心无知。
图片
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#12

帖子 eexpress » 2005-08-15 13:59

选中了曾被取消选择的软件包 scim。
(正在读取数据库 ... 系统当前总共安装有 59637 个文件和目录。)
正在解压缩 scim (从 scim_1.0.2-3_i386.deb) ...
dpkg:依赖关系问题使得 scim 的配置工作不能继续:
scim 依赖于 libc6 (>= 2.3.2.ds1-21);然而:
系统里的 libc6 的版本是 2.3.2.ds1-20ubuntu14.
dpkg:处理 scim (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
scim

where can i get a libc6 2.3.2.ds1-21? many application need this when install.
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#13

帖子 firehare » 2005-08-15 14:20

请再UPDATE一下
看刚刚看了,已经修复了
我心无畏,源自于我心无知。
图片
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#14

帖子 eexpress » 2005-08-15 14:38

#apt-get update
获取:1 http://archive.ubuntu.org.cn hoary Release.gpg [189B]
获取:2 http://archive.ubuntu.org.cn hoary-security Release.gpg [189B]
获取:3 http://archive.ubuntu.org.cn hoary-updates Release.gpg [189B]
忽略 http://archive.ubuntu.org.cn ubuntu.org.cn Release.gpg
.....
下载 3B,耗时 6s (0B/s)
正在读取软件包列表... 完成
.....
#apt-get dist-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
scim: 依赖: libc6 (>= 2.3.2.ds1-21) 但是 2.3.2.ds1-20ubuntu14 已经安装了
E: 不能满足依赖关系。不妨试一下 -f 选项。

#dpkg-reconfigure locales (ok, can select loacl language)

#apt-get install language-pack-zh language-pack-zh-base language-support-zh
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
language-pack-zh 已经是最新的版本了。
language-pack-zh-base 已经是最新的版本了。
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
language-support-zh: 依赖: openoffice.org-l10n-zh-cn 但是它将不会被安装
依赖: openoffice.org-l10n-zh-tw 但是它将不会被安装
依赖: openoffice.org-help-zh-tw 但是它将不会被安装
依赖: openoffice.org-help-zh-cn 但是它将不会被安装
依赖: mozilla-firefox-locale-zh-cn 但是它将不会被安装
依赖: mozilla-firefox-locale-zh-tw 但是它将不会被安装
scim: 依赖: libc6 (>= 2.3.2.ds1-21) 但是 2.3.2.ds1-20ubuntu14 正要被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

#apt-get install ttf-arphic-newsung
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
scim: 依赖: libc6 (>= 2.3.2.ds1-21) 但是 2.3.2.ds1-20ubuntu14 正要被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

#apt-get install ttf-vera-yuan
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
scim: 依赖: libc6 (>= 2.3.2.ds1-21) 但是 2.3.2.ds1-20ubuntu14 正要被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

#sudo apt-get install scim scim-gtk2-immodule scim-modules-socket scim-modules-table scim-pinyin scim-tables-zh scim-input-pad
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
scim: 依赖: libscim6 但是它将不会被安装
scim-gtk2-immodule: 依赖: libscim6 但是它将不会被安装
scim-input-pad: 依赖: libscim6 但是它将不会被安装
scim-modules-socket: 依赖: libscim6 但是它将不会被安装
scim-modules-table: 依赖: libscim6 但是它将不会被安装
scim-pinyin: 依赖: libscim6 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#15

帖子 eexpress » 2005-08-15 14:41

still...........need this

依赖: libc6 (>= 2.3.2.ds1-21) 但是 2.3.2.ds1-20ubuntu14 已经安装了
回复

回到 “老旧版本支持”