[问题]怎样安装内核

为当前最终发行版之前的所有版本提供支持
回复
Jolly Roger
帖子: 32
注册时间: 2006-07-12 8:27
送出感谢: 0
接收感谢: 0

[问题]怎样安装内核

#1

帖子 Jolly Roger » 2006-07-19 16:38

想编译内核安装声卡,发现在usr/src下没有内核源文件,用光盘怎么装阿??
头像
madoldman
帖子: 599
注册时间: 2006-02-27 20:19
来自: works system
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 madoldman » 2006-07-19 17:26

光盘里面没有,sudo apt-get install linux-source
东西路,南北走
十字路口人咬狗
拿起狗来打砖头
砖头咬了狗一口
图片
Jolly Roger
帖子: 32
注册时间: 2006-07-12 8:27
送出感谢: 0
接收感谢: 0

#3

帖子 Jolly Roger » 2006-07-19 19:34

多谢!
Jolly Roger
帖子: 32
注册时间: 2006-07-12 8:27
送出感谢: 0
接收感谢: 0

#4

帖子 Jolly Roger » 2006-07-22 8:55

下下来了在 /usr/src/下 有一个 linux-source-1.6.15.bar.bz2没有 linux文件夹 阿,
安装 alsa-driver-1.0.12rc1的 时候 在 ./configure这一步
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking whether gcc needs -traditional... no
checking for current directory... /tmp/alsa-driver-1.0.12rc1
checking cross compile...
checking for directory with kernel source... /usr/src/linux
checking for directory with kernel build...
checking for kernel linux/version.h... no
The file /usr/src/linux/include/linux/version.h does not exist.
Please install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /usr/src/linux).


怎么解决阿 !!!
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 yongyi » 2006-07-22 9:08

sudo apt-get install build-essential

可以参考一下这:
viewtopic.php?t=9557&highlight=%E7%BC%9 ... 5%E6%A0%B8
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
Jolly Roger
帖子: 32
注册时间: 2006-07-12 8:27
送出感谢: 0
接收感谢: 0

#6

帖子 Jolly Roger » 2006-07-22 9:16

谢谢我先实践一下
Jolly Roger
帖子: 32
注册时间: 2006-07-12 8:27
送出感谢: 0
接收感谢: 0

#7

帖子 Jolly Roger » 2006-07-22 9:24

这个命令
sudo apt-get install linux-source
干什么的阿,看名字像是安装内核的,可是怎么出来的是一个tar阿?
Jolly Roger
帖子: 32
注册时间: 2006-07-12 8:27
送出感谢: 0
接收感谢: 0

#8

帖子 Jolly Roger » 2006-07-22 9:55

还是不行啊,问题一样,发现没有version.h文件,在光盘里找到linux-header-2.6.15-23,
创建一个linux连接到header文件夹,执行./configure

# ./configure
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking whether gcc needs -traditional... no
checking for current directory... /tmp/alsa-driver-1.0.12rc1
checking cross compile...
checking for directory with kernel source... /usr/src/linux
checking for directory with kernel build...
checking for kernel linux/version.h... yes
checking for kernel linux/autoconf.h... yes
checking for kernel version... 2.6.15-23
checking for GCC version... Kernel compiler: Used compiler: gcc (GCC) 4.0.3 (Ubuntu 4.0.3-1ubuntu5)

*** NO PREDEFINED KERNEL COMPILER IS DETECTED
*** Assuming the same compiler is used with the current system compiler.

*** Please make sure that the same compiler version was used for building kernel.

checking for built-in ALSA... yes
configure: error: You have built-in ALSA in your kernel.
回复

回到 “老旧版本支持”