当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [求助]安装ubuntu后的问题
帖子发表于 : 2006-07-19 18:20 

注册: 2006-03-09 22:05
帖子: 55
送出感谢: 0 次
接收感谢: 0 次
第一次安装,看见ubuntu的桌面还是很高兴的,但随后就发现启动windowsxp时出现“system32\hal.dll文件损坏或丢失,系统不能启动”。我原以为在另一个盘上重装系统,再将里面的hal.dll文件复制过去就行了,可惜还是如此。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-07-19 23:04 

注册: 2006-03-26 17:16
帖子: 163
地址: 广东中山
送出感谢: 0 次
接收感谢: 0 次
hal.dll是WinNT内核(包括WinXP)操作系统卷的核心驱动,通常由安装多个操作系统而造成损坏,如果系统还能启动,可以从安装盘中提取该文件进行恢复,否则个别磁盘分区可能无法使用。如果系统无法正常启动,特别是系统分区使用了NTFS,恐怕就只有重新安装操作系统或者使用控制台修复了

插入XP安装盘重新启动电脑,选择故障恢复控制台。依提示进入windows目录。
在DOS提示符下输入:expand x:\i386\driver.cab /f:hal.dll c:\windows\system32\(x:为光驱盘符.再次利用expand 首先将halaacpi.dll拷贝至c:\winindows\system32\,并改名为hal.dll后重新启动电脑,再拷 halacpi.dll(因为hal.dll的源文件名是halacpi.dll).改名(ren)后重启,restart即可


_________________
从明天起,做一个幸福的人.
过着简单的生活.
很惬意,没有纷争.
家人很快乐.朋友都幸福.
爱我的人和我爱的人是同一个人.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-07-19 23:26 

注册: 2006-07-09 12:22
帖子: 1331
地址: 南京
送出感谢: 0 次
接收感谢: 1
http://www.51eshu.com/Article/Print.asp?ArticleID=7648
有关细节提示一下:
1、进入恢复控制台时,提示输入安装的XP号码,输入一非零值即可(如1),然后输入管理员密码,即可进入恢复控制台命令行。
2、安装盘的hal.dll文件不一定就在driver.cab里面,尽管多数情况是这样。自己可以用dir查看一下。。。
3、关于计算机的类型描述及对应的hal文件,上面的网页中说得很清楚了,可不能搞错了^^
我的电脑右键->属性->硬件->配置管理器,可以查到你的计算机的类型描述。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-07-20 17:17 

注册: 2006-03-09 22:05
帖子: 55
送出感谢: 0 次
接收感谢: 0 次
这问题我已解决了。在google搜索才知道原来是boot的问题。由于我的交换分区在C盘的前面,所以只要把partition后的数值改为2。
还想问一下:1 如何上网?我在wiki里没看见详细的说明。我用的是电信的宽带,中兴的ADSL
2 为什么kubuntu里的软件比ubuntu里的多?我能将kubuntu里的软件安装在ubuntu上吗?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-07-20 17:35 

注册: 2006-07-12 16:02
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
kubuntu以kde为桌面的,ubuntu默认以gnome为桌面的,kubuntu的软件是可以安装在ubuntu上的,但不能保证兼容性(ubuntu wiki语)


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-07-20 17:58 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
adsl 上网,执行sudo pppoeconf配置用户名密码

gnome和kde之间的软件可以混用,基本上没有问题.


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-07-20 22:26 

注册: 2006-03-09 22:05
帖子: 55
送出感谢: 0 次
接收感谢: 0 次
能说详细一点吗?我在终端中执行了sudo pppoecon,f配置用户名密码,一路按“是”,还是上不了网。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译