想安装一个deb包,但是有层层依赖,难道每个包都需要单独下载?

为当前最终发行版之前的所有版本提供支持
回复
wukw
帖子: 107
注册时间: 2006-07-13 16:51
送出感谢: 0
接收感谢: 0

想安装一个deb包,但是有层层依赖,难道每个包都需要单独下载?

#1

帖子 wukw » 2006-07-21 18:48

http://packages.debian.org/stable/devel/ocaml

每一个子依赖包都另有依赖,虽然都有下载,但是怎么会这样呢?那不是麻烦死了?各位大哥有什么好的解决办法吗??
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-07-21 19:02

用源的。如果源没有,那就只能这样了。不过可能导致系统故障的。
● 鸣学
头像
drivel
帖子: 1917
注册时间: 2006-07-08 9:21
来自: University of Science and Technology Beijing
送出感谢: 1 次
接收感谢: 0
联系:

#3

帖子 drivel » 2006-07-21 23:25

貌似的确没有好的方法了
wukw
帖子: 107
注册时间: 2006-07-13 16:51
送出感谢: 0
接收感谢: 0

#4

帖子 wukw » 2006-07-22 7:27

天啊,人家RPM好像是臭名昭著,倒是一个包就解决问题了啊!!
头像
madoldman
帖子: 599
注册时间: 2006-02-27 20:19
来自: works system
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 madoldman » 2006-07-22 11:32

wukw 写了:天啊,人家RPM好像是臭名昭著,倒是一个包就解决问题了啊!!
是这样吗?好像也不是吧,记得以前用FC4的时候,也经常缺东西,不过它不会提示你缺哪个包,只是提示你哪个库的版本不对,那才会死人的呢,有时侯一个库文件找一天多都找不到,当时转Debian时就是因为受不了这个折腾
东西路,南北走
十字路口人咬狗
拿起狗来打砖头
砖头咬了狗一口
图片
头像
mikeandmore
帖子: 109
注册时间: 2005-10-13 18:29
送出感谢: 0
接收感谢: 0

#6

帖子 mikeandmore » 2006-07-22 11:48

i just wanna tell you.

源里有这个包。。。
wukw
帖子: 107
注册时间: 2006-07-13 16:51
送出感谢: 0
接收感谢: 0

#7

帖子 wukw » 2006-07-24 2:14

madoldman 写了:
wukw 写了:天啊,人家RPM好像是臭名昭著,倒是一个包就解决问题了啊!!
是这样吗?好像也不是吧,记得以前用FC4的时候,也经常缺东西,不过它不会提示你缺哪个包,只是提示你哪个库的版本不对,那才会死人的呢,有时侯一个库文件找一天多都找不到,当时转Debian时就是因为受不了这个折腾
至少安装OCAML语言,RPM的确是一个包就解决问题啊!!
wind21st
帖子: 24
注册时间: 2006-07-20 19:59
送出感谢: 0
接收感谢: 0

这方面和FC5相比实在是太弱拉

#8

帖子 wind21st » 2006-07-24 20:54

在Ubuntu下安装一种软件简直就是活受罪,层层依赖,有的时候像删除一个包居然必须先删除ubuntu-desktop,简直就是狂晕
wukw
帖子: 107
注册时间: 2006-07-13 16:51
送出感谢: 0
接收感谢: 0

#9

帖子 wukw » 2006-07-25 18:17

wukw 写了:
madoldman 写了:
wukw 写了:天啊,人家RPM好像是臭名昭著,倒是一个包就解决问题了啊!!
是这样吗?好像也不是吧,记得以前用FC4的时候,也经常缺东西,不过它不会提示你缺哪个包,只是提示你哪个库的版本不对,那才会死人的呢,有时侯一个库文件找一天多都找不到,当时转Debian时就是因为受不了这个折腾
至少安装OCAML语言,RPM的确是一个包就解决问题啊!!
那怎么查看、安装呢??谢谢指教。。。。
wind21st
帖子: 24
注册时间: 2006-07-20 19:59
送出感谢: 0
接收感谢: 0

#10

帖子 wind21st » 2006-07-25 19:17

深有同感阿!!难道就没有好的办法吗!
wukw
帖子: 107
注册时间: 2006-07-13 16:51
送出感谢: 0
接收感谢: 0

#11

帖子 wukw » 2006-07-27 6:27

源里确实有。不过编译程序的时候好像还有点问题,我再研究一下~
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 karron » 2006-07-27 8:15

第一,安装软件的时候用新立得来搜索安装,不建议自己去找deb包.大部分软件源里面都有,何必舍近求远,还要自己解决依赖问题.用debian/ubuntu这样的发行版就要抛弃fc系列的一些习惯,比如到处找安装包.

第二,ubuntu的deb和debian的deb最好不要混用,它们在二进制上并不完全兼容.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
drivel
帖子: 1917
注册时间: 2006-07-08 9:21
来自: University of Science and Technology Beijing
送出感谢: 1 次
接收感谢: 0
联系:

#13

帖子 drivel » 2006-07-27 10:55

还是atp-get最好,什么都解决了
头像
sigma
帖子: 439
注册时间: 2006-06-01 22:45
来自: Fujian
送出感谢: 0
接收感谢: 0

#14

帖子 sigma » 2006-07-27 11:13

drivel 你学那个谁的头像阿
是不是我也应该去搞个
被时间羁绊,被邪恶包围……空气稀薄
头像
drivel
帖子: 1917
注册时间: 2006-07-08 9:21
来自: University of Science and Technology Beijing
送出感谢: 1 次
接收感谢: 0
联系:

#15

帖子 drivel » 2006-07-27 11:24

sigma 写了:drivel 你学那个谁的头像阿
是不是我也应该去搞个
是的啊。。啊哈~帅吧。。。
回复

回到 “老旧版本支持”