当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]新手问题列表(本论坛第一次问问题,大家帮忙阿)
帖子发表于 : 2006-07-25 19:12 

注册: 2006-07-20 19:59
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
小弟用ubuntu没有几天,之前用过FC4/5,多少有点Linux常识,最近因为工作需要新换了一台DELL的液晶进行工作,但是破DELL的光驱实在是垃圾,我自己刻的FC5盘在太刺拉(TCL)下都能通过校验,但是这个破光驱就是不能读,别人刻FC5也同样不能读。没有办法,抱着学习的精神,我踏上拉UBUNTU(因为光盘是派送的所以能安装)的旅途。但是,最近几天,由于初次接触UBUNTU,有很多问题不能解决。正如本版标题框所说的:“我们是菜鸟,很想起飞,请多点耐心关注和指点”,希望各位同胞广施爱心,有问有答,多谢!

1。(该问题已经解决,我配的cn99的源好像不适合我,不管装什么软件都说缺包,所以才造成下面的一长串,后来加上ubuntu.org源之后可以安装kde的desktop拉)如果安装KDE,大家都知道,很多软件都基于KDE(比如lincvs,我可不喜欢打诸如cvs update xxx的命令),这家伙不装不行,FC自己就带拉,但是我没有kubuntu的盘,所以只能按照论坛说的
代码:
jason@jason:~$ sudo apt-get install kubuntu-desktop
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  kubuntu-desktop: Depends: adept but it is not going to be installed
                   Depends: akode but it is not going to be installed
                   Depends: akregator but it is not going to be installed
                   Depends: amarok but it is not going to be installed
                   Depends: ark but it is not going to be installed
                   Depends: cupsys-driver-gimpprint but it is not going to be installed
                   Depends: gtk2-engines-gtk-qt but it is not going to be installed
                   Depends: gwenview but it is not going to be installed
                   Depends: hplip-base but it is not going to be installed
                   Depends: ivman but it is not going to be installed
                   Depends: k3b but it is not going to be installed
                   Depends: kaddressbook but it is not going to be installed
                   Depends: kaffeine-gstreamer but it is not going to be installed
                   Depends: kamera but it is not going to be installed
                   Depends: karm but it is not going to be installed
                   Depends: katapult but it is not going to be installed
                   Depends: kate but it is not going to be installed
                   Depends: kaudiocreator but it is not going to be installed
                   Depends: kcontrol but it is not going to be installed
                   Depends: kcron but it is not going to be installed
                   Depends: kde-guidance but it is not going to be installed
                   Depends: kde-systemsettings but it is not going to be installed
                   Depends: kdeadmin-kfile-plugins but it is not going to be installed
                   Depends: kdebase-kio-plugins but it is not going to be installed
                   Depends: kdebluetooth but it is not going to be installed
                   Depends: kdegraphics-kfile-plugins but it is not going to be installed
                   Depends: kdemultimedia-kappfinder-data but it is not going to be installed
                   Depends: kdemultimedia-kfile-plugins but it is not going to be installed
                   Depends: kdemultimedia-kio-plugins but it is not going to be installed
                   Depends: kdenetwork-filesharing but it is not going to be installed
                   Depends: kdenetwork-kfile-plugins but it is not going to be installed
                   Depends: kdepasswd but it is not going to be installed
                   Depends: kdepim-kio-plugins but it is not going to be installed
                   Depends: kdepim-wizards but it is not going to be installed
                   Depends: kdeprint but it is not going to be installed
                   Depends: kdesktop but it is not going to be installed
                   Depends: kdm but it is not going to be installed
                   Depends: kfind but it is not going to be installed
                   Depends: kghostview but it is not going to be installed
                   Depends: khelpcenter but it is not going to be installed
                   Depends: kicker but it is not going to be installed
                   Depends: kio-apt but it is not going to be installed
                   Depends: kio-locate but it is not going to be installed
                   Depends: klaptopdaemon but it is not going to be installed
                   Depends: klipper but it is not going to be installed
                   Depends: kmail but it is not going to be installed
                   Depends: kmenuedit but it is not going to be installed
                   Depends: kmilo but it is not going to be installed
                   Depends: kmix but it is not going to be installed
                   Depends: knetworkconf but it is not going to be installed
                   Depends: knotes but it is not going to be installed
                   Depends: konq-plugins but it is not going to be installed
                   Depends: konqueror but it is not going to be installed
                   Depends: konqueror-nsplugins but it is not going to be installed
                   Depends: konserve but it is not going to be installed
                   Depends: konsole but it is not going to be installed
                   Depends: kontact but it is not going to be installed
                   Depends: konversation but it is not going to be installed
                   Depends: kooka but it is not going to be installed
                   Depends: kopete but it is not going to be installed
                   Depends: korganizer but it is not going to be installed
                   Depends: kpdf but it is not going to be installed
                   Depends: kpf but it is not going to be installed
                   Depends: kppp but it is not going to be installed
                   Depends: krdc but it is not going to be installed
                   Depends: krfb but it is not going to be installed
                   Depends: krita but it is not going to be installed
                   Depends: kscd but it is not going to be installed
                   Depends: kscreensaver but it is not going to be installed
                   Depends: ksmserver but it is not going to be installed
                   Depends: ksnapshot but it is not going to be installed
                   Depends: ksplash but it is not going to be installed
                   Depends: ksvg but it is not going to be installed
                   Depends: ksysguard but it is not going to be installed
                   Depends: ksystemlog but it is not going to be installed
                   Depends: kubuntu-default-settings but it is not going to be installed
                   Depends: kubuntu-docs but it is not going to be installed
                   Depends: kubuntu-konqueror-shortcuts but it is not going to be installed
                   Depends: kuser but it is not going to be installed
                   Depends: kwalletmanager but it is not going to be installed
                   Depends: kwifimanager but it is not going to be installed
                   Depends: kwin but it is not going to be installed
                   Depends: openoffice.org2-kde but it is not going to be installed
E: Broken packages

结果大家看到拉,就是那么一长串,要独自去完成这些依赖包的安装基本不可能,我曾经尝试用synaptic package manager安装adept包,提示我又要安装
代码:
adept:
 Depends: sanekonsole but it is not going to be installed
 Depends: debtags but it is not going to be installed
 Depends: kdelibs4c2 but it is not going to be installed
 Depends: libapt-pkg-libc6.3-6-3.10

我心想,难道我英名一世在这个地方就卡死了吗,没办法,我只能跑来问大家拉。

2。SCIM的问题,SCIM跟很多软件冲突,常见的办法是在各个软件的BASH文件加上
代码:
export GTK_IM_MODULE=xim
LC_NUMERIC=C
export LC_NUMERIC

基本上别的软件都还好,但是唯独EIOffice(我工作还真少不了EIOffice,因为OpenOffice在某些情况下根本没法代替MSOffice,比如有些设计书用OpenOffice根本显示不了内容)不行,错误日志是
代码:
C  [libX11.so.6+0x1e424]  XFreeFontSet+0x15
C  [libmawt.so+0x19c65]
C  [libmawt.so+0x19bb1]
C  [libmawt.so+0x1c28e]  Java_sun_awt_X11InputMethod_disposeXIC+0xc6
j  sun.awt.X11InputMethod.disposeXIC()V+0
j  sun.awt.X11InputMethod.disposeImpl()V+1
j  sun.awt.X11.XInputMethod.disposeImpl()V+1
...

很明显就是输入问题!当然wiki也说过通过修改
代码:
GTK_IM_MODULE="scim-bridge"
QT_IM_MODULE="xim"

即修改输入法为scim-bridge,这个确实很好用,包括很多软件的bash我也加了这句话,确实能正常运行,但是不能通过ctrl-space激活,只能通过手动的点击Notification Area的输入法图标点选,这显然很不方便。当然我也考虑过用fcitx,在en_US的locale下无法激活,我一直在en_US的locale下工作,这个不能改变,所以我基本就束手无策拉。

3。现在项目用到了mysql_query_browser(1.1.18),这个工具必不可少,但是安装完毕后发现
代码:
./mysql-query-browser
./mysql-query-browser: line 20:  6959 Segmentation fault      $PRG-bin

当然这个问题FC5也存在,但是有个补丁能解决这个问题。不知道UBUNTU下是否有相应的解决方案

以上三个问题如梗在喉,严重响应我在ubuntu下的工作,希望有知晓解决办法的高手不吝赐教!谢谢[/i]


最后由 wind21st 编辑于 2006-07-26 9:12,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-07-25 19:19 
头像

注册: 2005-08-18 18:43
帖子: 3277
送出感谢: 0 次
接收感谢: 3
我知道wiki里的快速设置指南有英文local下用scim的设置


_________________
໌→ iCookie Gtk Theme
໌→DropPlusBluetheme
กรัก กรัก`菠萝


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-07-25 19:36 

注册: 2006-07-20 19:59
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
内存不足 写道:
我知道wiki里的快速设置指南有英文local下用scim的设置

这个问题我已经解决拉,我需要解决的问题是scim和eioffice冲突的问题,或者fcitx在英文locale下被激活的问题


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-07-25 20:03 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
依赖一堆。似乎是source.list没设置。或者没update.


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-07-25 20:23 

注册: 2006-07-20 19:59
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
依赖一堆。似乎是source.list没设置。或者没update.

wiki里面提到了好多源,如ubuntu.com,ubuntu.cn99.com等等,这些源是选一个加上还是都加上阿。另外,有没有好点的源地址,能不能贴一下


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-07-25 20:25 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
选一组快的。cn99.com的快。但是如果是网通,教育网,选其他的。wiki也说明了。


_________________
● 鸣学


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-07-25 20:30 
头像

注册: 2006-07-08 9:21
帖子: 1917
地址: University of Science and Technology Beijing
送出感谢: 1
接收感谢: 0 次
源更改之后,一定要
sudo apt-get update


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-07-25 20:31 

注册: 2006-07-20 19:59
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
我用的就是cn99的,更新好像好慢,今天我把cn99,ubuntu.org都选上拉,结果告诉我60多个软件要更新,都不知道怎么回事


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-07-25 20:31 

注册: 2006-07-20 19:59
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
drivel 写道:
源更改之后,一定要
sudo apt-get update

不然会出现什么后果,我更新源之后还真没这么做


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-07-25 20:33 
头像

注册: 2006-07-08 9:21
帖子: 1917
地址: University of Science and Technology Beijing
送出感谢: 1
接收感谢: 0 次
wind21st 写道:
我用的就是cn99的,更新好像好慢,今天我把cn99,ubuntu.org都选上拉,结果告诉我60多个软件要更新,都不知道怎么回事

这个速度问题要看你的网络了


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-07-25 20:34 

注册: 2006-07-20 19:59
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
代码:
# cn99.com
deb http://ubuntu.cn99.com/ubuntu/ breezy main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ breezy-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ breezy-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ breezy-backports main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ breezy main restricted universe multiverse

# ubuntu.org
deb http://archive.ubuntu.com/ubuntu/ dapper main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ dapper-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ dapper-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu-cn/ dapper main restricted universe multiverse

我把两个源都选上拉行吗,会有什么影响没有


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-07-25 20:36 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
可以。archive.ubuntu.com是欧洲的。


_________________
● 鸣学


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2006-07-25 20:51 

注册: 2006-07-20 19:59
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
依赖一堆。似乎是source.list没设置。或者没update.

兄弟果然是高手阿,按照你的说法把源刷了一下之后,更新完毕后就可以安装kubuntu-desktop,真是感谢!!!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot], Sogou [Spider] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译