sap linux gui 安装问题

为当前最终发行版之前的所有版本提供支持
回复
lukefury
帖子: 138
注册时间: 2006-06-03 15:41
送出感谢: 0
接收感谢: 0

sap linux gui 安装问题

#1

帖子 lukefury » 2006-07-25 22:57

今天下载了sap linux gui(PlatinGUI-Linux-640r6.jar),安装时提示如下,请问下一步该怎么办。
lukefury@lukefury-laptop:~/download/sap$ java -jar PlatinGUI-Linux-640r6.jar
Exception in thread "main" java.awt.AWTError: Cannot load AWT toolkit: gnu.java. awt.peer.gtk.GtkToolkit
at java.awt.Toolkit.getDefaultToolkit(libgcj.so.7)
at java.awt.Font.tk(libgcj.so.7)
at java.awt.Font.getPeerFromToolkit(libgcj.so.7)
at java.awt.Font.<init>(libgcj.so.7)
at javax.swing.plaf.FontUIResource.<init>(libgcj.so.7)
at javax.swing.plaf.metal.DefaultMetalTheme.<clinit>(libgcj.so.7)
at java.lang.Class.initializeClass(libgcj.so.7)
at javax.swing.plaf.metal.MetalLookAndFeel.createDefaultTheme(libgcj.so.7)
at javax.swing.plaf.metal.MetalLookAndFeel.<init>(libgcj.so.7)
at javax.swing.UIManager.<clinit>(libgcj.so.7)
at java.lang.Class.initializeClass(libgcj.so.7)
at com.sap.platin.base.install.GuiInstall.main(GuiInstall.java:440)
Caused by: java.lang.ClassNotFoundException: gnu.java.awt.peer.gtk.GtkToolkit
at java.lang.Class.forName(libgcj.so.7)
at java.lang.Class.forName(libgcj.so.7)
at java.awt.Toolkit.getDefaultToolkit(libgcj.so.7)
...11 more
lukefury
帖子: 138
注册时间: 2006-06-03 15:41
送出感谢: 0
接收感谢: 0

#2

帖子 lukefury » 2006-07-27 8:30

貌似java没有装全,自己顶起来
lukefury
帖子: 138
注册时间: 2006-06-03 15:41
送出感谢: 0
接收感谢: 0

#3

帖子 lukefury » 2006-07-28 15:58

继续顶
回复

回到 “老旧版本支持”