[问题]ubuntu5.10如何安装jre1.5

为当前最终发行版之前的所有版本提供支持
回复
tanlimingwhu
帖子: 10
注册时间: 2006-07-26 12:48
送出感谢: 0
接收感谢: 0
联系:

[问题]ubuntu5.10如何安装jre1.5

#1

帖子 tanlimingwhu » 2006-07-26 14:56

装了Lumaqq就是不能启动,郁闷死了。看了很多帖子,说是要装jre,于是在java的官方网站上下载了jre-1_5_0_07-linux-i586.bin,请教大家如何安装它啊,谢了!!!!!!
头像
drivel
帖子: 1917
注册时间: 2006-07-08 9:21
来自: University of Science and Technology Beijing
送出感谢: 1 次
接收感谢: 0
联系:

#2

帖子 drivel » 2006-07-26 15:06

直接
sudo apt-get install sun-java5-jre
tanlimingwhu
帖子: 10
注册时间: 2006-07-26 12:48
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 tanlimingwhu » 2006-07-26 15:22

直接输入后出现以下问题,是怎么回事啊?
tanliming@ubuntutlm:~$ sudo apt-get install sun-java5-jre
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
amule: 依赖: amule-common 但是它将不会被安装
sun-java5-jre: 依赖: sun-java5-bin (= 1.5.0-06-1) 但是它将不会被安装 或
ia32-sun-java5-bin (= 1.5.0-06-1) 但却无法安装它
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

我到底应该怎么办啊?谢谢了
头像
drivel
帖子: 1917
注册时间: 2006-07-08 9:21
来自: University of Science and Technology Beijing
送出感谢: 1 次
接收感谢: 0
联系:

#4

帖子 drivel » 2006-07-26 15:33

tanlimingwhu 写了:直接输入后出现以下问题,是怎么回事啊?
tanliming@ubuntutlm:~$ sudo apt-get install sun-java5-jre
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
amule: 依赖: amule-common 但是它将不会被安装
sun-java5-jre: 依赖: sun-java5-bin (= 1.5.0-06-1) 但是它将不会被安装 或
ia32-sun-java5-bin (= 1.5.0-06-1) 但却无法安装它
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

我到底应该怎么办啊?谢谢了
把以前的卸载了,更换源,sudo apt-get update
tanlimingwhu
帖子: 10
注册时间: 2006-07-26 12:48
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 tanlimingwhu » 2006-07-26 15:46

我昨天才在vmware上装上ubuntu5.10,对ubuntu不大懂,敢问这位大侠可以说得详细些吗?谢谢~
头像
drivel
帖子: 1917
注册时间: 2006-07-08 9:21
来自: University of Science and Technology Beijing
送出感谢: 1 次
接收感谢: 0
联系:

#6

帖子 drivel » 2006-07-26 16:44

tanlimingwhu 写了:我昨天才在vmware上装上ubuntu5.10,对ubuntu不大懂,敢问这位大侠可以说得详细些吗?谢谢~
http://wiki.ubuntu.org.cn/%E5%BF%AB%E9% ... apperDrake
77519697
帖子: 26
注册时间: 2006-07-20 15:44
送出感谢: 0
接收感谢: 0

估计源不好 个人意见

#7

帖子 77519697 » 2006-07-26 20:43

是学生 把源换成 (网通也行)
deb http://ftp.sjtu.edu.cn/ubuntu/ dapper main multiverse restricted universe
deb http://ftp.sjtu.edu.cn/ubuntu/ dapper-backports main multiverse restricted universe
deb http://ftp.sjtu.edu.cn/ubuntu/ dapper-proposed main multiverse restricted universe
deb http://ftp.sjtu.edu.cn/ubuntu/ dapper-security main multiverse restricted universe
deb http://ftp.sjtu.edu.cn/ubuntu/ dapper-updates main multiverse restricted universe
deb http://ftp.sjtu.edu.cn/ubuntu-cn/ dapper main multiverse restricted universe
不是学生 换成 电信
deb http://mirror.vmmatrix.net/ubuntu/ dapper main restricted universe multiverse
deb-src http://mirror.vmmatrix.net/ubuntu/ dapper main restricted universe multiverse
deb http://mirror.vmmatrix.net/ubuntu/ dapper-updates main restricted universe multiverse
deb-src http://mirror.vmmatrix.net/ubuntu/ dapper-updates main restricted universe multiverse
deb http://mirror.vmmatrix.net/ubuntu/ dapper-backports main restricted universe multiverse
deb-src http://mirror.vmmatrix.net/ubuntu/ dapper-backports main restricted universe multiverse
deb http://mirror.vmmatrix.net/ubuntu/ dapper-security main restricted universe multiverse
deb-src http://mirror.vmmatrix.net/ubuntu/ dapper-security main restricted universe multiverse
deb http://ftp.sjtu.edu.cn/ubuntu-cn/ dapper main multiverse restricted universe
77519697
帖子: 26
注册时间: 2006-07-20 15:44
送出感谢: 0
接收感谢: 0

#8

帖子 77519697 » 2006-07-26 20:44

apt-get -f install sun-java5-jre 怎么提示
77519697
帖子: 26
注册时间: 2006-07-20 15:44
送出感谢: 0
接收感谢: 0

#9

帖子 77519697 » 2006-07-26 20:48

是否应该先apt-get install amule-common 我也是新手 我是靠感觉 接触2个星期了 中学时听说 unix 现在终于用上了 一起努力阿 实践 + 乐趣 + 玩耍
tanlimingwhu
帖子: 10
注册时间: 2006-07-26 12:48
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 tanlimingwhu » 2006-07-28 0:36

tanliming@ubuntutlm:~$ sudo apt-get install sun-java5-jre
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
将会安装下列额外的软件包:
sun-java5-bin unixodbc
建议安装的软件包:
sun-java5-plugin ia32-sun-java5-plugin sun-java5-fonts libmyodbc
odbc-postgresql libct1
推荐安装的软件包:
gsfonts-x11
下列【新】软件包将被安装:
sun-java5-bin sun-java5-jre unixodbc
共升级了 0 个软件包,新安装了 3 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 29.8MB 的软件包。
解压缩后会消耗掉 84.1MB 的额外空间。
您希望继续执行吗?[Y/n]y
获取:1 http://mirror.vmmatrix.net dapper/main unixodbc 2.2.11-11build1 [269kB]
获取:2 http://mirror.vmmatrix.net dapper/multiverse sun-java5-bin 1.5.0-06-1 [22.1MB]
错误 http://mirror.vmmatrix.net dapper/multiverse sun-java5-bin 1.5.0-06-1
从服务器读取数据时出错,对方关闭了连接 [IP: 61.172.246.167 80]
获取:3 http://mirror.vmmatrix.net dapper/multiverse sun-java5-jre 1.5.0-06-1 [7341kB]
下载 7610kB,耗时 2m46s (45.6kB/s)
无法下载 http://mirror.vmmatrix.net/ubuntu/pool/ ... 1_i386.deb 从服务器读取数据时出错,对方关闭了连接 [IP: 61.172.246.167 80]
E: 有几个软件包无法下载,您可以运行 apt-get update 或者加上 --fix-missing 的选项再试试?
头像
drivel
帖子: 1917
注册时间: 2006-07-08 9:21
来自: University of Science and Technology Beijing
送出感谢: 1 次
接收感谢: 0
联系:

#11

帖子 drivel » 2006-07-28 0:44

国内的还是CN99好些。VMM的有些东西都没有
magic1136
帖子: 94
注册时间: 2006-01-02 0:37
送出感谢: 0
接收感谢: 0

#12

帖子 magic1136 » 2006-07-28 0:50

drivel 写了:国内的还是CN99好些。VMM的有些东西都没有
cn99得源贴一下啊
riskyxu
帖子: 1
注册时间: 2008-03-19 10:37
送出感谢: 0
接收感谢: 0

cn99的源

#13

帖子 riskyxu » 2008-03-19 10:39

#江苏省常州市电信
deb http://ubuntu.cn99.com/ubuntu/ feisty main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ feisty-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ feisty-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ feisty-proposed main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ feisty-backports main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ feisty main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ feisty-security main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ feisty-updates main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ feisty-proposed main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ feisty-backports main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ feisty main restricted universe multiverse
回复

回到 “老旧版本支持”