当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [急]自动升级程序发生错误,随之带来的一系列问题,清帮助,谢谢
帖子发表于 : 2006-07-28 10:00 

注册: 2006-07-05 16:47
帖子: 275
送出感谢: 0 次
接收感谢: 0 次
今天提示有升级信息,下载完毕开始安装时发生故障,自动升级程序提示
“错误信息为:error: BrokenCount>0 请在终端中使用apt-get install -f解决此问题”

可是我安装其提示在终端中使用apt-get install -f后,错误仍旧,以下为终端机执行此命令的信息。




引用:
root@Ubuntu-book:/home/ericzhao# apt-get install -f
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
openoffice.org-base openoffice.org-calc openoffice.org-common openoffice.org-core
openoffice.org-draw openoffice.org-impress openoffice.org-math openoffice.org-writer
建议安装的软件包:
unixodbc libmyodbc odbc-postgresql tdsodbc mdbtools libmysql-java libpg-java libsapdbc-java
openoffice.org-gcj
下列【新】软件包将被安装:
openoffice.org-core
下列的软件包将被升级:
openoffice.org-base openoffice.org-calc openoffice.org-common openoffice.org-draw
openoffice.org-impress openoffice.org-math openoffice.org-writer
共升级了 7 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 6 个软件未被升级。
有 2 个软件包没有被完全安装或卸载。
需要下载 0B/83.0MB 的软件包。
解压缩后会消耗掉 110MB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 88573 个文件和目录。)
正预备替换 openoffice.org-calc 2.0.2-2ubuntu12.1 (使用 .../openoffice.org-calc_2.0.3-3dapper3_i386.d eb) ...
正在解压缩将用于更替的包文件 openoffice.org-calc ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-calc_2.0.3-3dapper3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/help/en/scalc.idx/DICTIONARY”,它属于软件包 openoffice.org-help-en-u s
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
正预备替换 openoffice.org-writer 2.0.2-2ubuntu12.1 (使用 .../openoffice.org-writer_2.0.3-3dapper3_i3 86.deb) ...
正在解压缩将用于更替的包文件 openoffice.org-writer ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-writer_2.0.3-3dapper3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/help/en/swriter.idx/DICTIONARY”,它属于软件包 openoffice.org-help-en -us
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
正预备替换 openoffice.org-draw 2.0.2-2ubuntu12.1 (使用 .../openoffice.org-draw_2.0.3-3dapper3_i386.d eb) ...
正在解压缩将用于更替的包文件 openoffice.org-draw ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-draw_2.0.3-3dapper3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/help/en/sdraw.idx/DICTIONARY”,它属于软件包 openoffice.org-help-en-u s
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
正预备替换 openoffice.org-impress 2.0.2-2ubuntu12.1 (使用 .../openoffice.org-impress_2.0.3-3dapper3_ i386.deb) ...
正在解压缩将用于更替的包文件 openoffice.org-impress ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-impress_2.0.3-3dapper3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/help/en/simpress.idx/DICTIONARY”,它属于软件包 openoffice.org-help-e n-us
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
正预备替换 openoffice.org-base 2.0.2-2ubuntu12.1 (使用 .../openoffice.org-base_2.0.3-3dapper3_i386.d eb) ...
正在解压缩将用于更替的包文件 openoffice.org-base ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-base_2.0.3-3dapper3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/help/en/sdatabase.idx/DICTIONARY”,它属于软件包 openoffice.org-help- en-us
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
正预备替换 openoffice.org-math 2.0.2-2ubuntu12.1 (使用 .../openoffice.org-math_2.0.3-3dapper3_i386.d eb) ...
正在解压缩将用于更替的包文件 openoffice.org-math ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-math_2.0.3-3dapper3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/help/en/smath.idx/DICTIONARY”,它属于软件包 openoffice.org-help-en-u s
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
dpkg:关于含有 openoffice.org-common 的 .../openoffice.org-common_2.0.3-3dapper3_all.deb:
openoffice.org-common 冲突于 openoffice.org-calc (<< 2.0.3)
openoffice.org-calc (版本为 2.0.2-2ubuntu12.1)现在 已安装完毕。
dpkg:处理 /var/cache/apt/archives/openoffice.org-common_2.0.3-3dapper3_all.deb (--unpack)时出错:
软件包相互冲突 - 将不安装 openoffice.org-common
dpkg:关于含有 openoffice.org-core 的 .../openoffice.org-core_2.0.3-3dapper3_i386.deb:
openoffice.org-core 冲突于 openoffice.org-calc (<< 2.0.3)
openoffice.org-calc (版本为 2.0.2-2ubuntu12.1)现在 已安装完毕。
dpkg:处理 /var/cache/apt/archives/openoffice.org-core_2.0.3-3dapper3_i386.deb (--unpack)时出错:
软件包相互冲突 - 将不安装 openoffice.org-core
在处理时有错误发生:
/var/cache/apt/archives/openoffice.org-calc_2.0.3-3dapper3_i386.deb
/var/cache/apt/archives/openoffice.org-writer_2.0.3-3dapper3_i386.deb
/var/cache/apt/archives/openoffice.org-draw_2.0.3-3dapper3_i386.deb
/var/cache/apt/archives/openoffice.org-impress_2.0.3-3dapper3_i386.deb
/var/cache/apt/archives/openoffice.org-base_2.0.3-3dapper3_i386.deb
/var/cache/apt/archives/openoffice.org-math_2.0.3-3dapper3_i386.deb
/var/cache/apt/archives/openoffice.org-common_2.0.3-3dapper3_all.deb
/var/cache/apt/archives/openoffice.org-core_2.0.3-3dapper3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@Ubuntu-book:/home/ericzhao#



最后由 Ericzhao82 编辑于 2006-07-28 11:06,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-07-28 10:25 

注册: 2006-07-09 12:22
帖子: 1331
地址: 南京
送出感谢: 0 次
接收感谢: 1
这可能与软件关联有些瓜葛吧,具体不太清楚了。
升级失败后如果没法打开新得立软件包管理器,可以先修复一下
代码:
sudo apt-get install -f

然后打开新得立软件包管理器,搜索openoffice.org-help-en-us,标记以便删除;应用。
最后再来升级系统吧:)


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-07-28 10:40 

注册: 2006-07-05 16:47
帖子: 275
送出感谢: 0 次
接收感谢: 0 次
这个网站,对于北方网通简直是折磨……龟速。

老大,百分百因为属性依赖的损坏,一共15个,我用新利得过滤竟然搜索不到结果。都采了图片的,可惜没法上传,超时报错了。

openoffice.org-help-en-us,标记以便删除,这步我做了,没法删除。提示错误,无法删除。

咋办呀??/

都有采图……可惜。。唉!



引用:
ericzhao@Ubuntu-book:~$ sudo apt-get check
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
openoffice.org: 依赖: openoffice.org-core (> 2.0.2) 但是它还没有被安装
openoffice.org-base: 依赖: openoffice.org-core (> 2.0.2) 但是它还没有被安装
openoffice.org-calc: 依赖: openoffice.org-core (> 2.0.2) 但是它还没有被安装
openoffice.org-common: 依赖: openoffice.org-core (> 2.0.2) 但是它还没有被安装 或
openoffice.org-core-experimental (> 2.0.2) 但却无法安装它
openoffice.org-draw: 依赖: openoffice.org-core (> 2.0.2) 但是它还没有被安装
openoffice.org-evolution: 依赖: openoffice.org-core (> 2.0.2) 但是它还没有被安装
openoffice.org-gnome: 依赖: openoffice.org-core (> 2.0.3) 但是它还没有被安装
openoffice.org-gtk: 依赖: openoffice.org-core (> 2.0.3) 但是它还没有被安装
openoffice.org-help-zh-cn: 依赖: openoffice.org-core (>= 2.0.3) 但是它还没有被安装 或
language-support-zh 但是它还没有被安装
openoffice.org-impress: 依赖: openoffice.org-core (> 2.0.2) 但是它还没有被安装
openoffice.org-l10n-zh-cn: 依赖: openoffice.org-common (>= 2.0.3) 但是 2.0.2-2ubuntu12.1 已经安装了 或
language-support-zh 但是它还没有被安装
openoffice.org-l10n-zh-tw: 依赖: openoffice.org-common (>= 2.0.3) 但是 2.0.2-2ubuntu12.1 已经安装了 或
language-support-zh 但是它还没有被安装
openoffice.org-math: 依赖: openoffice.org-core (> 2.0.2) 但是它还没有被安装
openoffice.org-writer: 依赖: openoffice.org-core (> 2.0.2) 但是它还没有被安装
python-uno: 依赖: openoffice.org-core (> 2.0.2) 但是它还没有被安装


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-07-28 10:58 

注册: 2006-07-05 16:47
帖子: 275
送出感谢: 0 次
接收感谢: 0 次
和我想的一样

我的openoffice启动不起来了:(


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-07-28 11:05 

注册: 2006-07-09 12:22
帖子: 1331
地址: 南京
送出感谢: 0 次
接收感谢: 1
那就把openoffice.org-core给安上呗
或者试试重新安装openoffice.org


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-07-28 11:10 

注册: 2006-07-05 16:47
帖子: 275
送出感谢: 0 次
接收感谢: 0 次
don-quixote 写道:
那就把openoffice.org-core给安上呗
或者试试重新安装openoffice.org


安装core时的错误:

E: /var/cache/apt/archives/openoffice.org-calc_2.0.3-3dapper3_i386.deb: 正试图覆盖“/usr/lib/openoffice/help/en/scalc.idx/DICTIONARY”,它属于软件包 openoffice.org-help-en-us
E: /var/cache/apt/archives/openoffice.org-writer_2.0.3-3dapper3_i386.deb: 正试图覆盖“/usr/lib/openoffice/help/en/swriter.idx/DICTIONARY”,它属于软件包 openoffice.org-help-en-us
E: /var/cache/apt/archives/openoffice.org-draw_2.0.3-3dapper3_i386.deb: 正试图覆盖“/usr/lib/openoffice/help/en/sdraw.idx/DICTIONARY”,它属于软件包 openoffice.org-help-en-us
E: /var/cache/apt/archives/openoffice.org-impress_2.0.3-3dapper3_i386.deb: 正试图覆盖“/usr/lib/openoffice/help/en/simpress.idx/DICTIONARY”,它属于软件包 openoffice.org-help-en-us
E: /var/cache/apt/archives/openoffice.org-base_2.0.3-3dapper3_i386.deb: 正试图覆盖“/usr/lib/openoffice/help/en/sdatabase.idx/DICTIONARY”,它属于软件包 openoffice.org-help-en-us
E: /var/cache/apt/archives/openoffice.org-math_2.0.3-3dapper3_i386.deb: 正试图覆盖“/usr/lib/openoffice/help/en/smath.idx/DICTIONARY”,它属于软件包 openoffice.org-help-en-us
E: /var/cache/apt/archives/openoffice.org-common_2.0.3-3dapper3_all.deb: 软件包相互冲突 - 将不安装 openoffice.org-common
E: /var/cache/apt/archives/openoffice.org-core_2.0.3-3dapper3_i386.deb: 软件包相互冲突 - 将不安装 openoffice.org-core



当然也根本无法卸载重装openoffice

楼上老大,可有实践??
我正着急,谢谢


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-07-28 11:16 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
你到irc上看看有没有人,到上面去问问,freeflying,huahua等高手一般在irc上面.


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-07-28 11:23 

注册: 2006-07-09 12:22
帖子: 1331
地址: 南京
送出感谢: 0 次
接收感谢: 1
maosi我不是菜鸟一样,哈哈
openoffice.org-help-en-us,我不知道你这何删除不了,我今天升级时也出现了依赖它的错误升级信息,只删除了它就顺利升级了。
要是升级失败,定要运行一下sudo apt-get -f install的。
在新得立软件包中搜索openoffice.org-core,卸了(关联的程序一并删除),就可以重装了。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-07-28 11:38 
头像

注册: 2006-07-08 9:21
帖子: 1917
地址: University of Science and Technology Beijing
送出感谢: 1
接收感谢: 0 次
oo的问题吧。。


页首
 用户资料  
 
10 楼 
 文章标题 : 我的也是这问题!
帖子发表于 : 2006-07-28 11:41 
头像

注册: 2006-06-01 13:20
帖子: 56
地址: 山东济南
送出感谢: 0 次
接收感谢: 0 次
我的也是这个问题,没有办法,只有把openoffice删除了!现在不知道怎么看doc文档了。重装也出错。删除openoffice.org-core重装也是出错,搜索openoffice.org-help-en-us,点删除,然后Apply的时候,竟然自动把openoffice安装上了。大家不妨试一下!


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-07-28 12:26 

注册: 2006-07-05 16:47
帖子: 275
送出感谢: 0 次
接收感谢: 0 次
don-quixote 写道:
maosi我不是菜鸟一样,哈哈
openoffice.org-help-en-us,我不知道你这何删除不了,我今天升级时也出现了依赖它的错误升级信息,只删除了它就顺利升级了。
要是升级失败,定要运行一下sudo apt-get -f install的。
在新得立软件包中搜索openoffice.org-core,卸了(关联的程序一并删除),就可以重装了。


为什么删除不了??
喏,下面就是原因

引用:
ericzhao@Ubuntu-book:~$ sudo apt-get -f remove openoffice.org-help-en-us
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
language-support-en: 依赖: openoffice.org-help-en-us 但是它将不会被安装 或
openoffice.org2-help-en-us 但却无法安装它
openoffice.org: 依赖: openoffice.org-core (> 2.0.3) 但是它将不会被安装
依赖: openoffice.org-writer (> 2.0.3) 但是 2.0.2-2ubuntu12.1 正要被安装
依赖: openoffice.org-calc (> 2.0.3) 但是 2.0.2-2ubuntu12.1 正要被安装
依赖: openoffice.org-impress (> 2.0.3) 但是 2.0.2-2ubuntu12.1 正要被安装
依赖: openoffice.org-draw (> 2.0.3) 但是 2.0.2-2ubuntu12.1 正要被安装
依赖: openoffice.org-math (> 2.0.3) 但是 2.0.2-2ubuntu12.1 正要被安装
依赖: openoffice.org-base (> 2.0.3) 但是 2.0.2-2ubuntu12.1 正要被安装
openoffice.org-base: 依赖: openoffice.org-core (> 2.0.2) 但是它将不会被安装
openoffice.org-calc: 依赖: openoffice.org-core (> 2.0.2) 但是它将不会被安装
openoffice.org-common: 依赖: openoffice.org-core (> 2.0.2) 但是它将不会被安装 或
openoffice.org-core-experimental (> 2.0.2) 但却无法安装它
openoffice.org-draw: 依赖: openoffice.org-core (> 2.0.2) 但是它将不会被安装
openoffice.org-evolution: 依赖: openoffice.org-core (> 2.0.3) 但是它将不会被安装
openoffice.org-gnome: 依赖: openoffice.org-core (> 2.0.3) 但是它将不会被安装
openoffice.org-gtk: 依赖: openoffice.org-core (> 2.0.3) 但是它将不会被安装
openoffice.org-help-zh-cn: 依赖: openoffice.org-core (>= 2.0.3) 但是它将不会被安装 或
language-support-zh 但是它将不会被安装
openoffice.org-impress: 依赖: openoffice.org-core (> 2.0.2) 但是它将不会被安装
openoffice.org-l10n-zh-cn: 依赖: openoffice.org-common (>= 2.0.3) 但是 2.0.2-2ubuntu12.1 正 要被安装 或
language-support-zh 但是它将不会被安装
openoffice.org-l10n-zh-tw: 依赖: openoffice.org-common (>= 2.0.3) 但是 2.0.2-2ubuntu12.1 正 要被安装 或
language-support-zh 但是它将不会被安装
openoffice.org-math: 依赖: openoffice.org-core (> 2.0.2) 但是它将不会被安装
openoffice.org-writer: 依赖: openoffice.org-core (> 2.0.2) 但是它将不会被安装
python-uno: 依赖: openoffice.org-core (> 2.0.2) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
ericzhao@Ubuntu-book:~$


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-07-28 12:44 

注册: 2006-07-05 16:47
帖子: 275
送出感谢: 0 次
接收感谢: 0 次
555

谁来帮帮我呀,我要删除openoffice.org-help-en-us 也不下行,全部openoffice删除也不行

提示都在上面


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2006-07-28 13:13 
头像

注册: 2006-06-01 13:20
帖子: 56
地址: 山东济南
送出感谢: 0 次
接收感谢: 0 次
Ericzhao82 写道:
555

谁来帮帮我呀,我要删除openoffice.org-help-en-us 也不下行,全部openoffice删除也不行

提示都在上面

试试新利得怎么样?


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2006-07-28 13:20 

注册: 2006-07-05 16:47
帖子: 275
送出感谢: 0 次
接收感谢: 0 次
snoopy2556 写道:
Ericzhao82 写道:
555

谁来帮帮我呀,我要删除openoffice.org-help-en-us 也不下行,全部openoffice删除也不行

提示都在上面

试试新利得怎么样?


新利得也试过了,也是上面提示。

另外新利得只不过是apt的一个图形界面而已


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-08-23 9:03 
头像

注册: 2007-04-14 0:41
帖子: 146
地址: 武汉
送出感谢: 0 次
接收感谢: 0 次
试一试这个方法(在论坛里搜出来的)
在系统--系统管理--新立德软件包管理器, 搜索openoffice.org-core,和 openoffice.org-common, 标记删除, 然后再把openoffice的其他程序,比如数据库,字处理,等程序全部标记删除,为什么要先标记删除 前两个呢?因为你标记删除openoffice应用程序的时候,前两个程序因为依赖关系是要升级的,但是oenoffice.org-core 又不能升级到 dapper 那个版本,所以应当先把前两个程序标记删除掉,然后再删除openoffice的其他程序。 openoffice的组件全删除完了之后,重新安装openoffice就没有问题了。
由于几次出错,而且出错后安装不了共享,所以先安装共享,不更新openoffice.org,以免以后安装什么软件出错(菜鸟的方法)


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译