[问题]g++不能用

为当前最终发行版之前的所有版本提供支持
回复
winson
帖子: 48
注册时间: 2006-07-11 14:43
送出感谢: 0
接收感谢: 0
联系:

[问题]g++不能用

#1

帖子 winson » 2006-07-28 21:33

新立得软件包里显示gcc和g++都已经安装了
可是g++ *.cpp,gcc *.c都显示bash:g++ command not found
我装的是g++-4.0
如果写g++-4.0 *.cpp就照了
怎么回事
头像
madoldman
帖子: 599
注册时间: 2006-02-27 20:19
来自: works system
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 madoldman » 2006-07-29 17:38

sudo ln -sf /usr/bin/gcc-4.0 /usr/bin/gcc
sudo ln -sf /usr/bin/g++-4.0 /usr/bin/g++
你直接安装的gcc-4.0和g++-4.0,而不是安装gcc和g++这两个包,让它们自己去寻找相应的版本,因此在/usr/bin下面没有自动创建gcc和g++的链接,手动创建吧
东西路,南北走
十字路口人咬狗
拿起狗来打砖头
砖头咬了狗一口
图片
winson
帖子: 48
注册时间: 2006-07-11 14:43
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 winson » 2006-07-29 18:00

我接着又装了gcc和g++
会不会多余了
头像
madoldman
帖子: 599
注册时间: 2006-02-27 20:19
来自: works system
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 madoldman » 2006-07-29 18:03

不会的,gcc和g++实际上并不是真实的包,只是指向某一个版本吧,我觉得它的功能就是做个链接而已吧,直接安装gcc和g++会提示依赖gcc-4.0和g++-4.0然后就一块装上了,记得以前没有4.0版的时候,装这两个包会安装3.4版
东西路,南北走
十字路口人咬狗
拿起狗来打砖头
砖头咬了狗一口
图片
回复

回到 “老旧版本支持”