[问题]软件更新--清华源不兼容--依赖性问题

为当前最终发行版之前的所有版本提供支持
回复
jsleemz
帖子: 144
注册时间: 2006-07-27 15:50
送出感谢: 0
接收感谢: 0
联系:

[问题]软件更新--清华源不兼容--依赖性问题

#1

帖子 jsleemz » 2006-07-29 10:21

使用软件自动更新,但总有26个不能更新。
出现警告如下内容:
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... 2_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... 2_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/rest ... -3_all.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/rest ... 3_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/rest ... 4_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/rest ... 4_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... .1_all.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... .1_all.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... .1_all.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... .1_all.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb
404 Not Found
W: 未能取回 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb
404 Not Found
其他更新都能够自动完成的。请教是源的问题吗?
上次由 jsleemz 在 2006-07-30 7:55,总共编辑 1 次。
头像
oneleaf
论坛管理员
帖子: 10230
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 103 次

#2

帖子 oneleaf » 2006-07-29 10:33

同时多添加几个源就好了。cn99的有时同步不完整。
头像
drivel
帖子: 1917
注册时间: 2006-07-08 9:21
来自: University of Science and Technology Beijing
送出感谢: 1 次
接收感谢: 0
联系:

#3

帖子 drivel » 2006-07-29 11:49

最好加上官方的源。毕竟有个后备保证。。
jsleemz
帖子: 144
注册时间: 2006-07-27 15:50
送出感谢: 0
接收感谢: 0
联系:

更新成功

#4

帖子 jsleemz » 2006-07-29 15:50

增加了下面的源:
Mirror.vmmatrix.net 更新服务器(上海市电信,推荐电信网通用户使用。)还是有3个不能更新。再增加http://mirror.net9.org北京市清华大学 更新服务器(教育网,推荐校园网和网通用户使用。)的,运行 sudo apt-get dist-upgrade,居然还有37个要更新。
因我是广电的网络(铁通),故速度cn99的速度最快。
但现在我放了三个源,不知会不会有影响?

谢谢帮助!
头像
drivel
帖子: 1917
注册时间: 2006-07-08 9:21
来自: University of Science and Technology Beijing
送出感谢: 1 次
接收感谢: 0
联系:

Re: 更新成功

#5

帖子 drivel » 2006-07-29 16:20

jsleemz 写了:增加了下面的源:
Mirror.vmmatrix.net 更新服务器(上海市电信,推荐电信网通用户使用。)还是有3个不能更新。再增加http://mirror.net9.org北京市清华大学 更新服务器(教育网,推荐校园网和网通用户使用。)的,运行 sudo apt-get dist-upgrade,居然还有37个要更新。
因我是广电的网络(铁通),故速度cn99的速度最快。
但现在我放了三个源,不知会不会有影响?

谢谢帮助!
你放进去全世界的源也没事,就是查找更新的时候会很慢,建议添加一个国内比较全的,比如CN99,一个自己连接速度快的,一个官方的
jsleemz
帖子: 144
注册时间: 2006-07-27 15:50
送出感谢: 0
接收感谢: 0
联系:

清华源openoffice依赖性问题

#6

帖子 jsleemz » 2006-07-29 18:56

从http://mirror.net9.org北京市清华大学的源更新后openoffice版本由2.0.2-2升级到2.0.3-3,语言由zh更改为en-us时提示错误,(中文支持已删除,英文装不上),出现15个包损坏,提示依赖性问题,新立得检查无法恢复(apt-get -f install)修复依赖性(提示强制锁定)。现openoffice程序已打不开。

请教怎样解决啊?

另:Gnumeric电子表格要比openoffice的电子表与微软的兼容性要好,excel的函数在gnumeric中能直接显示结果,在openoffice中会显示错误(初步测试,发现对页间单元格引用方式上不兼容)。
jsleemz
帖子: 144
注册时间: 2006-07-27 15:50
送出感谢: 0
接收感谢: 0
联系:

升级错误提示

#7

帖子 jsleemz » 2006-07-30 10:12

升级后出现错误,在新立得中提示15个包损坏,由于依赖性原因,无法执行强制版本,在增加快速设置指南中的源后运行命令,结果如下:
sudo apt-get -qq -f dist-upgrade
(正在读取数据库 ... 系统当前总共安装有 84354 个文件和目录。)
正预备替换 openoffice.org-calc 2.0.2-2ubuntu12 (使用 .../openoffice.org-calc_2.0.3-3dapper3_i386.deb) ...
正在解压缩将用于更替的包文件 openoffice.org-calc ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-calc_2.0.3-3dapper3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/help/en/scalc.idx/DICTIONARY”,它属于软件包 openoffice.org-help-en-us
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
正预备替换 openoffice.org-writer 2.0.2-2ubuntu12 (使用 .../openoffice.org-writer_2.0.3-3dapper3_i386.deb) ...
正在解压缩将用于更替的包文件 openoffice.org-writer ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-writer_2.0.3-3dapper3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/help/en/swriter.idx/DICTIONARY”,它属于软件包 openoffice.org-help-en-us
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
正预备替换 openoffice.org-draw 2.0.2-2ubuntu12 (使用 .../openoffice.org-draw_2.0.3-3dapper3_i386.deb) ...
正在解压缩将用于更替的包文件 openoffice.org-draw ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-draw_2.0.3-3dapper3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/help/en/sdraw.idx/DICTIONARY”,它属于软件包 openoffice.org-help-en-us
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
正预备替换 openoffice.org-impress 2.0.2-2ubuntu12 (使用 .../openoffice.org-impress_2.0.3-3dapper3_i386.deb) ...
正在解压缩将用于更替的包文件 openoffice.org-impress ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-impress_2.0.3-3dapper3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/help/en/simpress.idx/DICTIONARY”,它属于软件包 openoffice.org-help-en-us
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
正预备替换 openoffice.org-math 2.0.2-2ubuntu12 (使用 .../openoffice.org-math_2.0.3-3dapper3_i386.deb) ...
正在解压缩将用于更替的包文件 openoffice.org-math ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-math_2.0.3-3dapper3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/help/en/smath.idx/DICTIONARY”,它属于软件包 openoffice.org-help-en-us
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
正预备替换 openoffice.org-base 2.0.2-2ubuntu12 (使用 .../openoffice.org-base_2.0.3-3dapper3_i386.deb) ...
正在解压缩将用于更替的包文件 openoffice.org-base ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-base_2.0.3-3dapper3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/help/en/sdatabase.idx/DICTIONARY”,它属于软件包 openoffice.org-help-en-us
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
dpkg:关于含有 openoffice.org-common 的 .../openoffice.org-common_2.0.3-3dapper3_all.deb:
openoffice.org-common 冲突于 openoffice.org-calc (<< 2.0.3)
openoffice.org-calc (版本为 2.0.2-2ubuntu12)现在 已安装完毕。
dpkg:处理 /var/cache/apt/archives/openoffice.org-common_2.0.3-3dapper3_all.deb (--unpack)时出错:
软件包相互冲突 - 将不安装 openoffice.org-common
dpkg:关于含有 openoffice.org-core 的 .../openoffice.org-core_2.0.3-3dapper3_i386.deb:
openoffice.org-core 冲突于 openoffice.org-calc (<< 2.0.3)
openoffice.org-calc (版本为 2.0.2-2ubuntu12)现在 已安装完毕。
dpkg:处理 /var/cache/apt/archives/openoffice.org-core_2.0.3-3dapper3_i386.deb (--unpack)时出错:
软件包相互冲突 - 将不安装 openoffice.org-core
在处理时有错误发生:
/var/cache/apt/archives/openoffice.org-calc_2.0.3-3dapper3_i386.deb
/var/cache/apt/archives/openoffice.org-writer_2.0.3-3dapper3_i386.deb
/var/cache/apt/archives/openoffice.org-draw_2.0.3-3dapper3_i386.deb
/var/cache/apt/archives/openoffice.org-impress_2.0.3-3dapper3_i386.deb
/var/cache/apt/archives/openoffice.org-math_2.0.3-3dapper3_i386.deb
/var/cache/apt/archives/openoffice.org-base_2.0.3-3dapper3_i386.deb
/var/cache/apt/archives/openoffice.org-common_2.0.3-3dapper3_all.deb
/var/cache/apt/archives/openoffice.org-core_2.0.3-3dapper3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

有解决的办法吗?
hbsld
帖子: 41
注册时间: 2006-06-27 22:36
送出感谢: 0
接收感谢: 0

#8

帖子 hbsld » 2006-07-30 13:25

我也遇到了同样的问题。

后来我把openoffice.org整个的删掉了,然后重装。
使用:
sudo apt-get install openoffice.org

可是,在应用程序菜单中根本无法启动openoffice.org,在终端中输入openoffice的话会出现错误:
fopen() failed.: No such file or directory
段错误

我在新立得里面看了看好像有一个openoffice.org-gcj的包最新都只能是2.0.2,不知道会不会是这个原因。
头像
JangMunho
帖子: 1347
注册时间: 2006-01-18 12:55
来自: 也许真的没有人理解
送出感谢: 0
接收感谢: 1 次

#9

帖子 JangMunho » 2006-07-30 16:50

哎呀,不至于的,去http://packages.ubuntu.com/ 搜索找不到的软件,下来后放到/var/cache/apt/archives/里面。

然后照常升级喽……
jsleemz
帖子: 144
注册时间: 2006-07-27 15:50
送出感谢: 0
接收感谢: 0
联系:

清华源是什么版本?

#10

帖子 jsleemz » 2006-07-30 19:15

多谢楼上的指导。
在http://packages.ubuntu.com/ 上搜索openoffice的版本全是2.0.2的,可是我在清华源上升级的是2.0.3,现在连新立得里也提示在修复损坏包之前无法执行其他操作,包括在终端里执行sudo apt-get dist-upgrade也会出现错误。
现在我重新按快速设置指南里的链接到“自定义产生若干源:http://www.ubuntulinux.nl/source-o-matic” 。按产生的源更改sources.list-- http://zh.archive.ubuntu.com,重新执行apt-get update后,在新立得中先过滤出有问题的损坏软件包,运行恢复操作(相当于-f install),又提示无法恢复,可是左下角状态里提示恢复成功,不管他,对标记的包执行强制版本到dapper,点应用后开始下载软件,目前正在进行中,可是速度慢得真是难以忍受。
在用快速设置指南中的源时,操作到执行强制版本--应用--时总出现错误,无法进行下去。
只有苦等了,明天上班去看看,实在不行再试试楼上的方法。

谢谢。
上次由 jsleemz 在 2006-07-31 7:17,总共编辑 1 次。
hbsld
帖子: 41
注册时间: 2006-06-27 22:36
送出感谢: 0
接收感谢: 0

#11

帖子 hbsld » 2006-07-31 2:20

我把openoffice.org完全卸载了,要怎样才能正确的把它安装回来。
我使用sudo apt-get install openoffice.org安装的都不成功啊。
jsleemz
帖子: 144
注册时间: 2006-07-27 15:50
送出感谢: 0
接收感谢: 0
联系:

成功修复

#12

帖子 jsleemz » 2006-07-31 7:11

用 http://zh.archive.ubuntu.com的源终于成功修复。

其实在http://wiki.ubuntu.org.cn/UbuntuManual中文参考手册中有详尽的说明,只是新手不知道到哪里去找资料,碰到问题除了搜索论坛、提问之外好象也无好的方法。

强烈推荐新手先学好中文参考手册再入手调整系统。

一起加油吧。
上次由 jsleemz 在 2006-07-31 7:18,总共编辑 1 次。
jsleemz
帖子: 144
注册时间: 2006-07-27 15:50
送出感谢: 0
接收感谢: 0
联系:

[建议]

#13

帖子 jsleemz » 2006-07-31 7:14

hbsld 写了:我把openoffice.org完全卸载了,要怎样才能正确的把它安装回来。
我使用sudo apt-get install openoffice.org安装的都不成功啊。
到openoffice官网上有中文安装详尽说明。
http://zh.openoffice.org/index_gb.html
hbsld
帖子: 41
注册时间: 2006-06-27 22:36
送出感谢: 0
接收感谢: 0

#14

帖子 hbsld » 2006-07-31 11:24

哈哈,我不向这么麻烦,我只想通过apt-get来安装。
hbsld
帖子: 41
注册时间: 2006-06-27 22:36
送出感谢: 0
接收感谢: 0

#15

帖子 hbsld » 2006-07-31 13:37

问题解决了。
使用:sudo apt-get remove --purge openoffice.org openoffice.org-core ...
然后再重新安装就可以了。
回复

回到 “老旧版本支持”