[问题]系统不让我删除scim ,不解?

为当前最终发行版之前的所有版本提供支持
回复
firefoxmmx
帖子: 407
注册时间: 2006-07-28 8:51
送出感谢: 0
接收感谢: 0
联系:

[问题]系统不让我删除scim ,不解?

#1

帖子 firefoxmmx » 2006-07-29 15:16

刚刚突然想删除scim ,然后,用fctix ,却发现,scim怎么都删不掉~~
报这个错~:

代码: 全选

root@dubuntu:/home/hooxin/Mydown# apt-get remove scim
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  openoffice.org-l10n-ja: 依赖: openoffice.org-common (>= 2.0.2) 但是它将不会被 安装 或
                                  language-support-ja 但是它将不会被安装
                          依赖: openoffice.org-common (< 2.0.3) 但是它将不会被安装 或
                                  language-support-ja 但是它将不会被安装
  openoffice.org-l10n-zh-cn: 依赖: openoffice.org-common (>= 2.0.2) 但是它将不会被安装 或
                                     language-support-zh 但是它将不会被安装
                             依赖: openoffice.org-common (< 2.0.3) 但是它将不会 被安装 或
                                     language-support-zh 但是它将不会被安装
  openoffice.org-l10n-zh-tw: 依赖: openoffice.org-common (>= 2.0.2) 但是它将不会被安装 或
                                     language-support-zh 但是它将不会被安装
                             依赖: openoffice.org-common (< 2.0.3) 但是它将不会 被安装 或
                                     language-support-zh 但是它将不会被安装
E: 无法安装的软件包

于是,我就加了, -f 这个选项,可是结果还是

代码: 全选

root@dubuntu:/home/hooxin/Mydown# apt-get -f remove scim
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  openoffice.org-l10n-ja: 依赖: openoffice.org-common (>= 2.0.2) 但是它将不会被 安装 或
                                  language-support-ja 但是它将不会被安装
                          依赖: openoffice.org-common (< 2.0.3) 但是它将不会被安装 或
                                  language-support-ja 但是它将不会被安装
  openoffice.org-l10n-zh-cn: 依赖: openoffice.org-common (>= 2.0.2) 但是它将不会被安装 或
                                     language-support-zh 但是它将不会被安装
                             依赖: openoffice.org-common (< 2.0.3) 但是它将不会 被安装 或
                                     language-support-zh 但是它将不会被安装
  openoffice.org-l10n-zh-tw: 依赖: openoffice.org-common (>= 2.0.2) 但是它将不会被安装 或
                                     language-support-zh 但是它将不会被安装
                             依赖: openoffice.org-common (< 2.0.3) 但是它将不会 被安装 或
                                     language-support-zh 但是它将不会被安装
E: 无法安装的软件包

无语中, 不知道要怎么才可以把这个scim删除掉~

再问个问题~ 就是好像在ubuntu里没有 alternatives 工具(但是,在/etc里又有他的文件夹),在哪里可以安装或者下载 ,源里没有~??
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-07-29 16:16

OOo,你的是不是自己下载安装的版本啊。
● 鸣学
头像
madoldman
帖子: 599
注册时间: 2006-02-27 20:19
来自: works system
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 madoldman » 2006-07-29 18:07

是你安装的时候不满足依赖停止了,不记得命令是什么了,记得我遇到这种问题,开一下新立德,它会提示你有不满足依赖的包,是否丢弃,然后点一下丢弃就好了,唉…哪位知道命令是什么来着??
东西路,南北走
十字路口人咬狗
拿起狗来打砖头
砖头咬了狗一口
图片
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 zhan » 2006-07-29 18:10

apt-get -f install

sudo update-alternatives --config ***
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
firefoxmmx
帖子: 407
注册时间: 2006-07-28 8:51
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 firefoxmmx » 2006-07-30 9:41

请楼上的兄弟,说具体一点~~
scim不是我自己下载安装的,我是用apt-get install scim 后,再去语言菜单 ,把中文选上了,然后, 我要删除的时候,就删不掉了。还有就是用新立得删除的时候, 它提示我说,有3个毁坏的包,必须要在修复后,才可以执行删除。
可是,我不知道怎么修复呀~?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2006-07-30 18:33

新利得里面。右边栏里面找broken的项目啊。把破损的包先卸载了。
● 鸣学
firefoxmmx
帖子: 407
注册时间: 2006-07-28 8:51
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 firefoxmmx » 2006-07-31 0:16

好,我会去试试 ~
回复

回到 “老旧版本支持”