请问ubuntu下如何安装opera9.0,下载了.tar.gz文件后?

为当前最终发行版之前的所有版本提供支持
回复
zouxiz
帖子: 40
注册时间: 2006-05-22 15:56
送出感谢: 0
接收感谢: 0
联系:

请问ubuntu下如何安装opera9.0,下载了.tar.gz文件后?

#1

帖子 zouxiz » 2006-07-31 13:51

从外面网站下载的opera9.0的.tar.gz二进制软件包。
解压后出现bin等文件夹和install.sh,opera.sh两个sh文件(是叫sh文件么?感觉跟安装有关)等文件,但是./configure不行,make不行,make install更不行。
不知道怎么安装了。
哪位仁兄给帮个忙指点指点!谢谢!
lypat2008
帖子: 203
注册时间: 2006-03-05 10:29
送出感谢: 1 次
接收感谢: 0

#2

帖子 lypat2008 » 2006-07-31 16:43

你上opera.com下载ubuntu的deb包
sudo dpkg -i opera.....
就行了.
另:要用tar,gz的话,看看里面的readme,或Install文件.sh文件是直接执行的, ./软件名.sh
头像
madoldman
帖子: 599
注册时间: 2006-02-27 20:19
来自: works system
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 madoldman » 2006-07-31 18:38

运行一下install.sh试试,建议还是用deb包
东西路,南北走
十字路口人咬狗
拿起狗来打砖头
砖头咬了狗一口
图片
头像
JangMunho
帖子: 1347
注册时间: 2006-01-18 12:55
来自: 也许真的没有人理解
送出感谢: 0
接收感谢: 1 次

#4

帖子 JangMunho » 2006-07-31 18:57

因为有install.sh
所以直接sudo ./install.sh 就行了。
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#5

帖子 lyreopera » 2006-07-31 19:50

e……这个源里面没有么?
……
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2006-07-31 21:30

lz是windows习惯,到处找软件而已。 :lol:
● 鸣学
头像
sigma
帖子: 439
注册时间: 2006-06-01 22:45
来自: Fujian
送出感谢: 0
接收感谢: 0

#7

帖子 sigma » 2006-07-31 21:57

源里就有opera了
被时间羁绊,被邪恶包围……空气稀薄
zouxiz
帖子: 40
注册时间: 2006-05-22 15:56
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 zouxiz » 2006-08-01 13:47

lypat2008 写了:你上opera.com下载ubuntu的deb包
sudo dpkg -i opera.....
就行了.
另:要用tar,gz的话,看看里面的readme,或Install文件.sh文件是直接执行的, ./软件名.sh
谢谢了!
eexpress 写了:lz是windows习惯,到处找软件而已。 :lol:
源里面有,不过没有9.0,呵呵!
opoppopopp
帖子: 17
注册时间: 2006-07-27 14:10
送出感谢: 0
接收感谢: 0

#9

帖子 opoppopopp » 2006-08-01 14:00

eexpress 写了:lz是windows习惯,到处找软件而已。 :lol:
一方面是这样。另一方面,到官方去下载软件——这是很好的习惯。
dspyu
帖子: 13
注册时间: 2008-10-18 22:20
送出感谢: 0
接收感谢: 0

Re: 请问ubuntu下如何安装opera9.0,下载了.tar.gz文件后?

#10

帖子 dspyu » 2008-10-25 16:13

sudo ./install.sh
头像
雨中漫步
帖子: 27
注册时间: 2008-10-21 23:48
送出感谢: 0
接收感谢: 0

Re: 请问ubuntu下如何安装opera9.0,下载了.tar.gz文件后?

#11

帖子 雨中漫步 » 2008-10-30 21:59

请教一下关于tar.gz的安装方式:
不知道我怎么安装不成功:
请高手分析“
administrator@administrator-desktop:~$ sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.1.1) 但是它将不会被安装
E: 无法安装的软件包
administrator@administrator-desktop:~$
回复

回到 “老旧版本支持”