当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [分享] Thinkpad 600E上安装Ubuntu 6.06的设置
帖子发表于 : 2006-08-01 11:53 

注册: 2006-07-20 16:25
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
600E上安装Ubuntu 6.06的设置,请参考:
http://jonathan.michahaesler.ch/misc/tp600e_en.html


Ubuntu 6.06 on the Thinkpad 600E
Overview
Introduction
1. Before installing: Hibernation Partition
2. What you may have to or want to do (optional)
3. BIOS
4. Speed up Ubuntu
5. Get PCMCIA to work
6. Sound
7. Mwave Modem
8. If this didn't work for you but you know how to (get it to work)
9. Links
Introduction
Well, trying to get Ubuntu or some derivate on your good old 600E? If you have a TP 600, these directions may not work, so please try http://ubuntuforums.org/showthread.php?t=188736 and search the forums for it. And don't blame me if it doesn't work...

For Ubuntu 5.10 try http://www.ubuntuforums.org/showthread.php?t=94414.

1. Before installing: Hibernation Partition
Suspend and hibernate may not work. Anyway, you will need a hibernation partition (FAT16) with a hibernation file on it... see http://pepper.linuxfocus.org/~guido/gentoo-tp600e/ for more infos. Even though this page is quite old you create the hibernation partition like you did back then. Now get the floppy images from there and prepare your floppies.

Note: Always substitute c: or C with your hibernation partition drive letter.

Boot your computer using the DOS 6.22 floppy.
First create the primary DOS partition using DOS-fdisk (Linux-fdisk doesn't seem to work". It has to be slightly (5-10MB) bigger than your RAM. Then do type the following commands format c: /s
c:



Now insert the floppy containing the Thinkpad 600E tools. copy a:\tp600e c:
ps2 HFILE C



While PS2 is running re-insert the DOS floppy.
When PS2 has finished running, turn your PC off and restart the computer (without floppy).
Now install your system

Hibernation should now work. It still doesn't for me. I'll have to check this to find out. If you know, please write me an e-mail explaining how you set it up so that others can profit...

2. What you may have to or want to do (optional)
1) You maybe want to do all this using ssh. (If you don't know what ssh is then you don't need it.) You'll need to install the ssh-server:

sudo apt-get install openssh-server ssh


2) Maybe you'll need to disable IPv6 if your network is much too slow (and subsequently doesn't support it:

Edit /etc/modprobe.d/aliases. Change alias net-pf-10 ipv6

to alias net-pf-10 off

Have fun...

3. BIOS
Well, to get sound (and some other things) to work your first step will be to reinitialize the BIOS:

Disable Quickboot in the BIOS (Press F1 to enter BIOS setup on boot)
You may also have to select initialise (still in the BIOS). I stongly recommend you to do it for maybe sound won't work otherwise.
4. Speed up Ubuntu
There are several things you can do to achieve this:

1) Select 16bit colours instead of 24bit

In /etc/X11/xorg.conf, change DefaultDepth 24

to DefaultDepth 16


2) Now, to install a i686 kernel

Select the other installation repositories in Synaptic
Fire up a terminal and: sudo apt-get install linux-686 linux-restricted-modules-686


5. Get PCMCIA to work
This is done in the GRUB config file because these are parameters the kernel needs on boot.

Add the following to your kernel options in /boot/grub/menu.lst: acpi=force pci=noacpi


It seems that to get wlan (wireless) cards to see the router you need to totally disable acpi: acpi=off pci=noacpi


For 1024x768px on statup, add: (I know, this isn't PCMCIA, but it's done in GRUB config) vga=0x317


6. Sound
Ok, these are the instuctions:

Add these lines to /etc/modules: sound
ad1848
uart401
snd-cs4236


Blacklist the incorrect sound card in /etc/modprobe.d/blacklist. Add these lines as written below - with the xx's: blacklist snd-cs46xx
blacklist cs46xx


Add the following lines into /etc/modprobe.d/alsa-base: alias char-major-116 snd
alias char-major-14 soundcore
alias snd-card-0 snd-cs4236
options snd-cs4236 isapnp=0 cport=0x538 port=0x530 sb_port=0x220 fm_port=0x388 irq=5 dma1=1 dma2=0
alias sound-slot-0 snd-card-0
alias sound-slot-1 snd-card-1

alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

options snd cards_limit=1


NOTE: When copying and pasting the above, make sure that the line starting with 'options...' is one line ending with '...dma2=0'.

Reboot and enjoy
Note: This didn't work one 600e, I had to reinitialise my BIOS... So if it doesn't work reinitialise your BIOS, it should work. Otherwise check whether your sound card works at all (using Win9x).

7. Mwave Modem
I don't know whether there is a deb-package. So you have two possibilities here.

1) Either use my package:

Download here
Install it: sudo dpkg -i mwavem*


Continue with 3 (configuring the modem)
2) Or build it yourself. Here are the instructions:

Get the mwavem source from http://sourceforge.net/projects/acpmodem
Install gcc and make: sudo apt-get install binutils cpp cpp-4.0 gcc gcc-4.0 make gobjc setserial


Untar the source, open a terminal and cd to the directory where it is.
Compile it using: ./configure
make


You can now either build a deb package:
Install checkinstall:
Download the deb package from http://checkinstall.izto.org/download.php
To install the package, cd to the directory where it's stored and sudo dpkg -i checkinstall*


Now build the source: sudo checkinstall -D make install


Or install it without building a package: sudo make install


3) Configuring the modem:

Loading the module is a bit tricky. I haven't managed yet to get it to work, but this is what I've done so far:
Add these lines to /etc/modprobe.d/options: #mwave modem module options
options mwave mwave_3780i_irq=10 mwave_3780i_io=0x0130 mwave_uart_irq=3 mwave_uart_io=0x2f8

NOTE: When copying and pasting the above, make sure that the line starting with 'options...' is one line ending with '...mwave_uart_io=0x2f8'.

Add these lines to /etc/pcmcia/config.opts: #PCMCIA IRQ conflicts with the modem without this
exclude irq 3
exclude irq 10


Add the following line to /etc/modules: mwave


Now edit /usr/local/etc/mwavem.conf. Change DEVICE=/dev/modems/mwave

to DEVICE=/dev/mwave

Also adapt it to your country. For example for Switzerland: COUNTRY=29


You'll now need to reboot to get the modem driver loaded correctly. Modprobe doesn't work here.

Configure the serial port and start the mwavem device software: sudo mwavem
sudo setserial /dev/ttyS1 autoconfig

NOTE: You have to start mwavem BEFORE your execute the setserial command. Otherwise, it won't work.

Now let's see if the modem can be configured: wvdialconf /etc/wvdial.conf


Go to System > Administration > Networking
Open the properties dialog of the modem connection
Select /dev/mwave as the modem port
Install a dial-up software: sudo apt-get install kppp


Now start kppp, choose configure, then modem and select /dev/ttyS1 as the modem port.
Configure all you need (like the provider), save your settings and close the configuration dialog.
You are now able to browse the web through your built-in Mwave ACP Modem. Congratulations!

The configuration part of this Modem howto was taken from the gentoo forum: http://forums.gentoo.org/viewtopic-t-26 ... mwave.html and slightly adapted to Ubuntu 6.06. Have fun...

8. If this didn't work for you but you know how to
If it doesn't work for you don't clame me but write me an e-mail containing your corrections so that others can profit...

9. Links
The Ubuntu Laptop Testing Team has a page on the 600E: https://wiki.ubuntu.com/LaptopTestingTeam/Thinkpad600E

There also is a script for enabling sound on the 600E. I haven't tested it yet but I can tell from the code it looks excellent: http://ubuntuforums.org/showpost.php?p=974031

Source of the above (it's from me, actually): http://www.ubuntuforums.org/showthread.php?t=192590

And, of course, don't forget to look at Tuxmobil and Linux-on-Laptops. Also, read the Thinkwiki pages on the 600E: http://www.thinkwiki.org/wiki/Category:600E


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-08-02 8:43 

注册: 2006-07-20 16:25
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
昨天我参照以下设置,还是不成功,请问哪位大侠成功设置600E的声卡的???

6. Sound
Ok, these are the instuctions:

Add these lines to /etc/modules:
代码:
sound
ad1848
uart401
snd-cs4236



Blacklist the incorrect sound card in /etc/modprobe.d/blacklist. Add these lines as written below - with the xx's:
代码:
blacklist snd-cs46xx
blacklist cs46xx



Add the following lines into /etc/modprobe.d/alsa-base:
代码:
alias char-major-116 snd
alias char-major-14 soundcore
alias snd-card-0 snd-cs4236
options snd-cs4236 isapnp=0 cport=0x538 port=0x530 sb_port=0x220 fm_port=0x388 irq=5 dma1=1 dma2=0
alias sound-slot-0 snd-card-0
alias sound-slot-1 snd-card-1

alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

options snd cards_limit=1



NOTE: When copying and pasting the above, make sure that the line starting with 'options...' is one line ending with '...dma2=0'.

Reboot and enjoy
Note: This didn't work one 600e, I had to reinitialise my BIOS... So if it doesn't work reinitialise your BIOS, it should work. Otherwise check whether your sound card works at all (using Win9x).


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译