当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 编译内核出现问题,大家帮我看下
帖子发表于 : 2006-08-05 15:43 

注册: 2006-07-26 11:46
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
执行make xconfig 时报错


scripts/kconfig/mconf.c: 在函数 ‘exec_conf’ 中:
scripts/kconfig/mconf.c:488: 错误: ‘EINTR’ 未声明 (在此函数内第一次使用)
scripts/kconfig/mconf.c:488: 错误: (即使在一个函数内多次出现,每个未声明的标识 符在其
scripts/kconfig/mconf.c:488: 错误: 所在的函数内只报告一次。)
scripts/kconfig/mconf.c:488: 错误: ‘EAGAIN’ 未声明 (在此函数内第一次使用)
make[1]: *** [scripts/kconfig/mconf.o] 错误 1


我在/usr/include下修改了链接如下
ln -s /usr/src/linux/include/asm-i386 asm
ln -s /usr/src/linux/include/linux linux
ln -s /usr/src/linux/include/scsi scsi


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-08-05 22:59 
头像

注册: 2005-08-29 14:49
帖子: 1119
地址: 杭州
送出感谢: 0 次
接收感谢: 3
什么都不用链接都不用建

进入 内核源码 目录

cd /usr/src/linux

make menuconfig (先试试这个)

make # 编译,连接

make modules_install # 安装内核模块

make install # 安装内核


_________________
用心×恒 | 豆瓣 | 门户 | Blog


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-08-08 9:29 

注册: 2006-05-25 20:18
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
我是make: command not found 郁闷了 是不是什么东西没装


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-08-08 18:23 
头像

注册: 2005-08-29 14:49
帖子: 1119
地址: 杭州
送出感谢: 0 次
接收感谢: 3
build-essential

编译所需的基本包没装吧


_________________
用心×恒 | 豆瓣 | 门户 | Blog


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译