我想自己编译安装Rhythmbox0.9.5,configure时发现下面错误,什么意思?

为当前最终发行版之前的所有版本提供支持
回复
linuxadmin
帖子: 33
注册时间: 2006-07-22 17:37
送出感谢: 0
接收感谢: 0

我想自己编译安装Rhythmbox0.9.5,configure时发现下面错误,什么意思?

#1

帖子 linuxadmin » 2006-08-06 16:07

checking for RB_CLIENT... configure: error: Package requirements (gnome-vfs-2.0 >= 2.7.4) were not met:

No package 'gnome-vfs-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables RB_CLIENT_CFLAGS
and RB_CLIENT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

其实我的系统里面已经有这个文件夹了 /etc/gnome-vfs-2.0 这里
头像
leal
帖子: 1119
注册时间: 2005-08-29 14:49
来自: 杭州
送出感谢: 0
接收感谢: 3 次
联系:

#2

帖子 leal » 2006-08-06 16:11

gnome-vfs-2.0

没装
用心×恒 | 豆瓣 | 门户 | Blog
pipago
帖子: 131
注册时间: 2006-07-14 21:04
送出感谢: 0
接收感谢: 0

Re: 我想自己编译安装Rhythmbox0.9.5,configure时发现下面错误,什么意思?

#3

帖子 pipago » 2006-08-06 19:59

linuxadmin 写了:checking for RB_CLIENT... configure: error: Package requirements (gnome-vfs-2.0 >= 2.7.4) were not met:

No package 'gnome-vfs-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables RB_CLIENT_CFLAGS
and RB_CLIENT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

其实我的系统里面已经有这个文件夹了 /etc/gnome-vfs-2.0 这里
我也遇到了同样的问题,关键是由于缺少编译库造成的。
有些文件虽然你自己去看的时候,发现已经安装了。但是编译新版本的程序通常需要更高的版本,这个时候你就要把那些debug和develop版本也装上去,还有建议多装几个版本(不管高低)的gcc。
我就是这样成功地编译了Rhythmbox0.9.5。
头像
ttand
帖子: 1743
注册时间: 2005-08-22 14:05
来自: 离开北京
送出感谢: 1 次
接收感谢: 3 次

#4

帖子 ttand » 2006-10-06 10:31

是gnome-vfs版本不够 高
回复

回到 “老旧版本支持”